dropbear: update version to 2015.71

Update dropbear to version 2015.71, released on 3 Dec 2015.
Refresh patches.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>

SVN-Revision: 48243
This commit is contained in:
Felix Fietkau 2016-01-15 11:24:09 +00:00
parent 708bbe9382
commit 64c23711ea
5 changed files with 10 additions and 10 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006-2014 OpenWrt.org # Copyright (C) 2006-2016 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=dropbear PKG_NAME:=dropbear
PKG_VERSION:=2015.68 PKG_VERSION:=2015.71
PKG_RELEASE:=3 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \ PKG_SOURCE_URL:= \
http://matt.ucc.asn.au/dropbear/releases/ \ http://matt.ucc.asn.au/dropbear/releases/ \
https://dropbear.nl/mirror/releases/ https://dropbear.nl/mirror/releases/
PKG_MD5SUM:=7664ac10f7cc2301c530eb80c756fc5d PKG_MD5SUM:=2ccc0a2f3e37ca221db12c5af6a88137
PKG_LICENSE:=MIT PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE

View File

@ -70,7 +70,7 @@
/* The MOTD file path */ /* The MOTD file path */
#ifndef MOTD_FILENAME #ifndef MOTD_FILENAME
@@ -231,7 +231,7 @@ Homedir is prepended unless path begins @@ -237,7 +237,7 @@ Homedir is prepended unless path begins
* note that it will be provided for all "hidden" client-interactive * note that it will be provided for all "hidden" client-interactive
* style prompts - if you want something more sophisticated, use * style prompts - if you want something more sophisticated, use
* SSH_ASKPASS instead. Comment out this var to remove this functionality.*/ * SSH_ASKPASS instead. Comment out this var to remove this functionality.*/

View File

@ -1,6 +1,6 @@
--- a/cli-runopts.c --- a/cli-runopts.c
+++ b/cli-runopts.c +++ b/cli-runopts.c
@@ -315,6 +315,10 @@ void cli_getopts(int argc, char ** argv) @@ -284,6 +284,10 @@ void cli_getopts(int argc, char ** argv)
debug_trace = 1; debug_trace = 1;
break; break;
#endif #endif
@ -11,7 +11,7 @@
case 'F': case 'F':
case 'e': case 'e':
#ifndef ENABLE_USER_ALGO_LIST #ifndef ENABLE_USER_ALGO_LIST
@@ -332,7 +336,6 @@ void cli_getopts(int argc, char ** argv) @@ -301,7 +305,6 @@ void cli_getopts(int argc, char ** argv)
print_version(); print_version();
exit(EXIT_SUCCESS); exit(EXIT_SUCCESS);
break; break;

View File

@ -1,6 +1,6 @@
--- a/options.h --- a/options.h
+++ b/options.h +++ b/options.h
@@ -341,7 +341,7 @@ be overridden at runtime with -I. 0 disa @@ -347,7 +347,7 @@ be overridden at runtime with -I. 0 disa
#define DEFAULT_IDLE_TIMEOUT 0 #define DEFAULT_IDLE_TIMEOUT 0
/* The default path. This will often get replaced by the shell */ /* The default path. This will often get replaced by the shell */

View File

@ -1,6 +1,6 @@
--- a/svr-runopts.c --- a/svr-runopts.c
+++ b/svr-runopts.c +++ b/svr-runopts.c
@@ -475,6 +475,7 @@ void load_all_hostkeys() { @@ -488,6 +488,7 @@ void load_all_hostkeys() {
m_free(hostkey_file); m_free(hostkey_file);
} }
@ -8,7 +8,7 @@
#ifdef DROPBEAR_RSA #ifdef DROPBEAR_RSA
loadhostkey(RSA_PRIV_FILENAME, 0); loadhostkey(RSA_PRIV_FILENAME, 0);
#endif #endif
@@ -486,6 +487,7 @@ void load_all_hostkeys() { @@ -499,6 +500,7 @@ void load_all_hostkeys() {
#ifdef DROPBEAR_ECDSA #ifdef DROPBEAR_ECDSA
loadhostkey(ECDSA_PRIV_FILENAME, 0); loadhostkey(ECDSA_PRIV_FILENAME, 0);
#endif #endif