ipq806x: 6.1: refresh kernel patches

Refresh ipq806x kernel patches with make target/linux/refresh.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
Christian Marangi 2023-05-22 18:12:08 +02:00
parent eb69d7a4ff
commit 64c204c586
No known key found for this signature in database
GPG Key ID: AC001D09ADBFEAD7
22 changed files with 55 additions and 97 deletions

View File

@ -19,11 +19,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
arch/arm/mach-qcom/Kconfig | 13 +++++++++++++ arch/arm/mach-qcom/Kconfig | 13 +++++++++++++
2 files changed, 15 insertions(+), 1 deletion(-) 2 files changed, 15 insertions(+), 1 deletion(-)
diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
index 1af63e17b4ad..0818d35973ad 100644
--- a/arch/arm/Kconfig --- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig +++ b/arch/arm/Kconfig
@@ -282,6 +282,7 @@ config PHYS_OFFSET @@ -283,6 +283,7 @@ config PHYS_OFFSET
default 0x30000000 if ARCH_S3C24XX default 0x30000000 if ARCH_S3C24XX
default 0xa0000000 if ARCH_IOP32X || ARCH_PXA default 0xa0000000 if ARCH_IOP32X || ARCH_PXA
default 0xc0000000 if ARCH_EP93XX || ARCH_SA1100 default 0xc0000000 if ARCH_EP93XX || ARCH_SA1100
@ -31,7 +29,7 @@ index 1af63e17b4ad..0818d35973ad 100644
default 0 default 0
help help
Please provide the physical address corresponding to the Please provide the physical address corresponding to the
@@ -1701,7 +1702,7 @@ config CRASH_DUMP @@ -1702,7 +1703,7 @@ config CRASH_DUMP
config AUTO_ZRELADDR config AUTO_ZRELADDR
bool "Auto calculation of the decompressed kernel image address" if !ARCH_MULTIPLATFORM bool "Auto calculation of the decompressed kernel image address" if !ARCH_MULTIPLATFORM
@ -40,8 +38,6 @@ index 1af63e17b4ad..0818d35973ad 100644
help help
ZRELADDR is the physical address where the decompressed kernel ZRELADDR is the physical address where the decompressed kernel
image will be placed. If AUTO_ZRELADDR is selected, the address image will be placed. If AUTO_ZRELADDR is selected, the address
diff --git a/arch/arm/mach-qcom/Kconfig b/arch/arm/mach-qcom/Kconfig
index 12a812e61c16..b11b6e391ff0 100644
--- a/arch/arm/mach-qcom/Kconfig --- a/arch/arm/mach-qcom/Kconfig
+++ b/arch/arm/mach-qcom/Kconfig +++ b/arch/arm/mach-qcom/Kconfig
@@ -46,4 +46,17 @@ config ARCH_MDM9615 @@ -46,4 +46,17 @@ config ARCH_MDM9615
@ -62,6 +58,3 @@ index 12a812e61c16..b11b6e391ff0 100644
+ disable AUTO_ZRELADDR. + disable AUTO_ZRELADDR.
+ +
endif endif
--
2.37.2

View File

@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
--- a/arch/arm/Kconfig --- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig +++ b/arch/arm/Kconfig
@@ -1727,6 +1727,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN @@ -1586,6 +1586,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
The command-line arguments provided by the boot loader will be The command-line arguments provided by the boot loader will be
appended to the the device tree bootargs property. appended to the the device tree bootargs property.
@ -248,7 +248,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
} }
--- a/init/main.c --- a/init/main.c
+++ b/init/main.c +++ b/init/main.c
@@ -113,6 +113,10 @@ @@ -114,6 +114,10 @@
#include <kunit/test.h> #include <kunit/test.h>
@ -259,7 +259,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
static int kernel_init(void *); static int kernel_init(void *);
extern void init_IRQ(void); extern void init_IRQ(void);
@@ -992,6 +996,18 @@ asmlinkage __visible void __init __no_sa @@ -994,6 +998,18 @@ asmlinkage __visible void __init __no_sa
pr_notice("Kernel command line: %s\n", saved_command_line); pr_notice("Kernel command line: %s\n", saved_command_line);
/* parameters may set static keys */ /* parameters may set static keys */
jump_label_init(); jump_label_init();

View File

@ -29,7 +29,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
cxo_board: cxo_board { cxo_board: cxo_board {
compatible = "fixed-clock"; compatible = "fixed-clock";
#clock-cells = <0>; #clock-cells = <0>;
@@ -490,6 +490,17 @@ @@ -575,15 +581,30 @@
clocks = <&gcc PLL8_VOTE>, <&pxo_board>; clocks = <&gcc PLL8_VOTE>, <&pxo_board>;
clock-names = "pll8_vote", "pxo"; clock-names = "pll8_vote", "pxo";
clock-output-names = "acpu_l2_aux"; clock-output-names = "acpu_l2_aux";
@ -47,8 +47,6 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
}; };
acc0: clock-controller@2088000 { acc0: clock-controller@2088000 {
@@ -503,17 +509,25 @@
acc0: clock-controller@2088000 {
compatible = "qcom,kpss-acc-v1"; compatible = "qcom,kpss-acc-v1";
reg = <0x02088000 0x1000>, <0x02008000 0x1000>; reg = <0x02088000 0x1000>, <0x02008000 0x1000>;
+ clock-output-names = "acpu0_aux"; + clock-output-names = "acpu0_aux";
@ -63,7 +61,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
reg = <0x02089000 0x1000>, <0x02009000 0x1000>; reg = <0x02089000 0x1000>, <0x02009000 0x1000>;
regulator; regulator;
}; };
@@ -591,14 +612,24 @@
acc1: clock-controller@2098000 { acc1: clock-controller@2098000 {
compatible = "qcom,kpss-acc-v1"; compatible = "qcom,kpss-acc-v1";
reg = <0x02098000 0x1000>, <0x02008000 0x1000>; reg = <0x02098000 0x1000>, <0x02008000 0x1000>;
@ -73,10 +71,6 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
+ #clock-cells = <0>; + #clock-cells = <0>;
}; };
saw1: regulator@2099000 {
@@ -531,11 +545,17 @@
};
saw1: regulator@2099000 { saw1: regulator@2099000 {
- compatible = "qcom,saw2"; - compatible = "qcom,saw2";
+ compatible = "qcom,saw2", "qcom,apq8064-saw2-v1.1-cpu", "syscon"; + compatible = "qcom,saw2", "qcom,apq8064-saw2-v1.1-cpu", "syscon";

View File

@ -127,7 +127,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
+ }; + };
+ +
thermal-zones { thermal-zones {
tsens_tz_sensor0 { sensor0-thermal {
polling-delay-passive = <0>; polling-delay-passive = <0>;
--- a/arch/arm/boot/dts/qcom-ipq8065.dtsi --- a/arch/arm/boot/dts/qcom-ipq8065.dtsi
+++ b/arch/arm/boot/dts/qcom-ipq8065.dtsi +++ b/arch/arm/boot/dts/qcom-ipq8065.dtsi

View File

@ -12,7 +12,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
--- a/arch/arm/boot/dts/qcom-ipq8064.dtsi --- a/arch/arm/boot/dts/qcom-ipq8064.dtsi
+++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi +++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi
@@ -559,12 +559,9 @@ @@ -599,12 +599,9 @@
}; };
nand_pins: nand_pins { nand_pins: nand_pins {

View File

@ -15,7 +15,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
--- a/arch/arm/boot/dts/qcom-ipq8064-rb3011.dts --- a/arch/arm/boot/dts/qcom-ipq8064-rb3011.dts
+++ b/arch/arm/boot/dts/qcom-ipq8064-rb3011.dts +++ b/arch/arm/boot/dts/qcom-ipq8064-rb3011.dts
@@ -24,73 +24,6 @@ @@ -25,73 +25,6 @@
device_type = "memory"; device_type = "memory";
}; };
@ -89,7 +89,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
mdio1: mdio-1 { mdio1: mdio-1 {
status = "okay"; status = "okay";
compatible = "virtual,mdio-gpio"; compatible = "virtual,mdio-gpio";
@@ -220,6 +153,73 @@ @@ -222,6 +155,73 @@
status = "okay"; status = "okay";
}; };
@ -165,8 +165,8 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
--- a/arch/arm/boot/dts/qcom-ipq8064.dtsi --- a/arch/arm/boot/dts/qcom-ipq8064.dtsi
+++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi +++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi
@@ -1446,6 +1446,20 @@ @@ -476,6 +476,20 @@
}; snps,blen = <16 0 0 0 0 0 0>;
}; };
+ mdio0: mdio@37000000 { + mdio0: mdio@37000000 {

View File

@ -16,7 +16,7 @@ Acked-by: Thara Gopinath <thara.gopinath@linaro.org>
--- a/drivers/thermal/qcom/tsens.c --- a/drivers/thermal/qcom/tsens.c
+++ b/drivers/thermal/qcom/tsens.c +++ b/drivers/thermal/qcom/tsens.c
@@ -917,8 +917,6 @@ int __init init_common(struct tsens_priv @@ -918,8 +918,6 @@ int __init init_common(struct tsens_priv
if (tsens_version(priv) >= VER_0_1) if (tsens_version(priv) >= VER_0_1)
tsens_enable_irq(priv); tsens_enable_irq(priv);
@ -25,7 +25,7 @@ Acked-by: Thara Gopinath <thara.gopinath@linaro.org>
err_put_device: err_put_device:
put_device(&op->dev); put_device(&op->dev);
return ret; return ret;
@@ -1163,7 +1161,12 @@ static int tsens_probe(struct platform_d @@ -1156,7 +1154,12 @@ static int tsens_probe(struct platform_d
} }
} }

View File

@ -17,7 +17,7 @@ Reviewed-by: Thara Gopinath <thara.gopinath@linaro.org>
--- a/drivers/thermal/qcom/tsens.c --- a/drivers/thermal/qcom/tsens.c
+++ b/drivers/thermal/qcom/tsens.c +++ b/drivers/thermal/qcom/tsens.c
@@ -691,7 +691,7 @@ static int dbg_version_show(struct seq_f @@ -692,7 +692,7 @@ static int dbg_version_show(struct seq_f
return ret; return ret;
seq_printf(s, "%d.%d.%d\n", maj_ver, min_ver, step_ver); seq_printf(s, "%d.%d.%d\n", maj_ver, min_ver, step_ver);
} else { } else {
@ -26,7 +26,7 @@ Reviewed-by: Thara Gopinath <thara.gopinath@linaro.org>
} }
return 0; return 0;
@@ -703,21 +703,17 @@ DEFINE_SHOW_ATTRIBUTE(dbg_sensors); @@ -704,21 +704,17 @@ DEFINE_SHOW_ATTRIBUTE(dbg_sensors);
static void tsens_debug_init(struct platform_device *pdev) static void tsens_debug_init(struct platform_device *pdev)
{ {
struct tsens_priv *priv = platform_get_drvdata(pdev); struct tsens_priv *priv = platform_get_drvdata(pdev);

View File

@ -21,9 +21,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
--- a/drivers/devfreq/Kconfig --- a/drivers/devfreq/Kconfig
+++ b/drivers/devfreq/Kconfig +++ b/drivers/devfreq/Kconfig
@@ -132,6 +132,17 @@ config ARM_RK3399_DMC_DEVFREQ @@ -151,6 +151,17 @@ config ARM_SUN8I_A33_MBUS_DEVFREQ
It sets the frequency for the memory controller and reads the usage counts This adds the DEVFREQ driver for the MBUS controller in some
from hardware. Allwinner sun8i (A33 through H3) and sun50i (A64 and H5) SoCs.
+config ARM_KRAIT_CACHE_DEVFREQ +config ARM_KRAIT_CACHE_DEVFREQ
+ tristate "Scaling support for Krait CPU Cache Devfreq" + tristate "Scaling support for Krait CPU Cache Devfreq"
@ -41,9 +41,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
endif # PM_DEVFREQ endif # PM_DEVFREQ
--- a/drivers/devfreq/Makefile --- a/drivers/devfreq/Makefile
+++ b/drivers/devfreq/Makefile +++ b/drivers/devfreq/Makefile
@@ -13,6 +13,7 @@ obj-$(CONFIG_ARM_IMX_BUS_DEVFREQ) += imx @@ -15,6 +15,7 @@ obj-$(CONFIG_ARM_MEDIATEK_CCI_DEVFREQ) +
obj-$(CONFIG_ARM_IMX8M_DDRC_DEVFREQ) += imx8m-ddrc.o
obj-$(CONFIG_ARM_RK3399_DMC_DEVFREQ) += rk3399_dmc.o obj-$(CONFIG_ARM_RK3399_DMC_DEVFREQ) += rk3399_dmc.o
obj-$(CONFIG_ARM_SUN8I_A33_MBUS_DEVFREQ) += sun8i-a33-mbus.o
obj-$(CONFIG_ARM_TEGRA_DEVFREQ) += tegra30-devfreq.o obj-$(CONFIG_ARM_TEGRA_DEVFREQ) += tegra30-devfreq.o
+obj-$(CONFIG_ARM_KRAIT_CACHE_DEVFREQ) += krait-cache-devfreq.o +obj-$(CONFIG_ARM_KRAIT_CACHE_DEVFREQ) += krait-cache-devfreq.o

View File

@ -31,9 +31,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
}; };
opp_table_l2: opp_table_l2 { opp_table_l2: opp_table_l2 {
@@ -470,6 +460,16 @@ @@ -1410,6 +1400,16 @@
ranges; #reset-cells = <1>;
compatible = "simple-bus"; };
+ L2: l2-cache { + L2: l2-cache {
+ compatible = "cache", "qcom,krait-cache"; + compatible = "cache", "qcom,krait-cache";

View File

@ -15,7 +15,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
--- a/drivers/devfreq/Kconfig --- a/drivers/devfreq/Kconfig
+++ b/drivers/devfreq/Kconfig +++ b/drivers/devfreq/Kconfig
@@ -143,6 +143,17 @@ config ARM_KRAIT_CACHE_DEVFREQ @@ -162,6 +162,17 @@ config ARM_KRAIT_CACHE_DEVFREQ
based on the max frequency across all core and the range set in the device based on the max frequency across all core and the range set in the device
dts. If provided this scale also the regulator attached to the l2 cache. dts. If provided this scale also the regulator attached to the l2 cache.
@ -35,8 +35,8 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
endif # PM_DEVFREQ endif # PM_DEVFREQ
--- a/drivers/devfreq/Makefile --- a/drivers/devfreq/Makefile
+++ b/drivers/devfreq/Makefile +++ b/drivers/devfreq/Makefile
@@ -14,6 +14,7 @@ obj-$(CONFIG_ARM_IMX8M_DDRC_DEVFREQ) += @@ -16,6 +16,7 @@ obj-$(CONFIG_ARM_RK3399_DMC_DEVFREQ) +=
obj-$(CONFIG_ARM_RK3399_DMC_DEVFREQ) += rk3399_dmc.o obj-$(CONFIG_ARM_SUN8I_A33_MBUS_DEVFREQ) += sun8i-a33-mbus.o
obj-$(CONFIG_ARM_TEGRA_DEVFREQ) += tegra30-devfreq.o obj-$(CONFIG_ARM_TEGRA_DEVFREQ) += tegra30-devfreq.o
obj-$(CONFIG_ARM_KRAIT_CACHE_DEVFREQ) += krait-cache-devfreq.o obj-$(CONFIG_ARM_KRAIT_CACHE_DEVFREQ) += krait-cache-devfreq.o
+obj-$(CONFIG_ARM_IPQ806X_FAB_DEVFREQ) += ipq806x-fab-devfreq.o +obj-$(CONFIG_ARM_IPQ806X_FAB_DEVFREQ) += ipq806x-fab-devfreq.o

View File

@ -30,9 +30,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
+ }; + };
+ +
thermal-zones { thermal-zones {
tsens_tz_sensor0 { sensor0-thermal {
polling-delay-passive = <0>; polling-delay-passive = <0>;
@@ -470,6 +482,13 @@ @@ -1410,6 +1422,13 @@
operating-points-v2 = <&opp_table_l2>; operating-points-v2 = <&opp_table_l2>;
}; };

View File

@ -13,11 +13,9 @@ Link: https://lore.kernel.org/r/20221108211734.3707-1-ansuelsmth@gmail.com
drivers/clk/qcom/kpss-xcc.c | 13 +++++++++---- drivers/clk/qcom/kpss-xcc.c | 13 +++++++++----
1 file changed, 9 insertions(+), 4 deletions(-) 1 file changed, 9 insertions(+), 4 deletions(-)
diff --git a/drivers/clk/qcom/kpss-xcc.c b/drivers/clk/qcom/kpss-xcc.c
index b1b370274ec4..97358c98c6c9 100644
--- a/drivers/clk/qcom/kpss-xcc.c --- a/drivers/clk/qcom/kpss-xcc.c
+++ b/drivers/clk/qcom/kpss-xcc.c +++ b/drivers/clk/qcom/kpss-xcc.c
@@ -31,12 +31,13 @@ MODULE_DEVICE_TABLE(of, kpss_xcc_match_table); @@ -31,12 +31,13 @@ MODULE_DEVICE_TABLE(of, kpss_xcc_match_t
static int kpss_xcc_driver_probe(struct platform_device *pdev) static int kpss_xcc_driver_probe(struct platform_device *pdev)
{ {
@ -32,7 +30,7 @@ index b1b370274ec4..97358c98c6c9 100644
if (!id) if (!id)
return -ENODEV; return -ENODEV;
@@ -45,7 +46,7 @@ static int kpss_xcc_driver_probe(struct platform_device *pdev) @@ -45,7 +46,7 @@ static int kpss_xcc_driver_probe(struct
return PTR_ERR(base); return PTR_ERR(base);
if (id->data) { if (id->data) {
@ -41,7 +39,7 @@ index b1b370274ec4..97358c98c6c9 100644
"clock-output-names", "clock-output-names",
0, &name)) 0, &name))
return -ENODEV; return -ENODEV;
@@ -55,12 +56,16 @@ static int kpss_xcc_driver_probe(struct platform_device *pdev) @@ -55,12 +56,16 @@ static int kpss_xcc_driver_probe(struct
base += 0x28; base += 0x28;
} }
@ -60,6 +58,3 @@ index b1b370274ec4..97358c98c6c9 100644
} }
static struct platform_driver kpss_xcc_driver = { static struct platform_driver kpss_xcc_driver = {
--
2.37.2

View File

@ -14,11 +14,9 @@ Link: https://lore.kernel.org/r/20221108215827.30475-1-ansuelsmth@gmail.com
drivers/clk/qcom/krait-cc.c | 2 +- drivers/clk/qcom/krait-cc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/clk/qcom/krait-cc.c b/drivers/clk/qcom/krait-cc.c
index e91275663973..33a78b7de0bd 100644
--- a/drivers/clk/qcom/krait-cc.c --- a/drivers/clk/qcom/krait-cc.c
+++ b/drivers/clk/qcom/krait-cc.c +++ b/drivers/clk/qcom/krait-cc.c
@@ -64,7 +64,7 @@ static int krait_notifier_register(struct device *dev, struct clk *clk, @@ -62,7 +62,7 @@ static int krait_notifier_register(struc
int ret = 0; int ret = 0;
mux->clk_nb.notifier_call = krait_notifier_cb; mux->clk_nb.notifier_call = krait_notifier_cb;
@ -27,6 +25,3 @@ index e91275663973..33a78b7de0bd 100644
if (ret) if (ret)
dev_err(dev, "failed to register clock notifier: %d\n", ret); dev_err(dev, "failed to register clock notifier: %d\n", ret);
--
2.37.2

View File

@ -12,20 +12,18 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
drivers/clk/qcom/krait-cc.c | 14 +++++++++++--- drivers/clk/qcom/krait-cc.c | 14 +++++++++++---
1 file changed, 11 insertions(+), 3 deletions(-) 1 file changed, 11 insertions(+), 3 deletions(-)
diff --git a/drivers/clk/qcom/krait-cc.c b/drivers/clk/qcom/krait-cc.c
index 84f0048961f5..f1d64b16cac3 100644
--- a/drivers/clk/qcom/krait-cc.c --- a/drivers/clk/qcom/krait-cc.c
+++ b/drivers/clk/qcom/krait-cc.c +++ b/drivers/clk/qcom/krait-cc.c
@@ -305,7 +305,7 @@ static int krait_cc_probe(struct platform_device *pdev) @@ -348,7 +348,7 @@ static int krait_cc_probe(struct platfor
{ {
struct device *dev = &pdev->dev; struct device *dev = &pdev->dev;
const struct of_device_id *id; const struct of_device_id *id;
- unsigned long cur_rate, aux_rate; - unsigned long cur_rate, aux_rate;
+ unsigned long cur_rate, aux_rate, qsb_rate; + unsigned long cur_rate, aux_rate, qsb_rate;
int cpu; int cpu;
struct clk *clk; struct clk_hw *mux, *l2_pri_mux;
struct clk **clks; struct clk *clk, **clks;
@@ -315,11 +315,19 @@ static int krait_cc_probe(struct platform_device *pdev) @@ -357,11 +357,19 @@ static int krait_cc_probe(struct platfor
if (!id) if (!id)
return -ENODEV; return -ENODEV;
@ -47,6 +45,3 @@ index 84f0048961f5..f1d64b16cac3 100644
if (!id->data) { if (!id->data) {
clk = clk_register_fixed_factor(dev, "acpu_aux", clk = clk_register_fixed_factor(dev, "acpu_aux",
"gpll0_vote", 0, 1, 2); "gpll0_vote", 0, 1, 2);
--
2.37.2

View File

@ -14,8 +14,6 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
drivers/clk/qcom/krait-cc.c | 8 +++++--- drivers/clk/qcom/krait-cc.c | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-) 1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/drivers/clk/qcom/krait-cc.c b/drivers/clk/qcom/krait-cc.c
index f1d64b16cac3..e91275663973 100644
--- a/drivers/clk/qcom/krait-cc.c --- a/drivers/clk/qcom/krait-cc.c
+++ b/drivers/clk/qcom/krait-cc.c +++ b/drivers/clk/qcom/krait-cc.c
@@ -25,6 +25,8 @@ enum { @@ -25,6 +25,8 @@ enum {
@ -27,7 +25,7 @@ index f1d64b16cac3..e91275663973 100644
static unsigned int sec_mux_map[] = { static unsigned int sec_mux_map[] = {
2, 2,
0, 0,
@@ -322,7 +324,7 @@ static int krait_cc_probe(struct platform_device *pdev) @@ -364,7 +366,7 @@ static int krait_cc_probe(struct platfor
*/ */
clk = clk_get(dev, "qsb"); clk = clk_get(dev, "qsb");
if (IS_ERR(clk)) if (IS_ERR(clk))
@ -36,6 +34,3 @@ index f1d64b16cac3..e91275663973 100644
if (IS_ERR(clk)) if (IS_ERR(clk))
return PTR_ERR(clk); return PTR_ERR(clk);
--
2.37.2

View File

@ -10,12 +10,10 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
drivers/clk/qcom/krait-cc.c | 8 ++++---- drivers/clk/qcom/krait-cc.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-) 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/clk/qcom/krait-cc.c b/drivers/clk/qcom/krait-cc.c
index b71067a49ee7..e4fb3ff2b5b5 100644
--- a/drivers/clk/qcom/krait-cc.c --- a/drivers/clk/qcom/krait-cc.c
+++ b/drivers/clk/qcom/krait-cc.c +++ b/drivers/clk/qcom/krait-cc.c
@@ -391,25 +391,25 @@ static int krait_cc_probe(struct platform_device *pdev) @@ -423,25 +423,25 @@ static int krait_cc_probe(struct platfor
cur_rate = clk_get_rate(l2_pri_mux_clk); cur_rate = clk_get_rate(clks[l2_mux]);
aux_rate = 384000000; aux_rate = 384000000;
if (cur_rate < aux_rate) { if (cur_rate < aux_rate) {
- pr_info("L2 @ Undefined rate. Forcing new rate.\n"); - pr_info("L2 @ Undefined rate. Forcing new rate.\n");
@ -44,6 +42,3 @@ index b71067a49ee7..e4fb3ff2b5b5 100644
} }
of_clk_add_provider(dev->of_node, krait_of_get, clks); of_clk_add_provider(dev->of_node, krait_of_get, clks);
--
2.37.2

View File

@ -17,8 +17,6 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
drivers/clk/qcom/krait-cc.c | 50 +++++++++++++++++-------------------- drivers/clk/qcom/krait-cc.c | 50 +++++++++++++++++--------------------
1 file changed, 23 insertions(+), 27 deletions(-) 1 file changed, 23 insertions(+), 27 deletions(-)
diff --git a/drivers/clk/qcom/krait-cc.c b/drivers/clk/qcom/krait-cc.c
index 717eff44b6a4..90dee71e7c38 100644
--- a/drivers/clk/qcom/krait-cc.c --- a/drivers/clk/qcom/krait-cc.c
+++ b/drivers/clk/qcom/krait-cc.c +++ b/drivers/clk/qcom/krait-cc.c
@@ -25,7 +25,9 @@ enum { @@ -25,7 +25,9 @@ enum {
@ -32,16 +30,16 @@ index 717eff44b6a4..90dee71e7c38 100644
static unsigned int sec_mux_map[] = { static unsigned int sec_mux_map[] = {
2, 2,
@@ -317,7 +319,7 @@ static int krait_cc_probe(struct platform_device *pdev) @@ -350,7 +352,7 @@ static int krait_cc_probe(struct platfor
{ {
struct device *dev = &pdev->dev; struct device *dev = &pdev->dev;
const struct of_device_id *id; const struct of_device_id *id;
- unsigned long cur_rate, aux_rate, qsb_rate; - unsigned long cur_rate, aux_rate, qsb_rate;
+ unsigned long cur_rate, qsb_rate; + unsigned long cur_rate, qsb_rate;
int cpu; int cpu;
struct clk *clk; struct clk_hw *mux, *l2_pri_mux;
struct clk **clks; struct clk *clk, **clks;
@@ -397,28 +399,29 @@ static int krait_cc_probe(struct platform_device *pdev) @@ -420,28 +422,29 @@ static int krait_cc_probe(struct platfor
* two different rates to force a HFPLL reinit under all * two different rates to force a HFPLL reinit under all
* circumstances. * circumstances.
*/ */
@ -88,5 +86,3 @@ index 717eff44b6a4..90dee71e7c38 100644
} }
of_clk_add_provider(dev->of_node, krait_of_get, clks); of_clk_add_provider(dev->of_node, krait_of_get, clks);

View File

@ -14,7 +14,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
--- a/drivers/clk/qcom/gcc-ipq806x.c --- a/drivers/clk/qcom/gcc-ipq806x.c
+++ b/drivers/clk/qcom/gcc-ipq806x.c +++ b/drivers/clk/qcom/gcc-ipq806x.c
@@ -3384,14 +3384,6 @@ static int gcc_ipq806x_probe(struct plat @@ -3386,14 +3386,6 @@ static int gcc_ipq806x_probe(struct plat
struct regmap *regmap; struct regmap *regmap;
int ret; int ret;

View File

@ -18,7 +18,7 @@ Link: https://lore.kernel.org/r/20221024233817.27410-1-ansuelsmth@gmail.com
--- a/arch/arm/boot/dts/qcom-ipq8064.dtsi --- a/arch/arm/boot/dts/qcom-ipq8064.dtsi
+++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi +++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi
@@ -1529,7 +1529,6 @@ @@ -932,7 +932,6 @@
non-removable; non-removable;
cap-sd-highspeed; cap-sd-highspeed;
cap-mmc-highspeed; cap-mmc-highspeed;

View File

@ -2,9 +2,9 @@ From: Christian Lamparter <chunkeey@googlemail.com>
Subject: SoC: add qualcomm syscon Subject: SoC: add qualcomm syscon
--- a/drivers/soc/qcom/Makefile --- a/drivers/soc/qcom/Makefile
+++ b/drivers/soc/qcom/Makefile +++ b/drivers/soc/qcom/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_QCOM_SMP2P) += smp2p.o @@ -23,6 +23,7 @@ obj-$(CONFIG_QCOM_SOCINFO) += socinfo.o
obj-$(CONFIG_QCOM_SMSM) += smsm.o obj-$(CONFIG_QCOM_SPM) += spm.o
obj-$(CONFIG_QCOM_SOCINFO) += socinfo.o obj-$(CONFIG_QCOM_STATS) += qcom_stats.o
obj-$(CONFIG_QCOM_WCNSS_CTRL) += wcnss_ctrl.o obj-$(CONFIG_QCOM_WCNSS_CTRL) += wcnss_ctrl.o
+obj-$(CONFIG_QCOM_TCSR) += qcom_tcsr.o +obj-$(CONFIG_QCOM_TCSR) += qcom_tcsr.o
obj-$(CONFIG_QCOM_APR) += apr.o obj-$(CONFIG_QCOM_APR) += apr.o
@ -12,9 +12,9 @@ Subject: SoC: add qualcomm syscon
obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
--- a/drivers/soc/qcom/Kconfig --- a/drivers/soc/qcom/Kconfig
+++ b/drivers/soc/qcom/Kconfig +++ b/drivers/soc/qcom/Kconfig
@@ -190,6 +190,13 @@ config QCOM_SOCINFO @@ -213,6 +213,13 @@ config QCOM_STATS
Say yes here to support the Qualcomm socinfo driver, providing various SoC level low power modes statistics and export to debugfs
information about the SoC to user space. interface.
+config QCOM_TCSR +config QCOM_TCSR
+ tristate "QCOM Top Control and Status Registers" + tristate "QCOM Top Control and Status Registers"

View File

@ -1,6 +1,6 @@
--- a/arch/arm/Kconfig --- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig +++ b/arch/arm/Kconfig
@@ -1740,6 +1740,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_MANGL @@ -1599,6 +1599,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_MANGL
endchoice endchoice
@ -17,7 +17,7 @@
default "" default ""
--- a/drivers/of/fdt.c --- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c +++ b/drivers/of/fdt.c
@@ -1162,6 +1162,17 @@ int __init early_init_dt_scan_chosen(uns @@ -1187,6 +1187,17 @@ int __init early_init_dt_scan_chosen(cha
if (p != NULL && l > 0) if (p != NULL && l > 0)
strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE)); strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE));