mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
ipq40xx: 6.6: refresh kernel patches
Refresh kernel patches using make target/linux/refresh. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
parent
8ec76705d4
commit
61d1eedc2d
@ -27,9 +27,9 @@ Signed-off-by: Bjorn Andersson <andersson@kernel.org>
|
||||
|
||||
--- a/drivers/firmware/qcom_scm.c
|
||||
+++ b/drivers/firmware/qcom_scm.c
|
||||
@@ -407,6 +407,29 @@ int qcom_scm_set_remote_state(u32 state,
|
||||
@@ -410,6 +410,29 @@ int qcom_scm_set_remote_state(u32 state,
|
||||
}
|
||||
EXPORT_SYMBOL(qcom_scm_set_remote_state);
|
||||
EXPORT_SYMBOL_GPL(qcom_scm_set_remote_state);
|
||||
|
||||
+static int qcom_scm_disable_sdi(void)
|
||||
+{
|
||||
@ -57,7 +57,7 @@ Signed-off-by: Bjorn Andersson <andersson@kernel.org>
|
||||
static int __qcom_scm_set_dload_mode(struct device *dev, bool enable)
|
||||
{
|
||||
struct qcom_scm_desc desc = {
|
||||
@@ -1411,6 +1434,13 @@ static int qcom_scm_probe(struct platfor
|
||||
@@ -1467,6 +1490,13 @@ static int qcom_scm_probe(struct platfor
|
||||
|
||||
__get_convention();
|
||||
|
||||
@ -73,7 +73,7 @@ Signed-off-by: Bjorn Andersson <andersson@kernel.org>
|
||||
* will cause the boot stages to enter download mode, unless
|
||||
--- a/drivers/firmware/qcom_scm.h
|
||||
+++ b/drivers/firmware/qcom_scm.h
|
||||
@@ -77,6 +77,7 @@ extern int scm_legacy_call(struct device
|
||||
@@ -80,6 +80,7 @@ extern int scm_legacy_call(struct device
|
||||
#define QCOM_SCM_SVC_BOOT 0x01
|
||||
#define QCOM_SCM_BOOT_SET_ADDR 0x01
|
||||
#define QCOM_SCM_BOOT_TERMINATE_PC 0x02
|
||||
|
@ -44,7 +44,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
|
||||
--- a/drivers/clk/qcom/gcc-ipq4019.c
|
||||
+++ b/drivers/clk/qcom/gcc-ipq4019.c
|
||||
@@ -1243,6 +1243,29 @@ static const struct clk_fepll_vco gcc_fe
|
||||
@@ -120,6 +120,29 @@ static const struct clk_fepll_vco gcc_fe
|
||||
.reg = 0x2f020,
|
||||
};
|
||||
|
||||
@ -74,7 +74,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
/*
|
||||
* Round rate function for APSS CPU PLL Clock divider.
|
||||
* It looks up the frequency table and returns the next higher frequency
|
||||
@@ -1255,7 +1278,7 @@ static long clk_cpu_div_round_rate(struc
|
||||
@@ -132,7 +155,7 @@ static long clk_cpu_div_round_rate(struc
|
||||
struct clk_hw *p_hw;
|
||||
const struct freq_tbl *f;
|
||||
|
||||
@ -83,7 +83,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
if (!f)
|
||||
return -EINVAL;
|
||||
|
||||
@@ -1277,7 +1300,7 @@ static int clk_cpu_div_set_rate(struct c
|
||||
@@ -154,7 +177,7 @@ static int clk_cpu_div_set_rate(struct c
|
||||
const struct freq_tbl *f;
|
||||
u32 mask;
|
||||
|
||||
@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
if (!f)
|
||||
return -EINVAL;
|
||||
|
||||
@@ -1304,6 +1327,7 @@ static unsigned long
|
||||
@@ -181,6 +204,7 @@ static unsigned long
|
||||
clk_cpu_div_recalc_rate(struct clk_hw *hw,
|
||||
unsigned long parent_rate)
|
||||
{
|
||||
@ -100,7 +100,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
||||
struct clk_fepll *pll = to_clk_fepll(hw);
|
||||
u32 cdiv, pre_div;
|
||||
u64 rate;
|
||||
@@ -1324,7 +1348,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
|
||||
@@ -201,7 +225,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
|
||||
rate = clk_fepll_vco_calc_rate(pll, parent_rate) * 2;
|
||||
do_div(rate, pre_div);
|
||||
|
||||
|
@ -45,11 +45,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
||||
drivers/mtd/mtdcore.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/mtd/mtdcore.c b/drivers/mtd/mtdcore.c
|
||||
index 5887feb347a4..6872477a5129 100644
|
||||
--- a/drivers/mtd/mtdcore.c
|
||||
+++ b/drivers/mtd/mtdcore.c
|
||||
@@ -900,7 +900,7 @@ static struct nvmem_device *mtd_otp_nvmem_register(struct mtd_info *mtd,
|
||||
@@ -933,7 +933,7 @@ static struct nvmem_device *mtd_otp_nvme
|
||||
config.name = compatible;
|
||||
config.id = NVMEM_DEVID_AUTO;
|
||||
config.owner = THIS_MODULE;
|
||||
@ -58,6 +56,3 @@ index 5887feb347a4..6872477a5129 100644
|
||||
config.type = NVMEM_TYPE_OTP;
|
||||
config.root_only = true;
|
||||
config.ignore_wp = true;
|
||||
--
|
||||
2.43.0
|
||||
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
||||
|
||||
--- a/drivers/mmc/host/sdhci-msm.c
|
||||
+++ b/drivers/mmc/host/sdhci-msm.c
|
||||
@@ -2451,7 +2451,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
|
||||
@@ -2320,7 +2320,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
|
||||
|
||||
static const struct sdhci_ops sdhci_msm_ops = {
|
||||
.reset = sdhci_and_cqhci_reset,
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
||||
|
||||
--- a/drivers/mmc/host/sdhci-msm.c
|
||||
+++ b/drivers/mmc/host/sdhci-msm.c
|
||||
@@ -1751,49 +1751,49 @@ static unsigned int sdhci_msm_get_min_cl
|
||||
@@ -1755,49 +1755,49 @@ static unsigned int sdhci_msm_get_min_cl
|
||||
return SDHCI_MSM_MIN_CLOCK;
|
||||
}
|
||||
|
||||
|
@ -118,7 +118,7 @@ Signed-off-by: Brian Norris <computersforpeace@gmail.com>
|
||||
}
|
||||
--- a/drivers/firmware/qcom_scm.c
|
||||
+++ b/drivers/firmware/qcom_scm.c
|
||||
@@ -312,6 +312,17 @@ static int qcom_scm_set_boot_addr(void *
|
||||
@@ -315,6 +315,17 @@ static int qcom_scm_set_boot_addr(void *
|
||||
desc.args[0] = flags;
|
||||
desc.args[1] = virt_to_phys(entry);
|
||||
|
||||
|
@ -32,7 +32,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -17075,6 +17075,13 @@ L: netdev@vger.kernel.org
|
||||
@@ -17708,6 +17708,13 @@ L: netdev@vger.kernel.org
|
||||
S: Maintained
|
||||
F: drivers/net/ethernet/qualcomm/emac/
|
||||
|
||||
@ -48,7 +48,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
R: Bhupesh Sharma <bhupesh.sharma@linaro.org>
|
||||
--- a/drivers/net/ethernet/qualcomm/Kconfig
|
||||
+++ b/drivers/net/ethernet/qualcomm/Kconfig
|
||||
@@ -60,6 +60,17 @@ config QCOM_EMAC
|
||||
@@ -61,6 +61,17 @@ config QCOM_EMAC
|
||||
low power, Receive-Side Scaling (RSS), and IEEE 1588-2008
|
||||
Precision Clock Synchronization Protocol.
|
||||
|
||||
|
@ -64,7 +64,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
|
||||
--- a/MAINTAINERS
|
||||
+++ b/MAINTAINERS
|
||||
@@ -17081,6 +17081,7 @@ L: netdev@vger.kernel.org
|
||||
@@ -17714,6 +17714,7 @@ L: netdev@vger.kernel.org
|
||||
S: Maintained
|
||||
F: Documentation/devicetree/bindings/net/qcom,ipq4019-ess-edma.yaml
|
||||
F: drivers/net/ethernet/qualcomm/ipqess/
|
||||
@ -93,7 +93,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
+#endif
|
||||
--- a/include/linux/skbuff.h
|
||||
+++ b/include/linux/skbuff.h
|
||||
@@ -4588,6 +4588,9 @@ enum skb_ext_id {
|
||||
@@ -4627,6 +4627,9 @@ enum skb_ext_id {
|
||||
#if IS_ENABLED(CONFIG_MCTP_FLOWS)
|
||||
SKB_EXT_MCTP,
|
||||
#endif
|
||||
@ -105,7 +105,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
|
||||
--- a/include/net/dsa.h
|
||||
+++ b/include/net/dsa.h
|
||||
@@ -55,6 +55,7 @@ struct phylink_link_state;
|
||||
@@ -56,6 +56,7 @@ struct phylink_link_state;
|
||||
#define DSA_TAG_PROTO_RTL8_4T_VALUE 25
|
||||
#define DSA_TAG_PROTO_RZN1_A5PSW_VALUE 26
|
||||
#define DSA_TAG_PROTO_LAN937X_VALUE 27
|
||||
@ -113,7 +113,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
|
||||
enum dsa_tag_protocol {
|
||||
DSA_TAG_PROTO_NONE = DSA_TAG_PROTO_NONE_VALUE,
|
||||
@@ -85,6 +86,7 @@ enum dsa_tag_protocol {
|
||||
@@ -86,6 +87,7 @@ enum dsa_tag_protocol {
|
||||
DSA_TAG_PROTO_RTL8_4T = DSA_TAG_PROTO_RTL8_4T_VALUE,
|
||||
DSA_TAG_PROTO_RZN1_A5PSW = DSA_TAG_PROTO_RZN1_A5PSW_VALUE,
|
||||
DSA_TAG_PROTO_LAN937X = DSA_TAG_PROTO_LAN937X_VALUE,
|
||||
@ -123,7 +123,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
struct dsa_switch;
|
||||
--- a/net/core/skbuff.c
|
||||
+++ b/net/core/skbuff.c
|
||||
@@ -62,8 +62,12 @@
|
||||
@@ -63,8 +63,12 @@
|
||||
#include <linux/mpls.h>
|
||||
#include <linux/kcov.h>
|
||||
#include <linux/if.h>
|
||||
@ -136,7 +136,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
#include <net/dst.h>
|
||||
#include <net/sock.h>
|
||||
#include <net/checksum.h>
|
||||
@@ -4517,6 +4521,9 @@ static const u8 skb_ext_type_len[] = {
|
||||
@@ -4812,6 +4816,9 @@ static const u8 skb_ext_type_len[] = {
|
||||
#if IS_ENABLED(CONFIG_MCTP_FLOWS)
|
||||
[SKB_EXT_MCTP] = SKB_EXT_CHUNKSIZEOF(struct mctp_flow),
|
||||
#endif
|
||||
@ -148,7 +148,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
static __always_inline unsigned int skb_ext_total_length(void)
|
||||
--- a/net/dsa/Kconfig
|
||||
+++ b/net/dsa/Kconfig
|
||||
@@ -113,6 +113,15 @@ config NET_DSA_TAG_OCELOT_8021Q
|
||||
@@ -119,6 +119,15 @@ config NET_DSA_TAG_OCELOT_8021Q
|
||||
this mode, less TCAM resources (VCAP IS1, IS2, ES0) are available for
|
||||
use with tc-flower.
|
||||
|
||||
@ -166,8 +166,8 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
help
|
||||
--- a/net/dsa/Makefile
|
||||
+++ b/net/dsa/Makefile
|
||||
@@ -22,6 +22,7 @@ obj-$(CONFIG_NET_DSA_TAG_LAN9303) += tag
|
||||
obj-$(CONFIG_NET_DSA_TAG_MTK) += tag_mtk.o
|
||||
@@ -31,6 +31,7 @@ obj-$(CONFIG_NET_DSA_TAG_MTK) += tag_mtk
|
||||
obj-$(CONFIG_NET_DSA_TAG_NONE) += tag_none.o
|
||||
obj-$(CONFIG_NET_DSA_TAG_OCELOT) += tag_ocelot.o
|
||||
obj-$(CONFIG_NET_DSA_TAG_OCELOT_8021Q) += tag_ocelot_8021q.o
|
||||
+obj-$(CONFIG_NET_DSA_TAG_OOB) += tag_oob.o
|
||||
|
@ -23,7 +23,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
|
||||
|
||||
--- a/drivers/net/ethernet/qualcomm/Kconfig
|
||||
+++ b/drivers/net/ethernet/qualcomm/Kconfig
|
||||
@@ -64,6 +64,7 @@ config QCOM_IPQ4019_ESS_EDMA
|
||||
@@ -65,6 +65,7 @@ config QCOM_IPQ4019_ESS_EDMA
|
||||
tristate "Qualcomm Atheros IPQ4019 ESS EDMA support"
|
||||
depends on (OF && ARCH_QCOM) || COMPILE_TEST
|
||||
select PHYLINK
|
||||
|
@ -21,7 +21,7 @@ Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
|
||||
|
||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
@@ -594,6 +594,54 @@
|
||||
@@ -596,6 +596,54 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
|
@ -37,7 +37,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
||||
|
||||
--- a/drivers/net/dsa/qca/Kconfig
|
||||
+++ b/drivers/net/dsa/qca/Kconfig
|
||||
@@ -23,3 +23,11 @@ config NET_DSA_QCA8K_LEDS_SUPPORT
|
||||
@@ -24,3 +24,11 @@ config NET_DSA_QCA8K_LEDS_SUPPORT
|
||||
help
|
||||
This enabled support for LEDs present on the Qualcomm Atheros
|
||||
QCA8K Ethernet switch chips.
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
||||
|
||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
@@ -594,6 +594,82 @@
|
||||
@@ -596,6 +596,82 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
|
@ -16,7 +16,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
||||
|
||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
@@ -725,24 +725,33 @@
|
||||
@@ -727,24 +727,33 @@
|
||||
reg = <0x90000 0x64>;
|
||||
status = "disabled";
|
||||
|
||||
|
@ -12,7 +12,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
||||
|
||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
|
||||
@@ -752,6 +752,10 @@
|
||||
@@ -754,6 +754,10 @@
|
||||
ethphy4: ethernet-phy@4 {
|
||||
reg = <4>;
|
||||
};
|
||||
|
@ -2,9 +2,9 @@ From: Christian Lamparter <chunkeey@googlemail.com>
|
||||
Subject: SoC: add qualcomm syscon
|
||||
--- a/drivers/soc/qcom/Kconfig
|
||||
+++ b/drivers/soc/qcom/Kconfig
|
||||
@@ -248,4 +248,11 @@ config QCOM_ICC_BWMON
|
||||
the fixed bandwidth votes from cpufreq (CPU nodes) thus achieve high
|
||||
memory throughput even with lower CPU frequencies.
|
||||
@@ -291,4 +291,11 @@ config QCOM_INLINE_CRYPTO_ENGINE
|
||||
tristate
|
||||
select QCOM_SCM
|
||||
|
||||
+config QCOM_TCSR
|
||||
+ tristate "QCOM Top Control and Status Registers"
|
||||
@ -16,7 +16,7 @@ Subject: SoC: add qualcomm syscon
|
||||
endmenu
|
||||
--- a/drivers/soc/qcom/Makefile
|
||||
+++ b/drivers/soc/qcom/Makefile
|
||||
@@ -29,3 +29,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
|
||||
@@ -32,3 +32,4 @@ obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=
|
||||
obj-$(CONFIG_QCOM_ICC_BWMON) += icc-bwmon.o
|
||||
qcom_ice-objs += ice.o
|
||||
obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE) += qcom_ice.o
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
|
||||
|
||||
--- a/drivers/firmware/qcom_scm.c
|
||||
+++ b/drivers/firmware/qcom_scm.c
|
||||
@@ -1466,7 +1466,8 @@ static int qcom_scm_probe(struct platfor
|
||||
@@ -1522,7 +1522,8 @@ static int qcom_scm_probe(struct platfor
|
||||
static void qcom_scm_shutdown(struct platform_device *pdev)
|
||||
{
|
||||
/* Clean shutdown, disable download mode to allow normal restart */
|
||||
|
Loading…
Reference in New Issue
Block a user