mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
gettext-full: update to v0.19.4
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43896
This commit is contained in:
parent
cdaf75b641
commit
5cda3e9f7f
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2013 OpenWrt.org
|
# Copyright (C) 2006-2015 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gettext-full
|
PKG_NAME:=gettext-full
|
||||||
PKG_VERSION:=0.18.2.1
|
PKG_VERSION:=0.19.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/gettext
|
PKG_SOURCE_URL:=@GNU/gettext
|
||||||
PKG_MD5SUM:=034c8103b14654ebd300fadac44d6f14
|
PKG_MD5SUM:=997c9070354eff5517115feaea6038f0
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -1,35 +1,24 @@
|
|||||||
--- a/gettext-runtime/man/Makefile.am
|
--- a/gettext-runtime/man/Makefile.am
|
||||||
+++ b/gettext-runtime/man/Makefile.am
|
+++ b/gettext-runtime/man/Makefile.am
|
||||||
@@ -159,8 +159,7 @@ bind_textdomain_codeset.3.html: bind_tex
|
@@ -171,8 +171,7 @@ textdomain.3.html: textdomain.3.in
|
||||||
$(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
|
bindtextdomain.3.html: bindtextdomain.3.in
|
||||||
mv t-$@ $@
|
bind_textdomain_codeset.3.html: bind_textdomain_codeset.3.in
|
||||||
|
|
||||||
-install-html-local:
|
-install-html-local:
|
||||||
- $(mkdir_p) $(DESTDIR)$(htmldir)
|
- $(MKDIR_P) $(DESTDIR)$(htmldir)
|
||||||
+install-html: installdirs-html
|
+install-html: installdirs-html
|
||||||
for file in $(man_HTML); do \
|
for file in $(man_HTML); do \
|
||||||
if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
|
if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
|
||||||
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
|
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
|
||||||
--- a/gettext-tools/man/Makefile.am
|
--- a/gettext-tools/man/Makefile.am
|
||||||
+++ b/gettext-tools/man/Makefile.am
|
+++ b/gettext-tools/man/Makefile.am
|
||||||
@@ -186,8 +186,7 @@ autopoint.1.html: autopoint.1
|
@@ -153,8 +153,7 @@ recode-sr-latin.1.html: recode-sr-latin.
|
||||||
$(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
|
gettextize.1.html: gettextize.1
|
||||||
mv t-$@ $@
|
autopoint.1.html: autopoint.1
|
||||||
|
|
||||||
-install-html-local:
|
-install-html-local:
|
||||||
- $(mkdir_p) $(DESTDIR)$(htmldir)
|
- $(MKDIR_P) $(DESTDIR)$(htmldir)
|
||||||
+install-html: installdirs-html
|
+install-html: installdirs-html
|
||||||
for file in $(man_HTML); do \
|
for file in $(man_HTML); do \
|
||||||
if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
|
if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
|
||||||
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
|
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
|
||||||
--- a/gettext-runtime/intl/Makefile.in
|
|
||||||
+++ b/gettext-runtime/intl/Makefile.in
|
|
||||||
@@ -17,7 +17,7 @@
|
|
||||||
PACKAGE = @PACKAGE@
|
|
||||||
VERSION = @VERSION@
|
|
||||||
|
|
||||||
-SHELL = /bin/sh
|
|
||||||
+SHELL = @SHELL@
|
|
||||||
|
|
||||||
srcdir = @srcdir@
|
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
|
@ -1,22 +1,22 @@
|
|||||||
--- a/gettext-runtime/Makefile.in
|
--- a/gettext-runtime/Makefile.am
|
||||||
+++ b/gettext-runtime/Makefile.in
|
+++ b/gettext-runtime/Makefile.am
|
||||||
@@ -251,7 +251,7 @@ ETAGS = etags
|
@@ -28,7 +28,7 @@ SUBDIR_libasprintf = libasprintf
|
||||||
CTAGS = ctags
|
else
|
||||||
CSCOPE = cscope
|
SUBDIR_libasprintf =
|
||||||
DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
|
endif
|
||||||
- src po man m4 tests
|
-SUBDIRS = doc intl intl-java intl-csharp gnulib-lib $(SUBDIR_libasprintf) src po man m4 tests
|
||||||
+ src po man m4
|
+SUBDIRS = intl intl-java intl-csharp gnulib-lib $(SUBDIR_libasprintf) src po m4
|
||||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
|
||||||
distdir = $(PACKAGE)-$(VERSION)
|
EXTRA_DIST = BUGS
|
||||||
top_distdir = $(distdir)
|
|
||||||
--- a/gettext-tools/Makefile.in
|
--- a/gettext-tools/Makefile.am
|
||||||
+++ b/gettext-tools/Makefile.in
|
+++ b/gettext-tools/Makefile.am
|
||||||
@@ -1503,7 +1503,7 @@ top_builddir = @top_builddir@
|
@@ -19,7 +19,7 @@
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
||||||
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
|
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
|
||||||
|
|
||||||
-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
|
-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
|
||||||
+SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
|
+SUBDIRS = intl gnulib-lib libgrep src libgettextpo po projects styles misc m4
|
||||||
|
|
||||||
# Allow users to use "gnulib-tool --update".
|
|
||||||
|
|
||||||
|
EXTRA_DIST = misc/DISCLAIM
|
||||||
|
MOSTLYCLEANFILES = core *.stackdump
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/gettext-runtime/intl/localename.c
|
--- a/gettext-runtime/intl/localename.c
|
||||||
+++ b/gettext-runtime/intl/localename.c
|
+++ b/gettext-runtime/intl/localename.c
|
||||||
@@ -2679,7 +2679,7 @@ gl_locale_name_posix (int category, cons
|
@@ -2779,7 +2779,7 @@ gl_locale_name_posix (int category, cons
|
||||||
{
|
{
|
||||||
/* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
|
/* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
|
||||||
On some systems this can be done by the 'setlocale' function itself. */
|
On some systems this can be done by the 'setlocale' function itself. */
|
||||||
|
Loading…
Reference in New Issue
Block a user