mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
kernel: backport build fix for tools/resolve_btfids
Building tools/resolve_btfids requires libelf and zlib. Without this build fix, the kernel build system will not find these dependencies. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
This commit is contained in:
parent
02850d7c9c
commit
5a12839087
@ -0,0 +1,54 @@
|
||||
From cdbc4e3399ed8cdcf234a85f7a2482b622379e82 Mon Sep 17 00:00:00 2001
|
||||
From: Connor O'Brien <connoro@google.com>
|
||||
Date: Wed, 12 Jan 2022 00:25:03 +0000
|
||||
Subject: [PATCH] tools/resolve_btfids: Build with host flags
|
||||
|
||||
resolve_btfids is built using $(HOSTCC) and $(HOSTLD) but does not
|
||||
pick up the corresponding flags. As a result, host-specific settings
|
||||
(such as a sysroot specified via HOSTCFLAGS=--sysroot=..., or a linker
|
||||
specified via HOSTLDFLAGS=-fuse-ld=...) will not be respected.
|
||||
|
||||
Fix this by setting CFLAGS to KBUILD_HOSTCFLAGS and LDFLAGS to
|
||||
KBUILD_HOSTLDFLAGS.
|
||||
|
||||
Also pass the cflags through to libbpf via EXTRA_CFLAGS to ensure that
|
||||
the host libbpf is built with flags consistent with resolve_btfids.
|
||||
|
||||
Signed-off-by: Connor O'Brien <connoro@google.com>
|
||||
Signed-off-by: Andrii Nakryiko <andrii@kernel.org>
|
||||
Acked-by: Song Liu <songliubraving@fb.com>
|
||||
Link: https://lore.kernel.org/bpf/20220112002503.115968-1-connoro@google.com
|
||||
(cherry picked from commit 0e3a1c902ffb56e9fe4416f0cd382c97b09ecbf6)
|
||||
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
|
||||
---
|
||||
tools/bpf/resolve_btfids/Makefile | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/bpf/resolve_btfids/Makefile b/tools/bpf/resolve_btfids/Makefile
|
||||
index af9f9d3534c9..e727058bfe15 100644
|
||||
--- a/tools/bpf/resolve_btfids/Makefile
|
||||
+++ b/tools/bpf/resolve_btfids/Makefile
|
||||
@@ -23,6 +23,8 @@ CC = $(HOSTCC)
|
||||
LD = $(HOSTLD)
|
||||
ARCH = $(HOSTARCH)
|
||||
RM ?= rm
|
||||
+CFLAGS := $(KBUILD_HOSTCFLAGS)
|
||||
+LDFLAGS := $(KBUILD_HOSTLDFLAGS)
|
||||
|
||||
OUTPUT ?= $(srctree)/tools/bpf/resolve_btfids/
|
||||
|
||||
@@ -45,9 +47,9 @@ $(SUBCMDOBJ): fixdep FORCE | $(OUTPUT)/libsubcmd
|
||||
$(Q)$(MAKE) -C $(SUBCMD_SRC) OUTPUT=$(abspath $(dir $@))/ $(abspath $@)
|
||||
|
||||
$(BPFOBJ): $(wildcard $(LIBBPF_SRC)/*.[ch] $(LIBBPF_SRC)/Makefile) | $(OUTPUT)/libbpf
|
||||
- $(Q)$(MAKE) $(submake_extras) -C $(LIBBPF_SRC) OUTPUT=$(abspath $(dir $@))/ $(abspath $@)
|
||||
+ $(Q)$(MAKE) $(submake_extras) -C $(LIBBPF_SRC) OUTPUT=$(abspath $(dir $@))/ EXTRA_CFLAGS="$(CFLAGS)" $(abspath $@)
|
||||
|
||||
-CFLAGS := -g \
|
||||
+CFLAGS += -g \
|
||||
-I$(srctree)/tools/include \
|
||||
-I$(srctree)/tools/include/uapi \
|
||||
-I$(LIBBPF_SRC) \
|
||||
--
|
||||
2.35.1
|
||||
|
@ -0,0 +1,54 @@
|
||||
From cdbc4e3399ed8cdcf234a85f7a2482b622379e82 Mon Sep 17 00:00:00 2001
|
||||
From: Connor O'Brien <connoro@google.com>
|
||||
Date: Wed, 12 Jan 2022 00:25:03 +0000
|
||||
Subject: [PATCH] tools/resolve_btfids: Build with host flags
|
||||
|
||||
resolve_btfids is built using $(HOSTCC) and $(HOSTLD) but does not
|
||||
pick up the corresponding flags. As a result, host-specific settings
|
||||
(such as a sysroot specified via HOSTCFLAGS=--sysroot=..., or a linker
|
||||
specified via HOSTLDFLAGS=-fuse-ld=...) will not be respected.
|
||||
|
||||
Fix this by setting CFLAGS to KBUILD_HOSTCFLAGS and LDFLAGS to
|
||||
KBUILD_HOSTLDFLAGS.
|
||||
|
||||
Also pass the cflags through to libbpf via EXTRA_CFLAGS to ensure that
|
||||
the host libbpf is built with flags consistent with resolve_btfids.
|
||||
|
||||
Signed-off-by: Connor O'Brien <connoro@google.com>
|
||||
Signed-off-by: Andrii Nakryiko <andrii@kernel.org>
|
||||
Acked-by: Song Liu <songliubraving@fb.com>
|
||||
Link: https://lore.kernel.org/bpf/20220112002503.115968-1-connoro@google.com
|
||||
(cherry picked from commit 0e3a1c902ffb56e9fe4416f0cd382c97b09ecbf6)
|
||||
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
|
||||
---
|
||||
tools/bpf/resolve_btfids/Makefile | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/bpf/resolve_btfids/Makefile b/tools/bpf/resolve_btfids/Makefile
|
||||
index af9f9d3534c9..e727058bfe15 100644
|
||||
--- a/tools/bpf/resolve_btfids/Makefile
|
||||
+++ b/tools/bpf/resolve_btfids/Makefile
|
||||
@@ -23,6 +23,8 @@ CC = $(HOSTCC)
|
||||
LD = $(HOSTLD)
|
||||
ARCH = $(HOSTARCH)
|
||||
RM ?= rm
|
||||
+CFLAGS := $(KBUILD_HOSTCFLAGS)
|
||||
+LDFLAGS := $(KBUILD_HOSTLDFLAGS)
|
||||
|
||||
OUTPUT ?= $(srctree)/tools/bpf/resolve_btfids/
|
||||
|
||||
@@ -45,9 +47,9 @@ $(SUBCMDOBJ): fixdep FORCE | $(OUTPUT)/libsubcmd
|
||||
$(Q)$(MAKE) -C $(SUBCMD_SRC) OUTPUT=$(abspath $(dir $@))/ $(abspath $@)
|
||||
|
||||
$(BPFOBJ): $(wildcard $(LIBBPF_SRC)/*.[ch] $(LIBBPF_SRC)/Makefile) | $(OUTPUT)/libbpf
|
||||
- $(Q)$(MAKE) $(submake_extras) -C $(LIBBPF_SRC) OUTPUT=$(abspath $(dir $@))/ $(abspath $@)
|
||||
+ $(Q)$(MAKE) $(submake_extras) -C $(LIBBPF_SRC) OUTPUT=$(abspath $(dir $@))/ EXTRA_CFLAGS="$(CFLAGS)" $(abspath $@)
|
||||
|
||||
-CFLAGS := -g \
|
||||
+CFLAGS += -g \
|
||||
-I$(srctree)/tools/include \
|
||||
-I$(srctree)/tools/include/uapi \
|
||||
-I$(LIBBPF_SRC) \
|
||||
--
|
||||
2.35.1
|
||||
|
Loading…
Reference in New Issue
Block a user