mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
tools/meson: update to 1.1.0
Remove upstreamed: - 010-wsl2.patch Release Notes: - 0.62.0 https://mesonbuild.com/Release-notes-for-0-62-0.html - 0.63.0 https://mesonbuild.com/Release-notes-for-0-63-0.html - 0.64.0 https://mesonbuild.com/Release-notes-for-0-64-0.html - 1.0.0 https://mesonbuild.com/Release-notes-for-1-0-0.html - 1.1.0 https://mesonbuild.com/Release-notes-for-1-1-0.html Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
e81298463e
commit
5636ffc22d
@ -1,11 +1,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=meson
|
PKG_NAME:=meson
|
||||||
PKG_VERSION:=0.61.5
|
PKG_VERSION:=1.1.0
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
|
||||||
PKG_HASH:=5e9a0d65c1a51936362b9686d1c5e9e184a6fd245d57e7269750ce50c20f5d9a
|
PKG_HASH:=d9616c44cd6c53689ff8f05fc6958a693f2e17c3472a8daf83cee55dabff829f
|
||||||
|
|
||||||
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
|
PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
|
||||||
PKG_LICENSE:=Apache-2.0
|
PKG_LICENSE:=Apache-2.0
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
From 7d1ef4343ed5b2b7ab51469177a42c32c47f0528 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rosen Penev <rosenp@gmail.com>
|
|
||||||
Date: Tue, 6 Sep 2022 01:36:17 -0700
|
|
||||||
Subject: [PATCH] minstall: handle extra error for selinuxenabled
|
|
||||||
|
|
||||||
Microsoft's WSL2 uses a Plan 9 filesystem, which returns IOError when file is missing.
|
|
||||||
---
|
|
||||||
mesonbuild/minstall.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/mesonbuild/minstall.py
|
|
||||||
+++ b/mesonbuild/minstall.py
|
|
||||||
@@ -229,7 +229,7 @@ def restore_selinux_contexts() -> None:
|
|
||||||
'''
|
|
||||||
try:
|
|
||||||
subprocess.check_call(['selinuxenabled'])
|
|
||||||
- except (FileNotFoundError, NotADirectoryError, PermissionError, subprocess.CalledProcessError):
|
|
||||||
+ except (FileNotFoundError, NotADirectoryError, OSError, PermissionError, subprocess.CalledProcessError):
|
|
||||||
# If we don't have selinux or selinuxenabled returned 1, failure
|
|
||||||
# is ignored quietly.
|
|
||||||
return
|
|
Loading…
Reference in New Issue
Block a user