mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
kernel: update linux 3.7 to 3.7.5
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35390
This commit is contained in:
parent
be55b0f3f4
commit
562ba537fc
@ -8,8 +8,8 @@ endif
|
|||||||
ifeq ($(LINUX_VERSION),3.6.11)
|
ifeq ($(LINUX_VERSION),3.6.11)
|
||||||
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
|
LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.7.4)
|
ifeq ($(LINUX_VERSION),3.7.5)
|
||||||
LINUX_KERNEL_MD5SUM:=b34c31c954bebdfb568244dd3897e7c6
|
LINUX_KERNEL_MD5SUM:=ae355001775bc841132fe0fea2f354d4
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
BOARD:=adm5120
|
BOARD:=adm5120
|
||||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
SUBTARGETS:=router_le router_be rb1xx
|
SUBTARGETS:=router_le router_be rb1xx
|
||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
|
|||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
SUBTARGETS:=generic nand
|
SUBTARGETS:=generic nand
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -11,7 +11,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
|
|
||||||
--- a/arch/mips/ath79/pci.c
|
--- a/arch/mips/ath79/pci.c
|
||||||
+++ b/arch/mips/ath79/pci.c
|
+++ b/arch/mips/ath79/pci.c
|
||||||
@@ -75,7 +75,9 @@ int __init pcibios_map_irq(const struct
|
@@ -75,7 +75,9 @@ int __init pcibios_map_irq(const struct
|
||||||
const struct ath79_pci_irq *entry;
|
const struct ath79_pci_irq *entry;
|
||||||
|
|
||||||
entry = &ath79_pci_irq_map[i];
|
entry = &ath79_pci_irq_map[i];
|
||||||
|
@ -44,7 +44,7 @@ Subject: [PATCH 26/34] MIPS: ath79: add PCI controller registration code for the
|
|||||||
int __init pcibios_map_irq(const struct pci_dev *dev, uint8_t slot, uint8_t pin)
|
int __init pcibios_map_irq(const struct pci_dev *dev, uint8_t slot, uint8_t pin)
|
||||||
{
|
{
|
||||||
int irq = -1;
|
int irq = -1;
|
||||||
@@ -64,6 +79,9 @@ int __init pcibios_map_irq(const struct
|
@@ -64,6 +79,9 @@ int __init pcibios_map_irq(const struct
|
||||||
soc_is_ar9344()) {
|
soc_is_ar9344()) {
|
||||||
ath79_pci_irq_map = ar724x_pci_irq_map;
|
ath79_pci_irq_map = ar724x_pci_irq_map;
|
||||||
ath79_pci_nr_irqs = ARRAY_SIZE(ar724x_pci_irq_map);
|
ath79_pci_nr_irqs = ARRAY_SIZE(ar724x_pci_irq_map);
|
||||||
|
@ -32,18 +32,19 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
- status = gpio_request(cdata->gpio, dev_name(&spi->dev));
|
- status = gpio_request(cdata->gpio, dev_name(&spi->dev));
|
||||||
- if (status)
|
- if (status)
|
||||||
- return status;
|
- return status;
|
||||||
+ flags = GPIOF_DIR_OUT;
|
-
|
||||||
+ if (spi->mode & SPI_CS_HIGH)
|
|
||||||
+ flags |= GPIOF_INIT_HIGH;
|
|
||||||
+ else
|
|
||||||
+ flags |= GPIOF_INIT_LOW;
|
|
||||||
|
|
||||||
- status = gpio_direction_output(cdata->gpio,
|
- status = gpio_direction_output(cdata->gpio,
|
||||||
- spi->mode & SPI_CS_HIGH);
|
- spi->mode & SPI_CS_HIGH);
|
||||||
- if (status) {
|
- if (status) {
|
||||||
- gpio_free(cdata->gpio);
|
- gpio_free(cdata->gpio);
|
||||||
- return status;
|
- return status;
|
||||||
- }
|
- }
|
||||||
|
+ flags = GPIOF_DIR_OUT;
|
||||||
|
+ if (spi->mode & SPI_CS_HIGH)
|
||||||
|
+ flags |= GPIOF_INIT_HIGH;
|
||||||
|
+ else
|
||||||
|
+ flags |= GPIOF_INIT_LOW;
|
||||||
|
+
|
||||||
+ status = gpio_request_one(cdata->gpio, flags,
|
+ status = gpio_request_one(cdata->gpio, flags,
|
||||||
+ dev_name(&spi->dev));
|
+ dev_name(&spi->dev));
|
||||||
}
|
}
|
||||||
|
@ -20,7 +20,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
|
|
||||||
--- a/drivers/spi/spi-ath79.c
|
--- a/drivers/spi/spi-ath79.c
|
||||||
+++ b/drivers/spi/spi-ath79.c
|
+++ b/drivers/spi/spi-ath79.c
|
||||||
@@ -96,16 +96,8 @@ static void ath79_spi_chipselect(struct
|
@@ -96,16 +96,8 @@ static void ath79_spi_chipselect(struct
|
||||||
|
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -170,7 +170,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
struct ath79_spi {
|
struct ath79_spi {
|
||||||
struct spi_bitbang bitbang;
|
struct spi_bitbang bitbang;
|
||||||
u32 ioc_base;
|
u32 ioc_base;
|
||||||
@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct
|
@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct
|
||||||
{
|
{
|
||||||
struct ath79_spi *sp = ath79_spidev_to_sp(spi);
|
struct ath79_spi *sp = ath79_spidev_to_sp(spi);
|
||||||
int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
|
int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
|
||||||
@ -178,7 +178,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
|
|
||||||
if (is_active) {
|
if (is_active) {
|
||||||
/* set initial clock polarity */
|
/* set initial clock polarity */
|
||||||
@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct
|
@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct
|
||||||
ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
|
ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -19,7 +19,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|||||||
|
|
||||||
--- a/arch/mips/ath79/gpio.c
|
--- a/arch/mips/ath79/gpio.c
|
||||||
+++ b/arch/mips/ath79/gpio.c
|
+++ b/arch/mips/ath79/gpio.c
|
||||||
@@ -137,47 +137,61 @@ static struct gpio_chip ath79_gpio_chip
|
@@ -137,47 +137,61 @@ static struct gpio_chip ath79_gpio_chip
|
||||||
.base = 0,
|
.base = 0,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -84,7 +84,7 @@
|
|||||||
|
|
||||||
mutex_unlock(&flash->lock);
|
mutex_unlock(&flash->lock);
|
||||||
|
|
||||||
@@ -910,6 +936,12 @@ static int __devinit m25p_probe(struct s
|
@@ -914,6 +940,12 @@ static int __devinit m25p_probe(struct s
|
||||||
flash->mtd._erase = m25p80_erase;
|
flash->mtd._erase = m25p80_erase;
|
||||||
flash->mtd._read = m25p80_read;
|
flash->mtd._read = m25p80_read;
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mtd/devices/m25p80.c
|
--- a/drivers/mtd/devices/m25p80.c
|
||||||
+++ b/drivers/mtd/devices/m25p80.c
|
+++ b/drivers/mtd/devices/m25p80.c
|
||||||
@@ -1003,7 +1003,9 @@ static int __devinit m25p_probe(struct s
|
@@ -1007,7 +1007,9 @@ static int __devinit m25p_probe(struct s
|
||||||
/* partitions should match sector boundaries; and it may be good to
|
/* partitions should match sector boundaries; and it may be good to
|
||||||
* use readonly partitions for writeprotected sectors (BP2..BP0).
|
* use readonly partitions for writeprotected sectors (BP2..BP0).
|
||||||
*/
|
*/
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mtd/devices/m25p80.c
|
--- a/drivers/mtd/devices/m25p80.c
|
||||||
+++ b/drivers/mtd/devices/m25p80.c
|
+++ b/drivers/mtd/devices/m25p80.c
|
||||||
@@ -963,6 +963,7 @@ static int __devinit m25p_probe(struct s
|
@@ -967,6 +967,7 @@ static int __devinit m25p_probe(struct s
|
||||||
if (info->flags & M25P_NO_ERASE)
|
if (info->flags & M25P_NO_ERASE)
|
||||||
flash->mtd.flags |= MTD_NO_ERASE;
|
flash->mtd.flags |= MTD_NO_ERASE;
|
||||||
|
|
||||||
|
@ -10,7 +10,7 @@
|
|||||||
#endif /* __ATH79_COMMON_H */
|
#endif /* __ATH79_COMMON_H */
|
||||||
--- a/arch/mips/ath79/gpio.c
|
--- a/arch/mips/ath79/gpio.c
|
||||||
+++ b/arch/mips/ath79/gpio.c
|
+++ b/arch/mips/ath79/gpio.c
|
||||||
@@ -198,6 +198,34 @@ void ath79_gpio_function_setup(u32 set,
|
@@ -198,6 +198,34 @@ void ath79_gpio_function_setup(u32 set,
|
||||||
spin_unlock_irqrestore(&ath79_gpio_lock, flags);
|
spin_unlock_irqrestore(&ath79_gpio_lock, flags);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/ath79/early_printk.c
|
--- a/arch/mips/ath79/early_printk.c
|
||||||
+++ b/arch/mips/ath79/early_printk.c
|
+++ b/arch/mips/ath79/early_printk.c
|
||||||
@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned
|
@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned
|
||||||
/* nothing to do */
|
/* nothing to do */
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -50,7 +50,7 @@
|
|||||||
#define PB44_GPIO_SW_RESET (PB44_GPIO_EXP_BASE + 6)
|
#define PB44_GPIO_SW_RESET (PB44_GPIO_EXP_BASE + 6)
|
||||||
#define PB44_GPIO_SW_JUMP (PB44_GPIO_EXP_BASE + 8)
|
#define PB44_GPIO_SW_JUMP (PB44_GPIO_EXP_BASE + 8)
|
||||||
#define PB44_GPIO_LED_JUMP1 (PB44_GPIO_EXP_BASE + 9)
|
#define PB44_GPIO_LED_JUMP1 (PB44_GPIO_EXP_BASE + 9)
|
||||||
@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
|
@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
|
||||||
.cs_line = 0,
|
.cs_line = 0,
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -288,7 +288,7 @@
|
|||||||
#include <asm/uaccess.h>
|
#include <asm/uaccess.h>
|
||||||
|
|
||||||
#include <linux/proc_fs.h>
|
#include <linux/proc_fs.h>
|
||||||
@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct
|
@@ -851,10 +852,10 @@ static void tcp_v6_send_response(struct
|
||||||
topt = (__be32 *)(t1 + 1);
|
topt = (__be32 *)(t1 + 1);
|
||||||
|
|
||||||
if (ts) {
|
if (ts) {
|
||||||
@ -415,7 +415,7 @@
|
|||||||
if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
|
if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
|
||||||
fl6.flowi6_mark = skb->mark;
|
fl6.flowi6_mark = skb->mark;
|
||||||
|
|
||||||
@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff
|
@@ -1256,7 +1256,7 @@ static int ip6gre_header(struct sk_buff
|
||||||
struct ipv6hdr *ipv6h = (struct ipv6hdr *)skb_push(skb, t->hlen);
|
struct ipv6hdr *ipv6h = (struct ipv6hdr *)skb_push(skb, t->hlen);
|
||||||
__be16 *p = (__be16 *)(ipv6h+1);
|
__be16 *p = (__be16 *)(ipv6h+1);
|
||||||
|
|
||||||
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
|||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
--- a/drivers/mtd/devices/m25p80.c
|
--- a/drivers/mtd/devices/m25p80.c
|
||||||
+++ b/drivers/mtd/devices/m25p80.c
|
+++ b/drivers/mtd/devices/m25p80.c
|
||||||
@@ -651,6 +651,10 @@
|
@@ -645,6 +645,10 @@ static const struct spi_device_id m25p_i
|
||||||
/* Everspin */
|
/* Everspin */
|
||||||
{ "mr25h256", CAT25_INFO( 32 * 1024, 1, 256, 2) },
|
{ "mr25h256", CAT25_INFO( 32 * 1024, 1, 256, 2) },
|
||||||
|
|
||||||
+ /* GigaDevice */
|
+ /* GigaDevice */
|
||||||
+ { "gd25q32", INFO(0xc84016, 0, 64 * 1024, 64, SECT_4K) },
|
+ { "gd25q32", INFO(0xc84016, 0, 64 * 1024, 64, SECT_4K) },
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/kernel/module.c
|
--- a/kernel/module.c
|
||||||
+++ b/kernel/module.c
|
+++ b/kernel/module.c
|
||||||
@@ -2378,12 +2378,15 @@ static void dynamic_debug_remove(struct
|
@@ -2398,12 +2398,15 @@ static void dynamic_debug_remove(struct
|
||||||
|
|
||||||
void * __weak module_alloc(unsigned long size)
|
void * __weak module_alloc(unsigned long size)
|
||||||
{
|
{
|
||||||
|
@ -16,7 +16,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
#define INFO(_jedec_id, _ext_id, _sector_size, _n_sectors, _flags) \
|
#define INFO(_jedec_id, _ext_id, _sector_size, _n_sectors, _flags) \
|
||||||
@@ -667,6 +669,10 @@ static const struct spi_device_id m25p_i
|
@@ -671,6 +673,10 @@ static const struct spi_device_id m25p_i
|
||||||
{ "n25q128", INFO(0x20ba18, 0, 64 * 1024, 256, 0) },
|
{ "n25q128", INFO(0x20ba18, 0, 64 * 1024, 256, 0) },
|
||||||
{ "n25q256a", INFO(0x20ba19, 0, 64 * 1024, 512, SECT_4K) },
|
{ "n25q256a", INFO(0x20ba19, 0, 64 * 1024, 512, SECT_4K) },
|
||||||
|
|
||||||
@ -27,7 +27,7 @@
|
|||||||
/* Spansion -- single (large) sector size only, at least
|
/* Spansion -- single (large) sector size only, at least
|
||||||
* for the chips listed here (without boot sectors).
|
* for the chips listed here (without boot sectors).
|
||||||
*/
|
*/
|
||||||
@@ -907,6 +913,9 @@ static int __devinit m25p_probe(struct s
|
@@ -911,6 +917,9 @@ static int __devinit m25p_probe(struct s
|
||||||
if (info->flags & SECT_4K) {
|
if (info->flags & SECT_4K) {
|
||||||
flash->erase_opcode = OPCODE_BE_4K;
|
flash->erase_opcode = OPCODE_BE_4K;
|
||||||
flash->mtd.erasesize = 4096;
|
flash->mtd.erasesize = 4096;
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mtd/devices/m25p80.c
|
--- a/drivers/mtd/devices/m25p80.c
|
||||||
+++ b/drivers/mtd/devices/m25p80.c
|
+++ b/drivers/mtd/devices/m25p80.c
|
||||||
@@ -751,6 +751,7 @@ static const struct spi_device_id m25p_i
|
@@ -755,6 +755,7 @@ static const struct spi_device_id m25p_i
|
||||||
{ "w25x64", INFO(0xef3017, 0, 64 * 1024, 128, SECT_4K) },
|
{ "w25x64", INFO(0xef3017, 0, 64 * 1024, 128, SECT_4K) },
|
||||||
{ "w25q64", INFO(0xef4017, 0, 64 * 1024, 128, SECT_4K) },
|
{ "w25q64", INFO(0xef4017, 0, 64 * 1024, 128, SECT_4K) },
|
||||||
{ "w25q80", INFO(0xef5014, 0, 64 * 1024, 16, SECT_4K) },
|
{ "w25q80", INFO(0xef5014, 0, 64 * 1024, 16, SECT_4K) },
|
||||||
|
@ -30,7 +30,7 @@
|
|||||||
/****************************************************************************/
|
/****************************************************************************/
|
||||||
|
|
||||||
struct m25p {
|
struct m25p {
|
||||||
@@ -911,7 +917,7 @@ static int __devinit m25p_probe(struct s
|
@@ -915,7 +921,7 @@ static int __devinit m25p_probe(struct s
|
||||||
flash->mtd._write = m25p80_write;
|
flash->mtd._write = m25p80_write;
|
||||||
|
|
||||||
/* prefer "small sector" erase if possible */
|
/* prefer "small sector" erase if possible */
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/init/main.c
|
--- a/init/main.c
|
||||||
+++ b/init/main.c
|
+++ b/init/main.c
|
||||||
@@ -877,7 +877,7 @@ static void __init kernel_init_freeable(
|
@@ -877,7 +877,7 @@ static noinline void __init kernel_init_
|
||||||
|
|
||||||
/* Open the /dev/console on the rootfs, this should never fail */
|
/* Open the /dev/console on the rootfs, this should never fail */
|
||||||
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
|
if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
|
||||||
|
@ -59,7 +59,7 @@
|
|||||||
* When we die, we re-parent all our children, and try to:
|
* When we die, we re-parent all our children, and try to:
|
||||||
--- a/kernel/sched/core.c
|
--- a/kernel/sched/core.c
|
||||||
+++ b/kernel/sched/core.c
|
+++ b/kernel/sched/core.c
|
||||||
@@ -3565,6 +3565,7 @@ int can_nice(const struct task_struct *p
|
@@ -3566,6 +3566,7 @@ int can_nice(const struct task_struct *p
|
||||||
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
|
return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
|
||||||
capable(CAP_SYS_NICE));
|
capable(CAP_SYS_NICE));
|
||||||
}
|
}
|
||||||
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
|
|||||||
FEATURES:=squashfs jffs2
|
FEATURES:=squashfs jffs2
|
||||||
SUBTARGETS=xway ase falcon
|
SUBTARGETS=xway ase falcon
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
|
|
||||||
|
@ -1,7 +1,5 @@
|
|||||||
Index: linux-3.7.4/arch/mips/lantiq/xway/timer.c
|
--- /dev/null
|
||||||
===================================================================
|
+++ b/arch/mips/lantiq/xway/timer.c
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ linux-3.7.4/arch/mips/lantiq/xway/timer.c 2013-01-28 18:37:52.316180918 +0100
|
|
||||||
@@ -0,0 +1,845 @@
|
@@ -0,0 +1,845 @@
|
||||||
+#ifndef CONFIG_SOC_AMAZON_SE
|
+#ifndef CONFIG_SOC_AMAZON_SE
|
||||||
+
|
+
|
||||||
@ -848,10 +846,8 @@ Index: linux-3.7.4/arch/mips/lantiq/xway/timer.c
|
|||||||
+module_exit(lq_gptu_exit);
|
+module_exit(lq_gptu_exit);
|
||||||
+
|
+
|
||||||
+#endif
|
+#endif
|
||||||
Index: linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
|
--- /dev/null
|
||||||
===================================================================
|
+++ b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
||||||
+++ linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h 2013-01-28 18:26:14.280164283 +0100
|
|
||||||
@@ -0,0 +1,155 @@
|
@@ -0,0 +1,155 @@
|
||||||
+#ifndef __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
|
+#ifndef __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
|
||||||
+#define __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
|
+#define __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
|
||||||
@ -1008,10 +1004,8 @@ Index: linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
|
|||||||
+ u32 reload, unsigned long arg1, unsigned long arg2);
|
+ u32 reload, unsigned long arg1, unsigned long arg2);
|
||||||
+
|
+
|
||||||
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
|
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
|
||||||
Index: linux-3.7.4/arch/mips/lantiq/xway/Makefile
|
--- a/arch/mips/lantiq/xway/Makefile
|
||||||
===================================================================
|
+++ b/arch/mips/lantiq/xway/Makefile
|
||||||
--- linux-3.7.4.orig/arch/mips/lantiq/xway/Makefile 2013-01-28 18:26:06.580164100 +0100
|
|
||||||
+++ linux-3.7.4/arch/mips/lantiq/xway/Makefile 2013-01-28 18:38:07.848181285 +0100
|
|
||||||
@@ -1,3 +1,3 @@
|
@@ -1,3 +1,3 @@
|
||||||
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
|
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
|
||||||
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
|
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
DEVICE_TYPE:=developerboard
|
DEVICE_TYPE:=developerboard
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
|
|||||||
FEATURES:=squashfs targz
|
FEATURES:=squashfs targz
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
|||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
|
|||||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
|
||||||
FEATURES:=squashfs
|
FEATURES:=squashfs
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=\
|
DEFAULT_PACKAGES+=\
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||||||
BOARDNAME:=Mikrotik RouterBoard 532
|
BOARDNAME:=Mikrotik RouterBoard 532
|
||||||
FEATURES:=jffs2 pci targz broken
|
FEATURES:=jffs2 pci targz broken
|
||||||
|
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||||
|
@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
|
|||||||
kmod-cpu-msr \
|
kmod-cpu-msr \
|
||||||
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
|
||||||
hwclock wpad flashrom tc
|
hwclock wpad flashrom tc
|
||||||
LINUX_VERSION:=3.7.4
|
LINUX_VERSION:=3.7.5
|
||||||
CS5535_MASK:=0x0E000048
|
CS5535_MASK:=0x0E000048
|
||||||
|
|
||||||
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
|
||||||
|
Loading…
Reference in New Issue
Block a user