refresh 2.6.39 patches

SVN-Revision: 29042
This commit is contained in:
Florian Fainelli 2011-11-13 19:19:10 +00:00
parent 717a4391d7
commit 54da5cf11f
5 changed files with 17 additions and 34 deletions

View File

@ -33,13 +33,11 @@ Cc: Richard Purdie <rpurdie@rpsys.net>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org> Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
--- ---
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
index f1833e3..d18e7a2 100644
--- a/arch/x86/Kconfig --- a/arch/x86/Kconfig
+++ b/arch/x86/Kconfig +++ b/arch/x86/Kconfig
@@ -2073,6 +2073,20 @@ config OLPC_XO15_SCI @@ -2087,6 +2087,20 @@ config OLPC_XO1
- AC adapter status updates ---help---
- Battery status updates Add support for non-essential features of the OLPC XO-1 laptop.
+config ALIX +config ALIX
+ bool "PCEngines ALIX System Support (LED setup)" + bool "PCEngines ALIX System Support (LED setup)"
@ -58,8 +56,6 @@ index f1833e3..d18e7a2 100644
endif # X86_32 endif # X86_32
config AMD_NB config AMD_NB
diff --git a/arch/x86/platform/Makefile b/arch/x86/platform/Makefile
index 021eee9..8d87439 100644
--- a/arch/x86/platform/Makefile --- a/arch/x86/platform/Makefile
+++ b/arch/x86/platform/Makefile +++ b/arch/x86/platform/Makefile
@@ -1,6 +1,7 @@ @@ -1,6 +1,7 @@
@ -70,16 +66,10 @@ index 021eee9..8d87439 100644
obj-y += iris/ obj-y += iris/
obj-y += mrst/ obj-y += mrst/
obj-y += olpc/ obj-y += olpc/
diff --git a/arch/x86/platform/geode/Makefile b/arch/x86/platform/geode/Makefile
new file mode 100644
index 0000000..07c9cd0
--- /dev/null --- /dev/null
+++ b/arch/x86/platform/geode/Makefile +++ b/arch/x86/platform/geode/Makefile
@@ -0,0 +1 @@ @@ -0,0 +1 @@
+obj-$(CONFIG_ALIX) += alix.o +obj-$(CONFIG_ALIX) += alix.o
diff --git a/arch/x86/platform/geode/alix.c b/arch/x86/platform/geode/alix.c
new file mode 100644
index 0000000..f3f01e2
--- /dev/null --- /dev/null
+++ b/arch/x86/platform/geode/alix.c +++ b/arch/x86/platform/geode/alix.c
@@ -0,0 +1,141 @@ @@ -0,0 +1,141 @@
@ -224,11 +214,9 @@ index 0000000..f3f01e2
+MODULE_AUTHOR("Ed Wildgoose <kernel@wildgooses.com>"); +MODULE_AUTHOR("Ed Wildgoose <kernel@wildgooses.com>");
+MODULE_DESCRIPTION("PCEngines ALIX System Setup"); +MODULE_DESCRIPTION("PCEngines ALIX System Setup");
+MODULE_LICENSE("GPL"); +MODULE_LICENSE("GPL");
diff --git a/drivers/leds/Kconfig b/drivers/leds/Kconfig
index b591e72..8974d27 100644
--- a/drivers/leds/Kconfig --- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig +++ b/drivers/leds/Kconfig
@@ -107,14 +107,6 @@ @@ -107,14 +107,6 @@ config LEDS_WRAP
help help
This option enables support for the PCEngines WRAP programmable LEDs. This option enables support for the PCEngines WRAP programmable LEDs.
@ -243,11 +231,9 @@ index b591e72..8974d27 100644
config LEDS_H1940 config LEDS_H1940
tristate "LED Support for iPAQ H1940 device" tristate "LED Support for iPAQ H1940 device"
depends on LEDS_CLASS depends on LEDS_CLASS
diff --git a/drivers/leds/Makefile b/drivers/leds/Makefile
index bbfd2e3..a0a1b89 100644
--- a/drivers/leds/Makefile --- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile +++ b/drivers/leds/Makefile
@@ -16,7 +16,6 @@ obj-$(CONFIG_LEDS_AMS_DELTA) += leds-ams-delta.o @@ -16,7 +16,6 @@ obj-$(CONFIG_LEDS_AMS_DELTA) += leds-am
obj-$(CONFIG_LEDS_NET48XX) += leds-net48xx.o obj-$(CONFIG_LEDS_NET48XX) += leds-net48xx.o
obj-$(CONFIG_LEDS_NET5501) += leds-net5501.o obj-$(CONFIG_LEDS_NET5501) += leds-net5501.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
@ -255,9 +241,6 @@ index bbfd2e3..a0a1b89 100644
obj-$(CONFIG_LEDS_H1940) += leds-h1940.o obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
obj-$(CONFIG_LEDS_COBALT_QUBE) += leds-cobalt-qube.o obj-$(CONFIG_LEDS_COBALT_QUBE) += leds-cobalt-qube.o
obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
diff --git a/drivers/leds/leds-alix2.c b/drivers/leds/leds-alix2.c
deleted file mode 100644
index f59ffad..0000000
--- a/drivers/leds/leds-alix2.c --- a/drivers/leds/leds-alix2.c
+++ /dev/null +++ /dev/null
@@ -1,239 +0,0 @@ @@ -1,239 +0,0 @@

View File

@ -1,5 +1,5 @@
--- a/arch/x86/platform/geode/alix.c 2011-08-13 15:51:30.892956346 -0600 --- a/arch/x86/platform/geode/alix.c
+++ b/arch/x86/platform/geode/alix.c 2011-08-13 16:14:58.082329961 -0600 +++ b/arch/x86/platform/geode/alix.c
@@ -6,6 +6,7 @@ @@ -6,6 +6,7 @@
* *
* Copyright (C) 2008 Constantin Baranov <const@mimas.ru> * Copyright (C) 2008 Constantin Baranov <const@mimas.ru>
@ -8,7 +8,7 @@
* *
* TODO: There are large similarities with leds-net5501.c * TODO: There are large similarities with leds-net5501.c
* by Alessandro Zummo <a.zummo@towertech.it> * by Alessandro Zummo <a.zummo@towertech.it>
@@ -24,14 +25,48 @@ @@ -23,14 +24,48 @@
#include <linux/leds.h> #include <linux/leds.h>
#include <linux/platform_device.h> #include <linux/platform_device.h>
#include <linux/gpio.h> #include <linux/gpio.h>
@ -57,7 +57,7 @@
static struct gpio_led alix_leds[] = { static struct gpio_led alix_leds[] = {
{ {
.name = "alix:1", .name = "alix:1",
@@ -64,17 +98,22 @@ @@ -63,17 +98,22 @@ static struct platform_device alix_leds_
.dev.platform_data = &alix_leds_data, .dev.platform_data = &alix_leds_data,
}; };
@ -82,7 +82,7 @@
const char *bios_virt; const char *bios_virt;
const char *scan_end; const char *scan_end;
const char *p; const char *p;
@@ -109,7 +148,9 @@ @@ -108,7 +148,9 @@ static int __init alix_present(unsigned
*a = '\0'; *a = '\0';
tail = p + alix_sig_len; tail = p + alix_sig_len;
@ -93,7 +93,7 @@
printk(KERN_INFO printk(KERN_INFO
"%s: system is recognized as \"%s\"\n", "%s: system is recognized as \"%s\"\n",
KBUILD_MODNAME, name); KBUILD_MODNAME, name);
@@ -128,8 +169,8 @@ @@ -127,8 +169,8 @@ static int __init alix_init(void)
if (!is_geode()) if (!is_geode())
return 0; return 0;

View File

@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig --- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig +++ b/drivers/leds/Kconfig
@@ -449,4 +449,8 @@ config LEDS_TRIGGER_DEFAULT_ON @@ -441,4 +441,8 @@ config LEDS_TRIGGER_DEFAULT_ON
comment "iptables trigger is under Netfilter config (LED target)" comment "iptables trigger is under Netfilter config (LED target)"
depends on LEDS_TRIGGERS depends on LEDS_TRIGGERS
@ -11,7 +11,7 @@
endif # NEW_LEDS endif # NEW_LEDS
--- a/drivers/leds/Makefile --- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile +++ b/drivers/leds/Makefile
@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += @@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o

View File

@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig --- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig +++ b/drivers/leds/Kconfig
@@ -453,4 +453,11 @@ config LEDS_TRIGGER_MORSE @@ -445,4 +445,11 @@ config LEDS_TRIGGER_MORSE
tristate "LED Morse Trigger" tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS depends on LEDS_TRIGGERS
@ -14,7 +14,7 @@
endif # NEW_LEDS endif # NEW_LEDS
--- a/drivers/leds/Makefile --- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile +++ b/drivers/leds/Makefile
@@ -54,3 +54,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += @@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o

View File

@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig --- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig +++ b/drivers/leds/Kconfig
@@ -460,4 +460,11 @@ config LEDS_TRIGGER_NETDEV @@ -452,4 +452,11 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity. This allows LEDs to be controlled by network device activity.
If unsure, say Y. If unsure, say Y.
@ -14,7 +14,7 @@
endif # NEW_LEDS endif # NEW_LEDS
--- a/drivers/leds/Makefile --- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile +++ b/drivers/leds/Makefile
@@ -55,3 +55,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt @@ -54,3 +54,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o