generic: move ledbar driver from mediatek target

This moves the ledbar driver to generic, to be also used by the ramips target.

Signed-off-by: Sven Wegener <sven.wegener@stealer.net>
This commit is contained in:
Sven Wegener 2022-05-02 22:13:14 +02:00 committed by Daniel Golle
parent 76198e8f09
commit 53fc987b25
5 changed files with 31 additions and 0 deletions

View File

@ -3042,6 +3042,7 @@ CONFIG_LEDS_TRIGGER_NETDEV=y
CONFIG_LEDS_TRIGGER_TIMER=y CONFIG_LEDS_TRIGGER_TIMER=y
# CONFIG_LEDS_TRIGGER_TRANSIENT is not set # CONFIG_LEDS_TRIGGER_TRANSIENT is not set
# CONFIG_LEDS_TURRIS_OMNIA is not set # CONFIG_LEDS_TURRIS_OMNIA is not set
# CONFIG_LEDS_UBNT_LEDBAR is not set
# CONFIG_LEDS_USER is not set # CONFIG_LEDS_USER is not set
# CONFIG_LED_TRIGGER_PHY is not set # CONFIG_LED_TRIGGER_PHY is not set
# CONFIG_LEGACY_PTYS is not set # CONFIG_LEGACY_PTYS is not set

View File

@ -3143,6 +3143,7 @@ CONFIG_LEDS_TRIGGER_TIMER=y
# CONFIG_LEDS_TRIGGER_TRANSIENT is not set # CONFIG_LEDS_TRIGGER_TRANSIENT is not set
# CONFIG_LEDS_TRIGGER_TTY is not set # CONFIG_LEDS_TRIGGER_TTY is not set
# CONFIG_LEDS_TURRIS_OMNIA is not set # CONFIG_LEDS_TURRIS_OMNIA is not set
# CONFIG_LEDS_UBNT_LEDBAR is not set
# CONFIG_LEDS_USER is not set # CONFIG_LEDS_USER is not set
# CONFIG_LED_TRIGGER_PHY is not set # CONFIG_LED_TRIGGER_PHY is not set
# CONFIG_LEGACY_PTYS is not set # CONFIG_LEGACY_PTYS is not set

View File

@ -0,0 +1,29 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -929,6 +929,16 @@ config LEDS_ACER_A500
This option enables support for the Power Button LED of
Acer Iconia Tab A500.
+config LEDS_UBNT_LEDBAR
+ tristate "LED support for Ubiquiti UniFi 6 LR"
+ depends on LEDS_CLASS && I2C && OF
+ help
+ This option enables support for the Ubiquiti LEDBAR
+ LED driver.
+
+ To compile this driver as a module, choose M here: the module
+ will be called leds-ubnt-ledbar.
+
comment "LED Triggers"
source "drivers/leds/trigger/Kconfig"
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
+obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
# LED SPI Drivers
obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o