mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 22:47:56 +00:00
kernel: update to kernel version 3.0.1
SVN-Revision: 27918
This commit is contained in:
parent
b043b26b54
commit
51be984655
@ -29,8 +29,8 @@ endif
|
|||||||
ifeq ($(LINUX_VERSION),2.6.39.2)
|
ifeq ($(LINUX_VERSION),2.6.39.2)
|
||||||
LINUX_KERNEL_MD5SUM:=51be93d92028658ec93f68b79a378b17
|
LINUX_KERNEL_MD5SUM:=51be93d92028658ec93f68b79a378b17
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.0)
|
ifeq ($(LINUX_VERSION),3.0.1)
|
||||||
LINUX_KERNEL_MD5SUM:=398e95866794def22b12dfbc15ce89c0
|
LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# disable the md5sum check for unknown kernel versions
|
# disable the md5sum check for unknown kernel versions
|
||||||
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
|||||||
BOARDNAME:=Broadcom BCM947xx/953xx
|
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||||
FEATURES:=squashfs usb pcmcia
|
FEATURES:=squashfs usb pcmcia
|
||||||
|
|
||||||
LINUX_VERSION:=3.0
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
|
||||||
|
@ -22,7 +22,7 @@
|
|||||||
depends on USB
|
depends on USB
|
||||||
--- a/drivers/usb/host/ehci-hcd.c
|
--- a/drivers/usb/host/ehci-hcd.c
|
||||||
+++ b/drivers/usb/host/ehci-hcd.c
|
+++ b/drivers/usb/host/ehci-hcd.c
|
||||||
@@ -1286,9 +1286,14 @@ MODULE_LICENSE ("GPL");
|
@@ -1284,9 +1284,14 @@ MODULE_LICENSE ("GPL");
|
||||||
#define PLATFORM_DRIVER ehci_grlib_driver
|
#define PLATFORM_DRIVER ehci_grlib_driver
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -38,7 +38,7 @@
|
|||||||
#error "missing bus glue for ehci-hcd"
|
#error "missing bus glue for ehci-hcd"
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@@ -1348,10 +1353,20 @@ static int __init ehci_hcd_init(void)
|
@@ -1346,10 +1351,20 @@ static int __init ehci_hcd_init(void)
|
||||||
if (retval < 0)
|
if (retval < 0)
|
||||||
goto clean4;
|
goto clean4;
|
||||||
#endif
|
#endif
|
||||||
@ -60,7 +60,7 @@
|
|||||||
clean4:
|
clean4:
|
||||||
#endif
|
#endif
|
||||||
#ifdef OF_PLATFORM_DRIVER
|
#ifdef OF_PLATFORM_DRIVER
|
||||||
@@ -1382,6 +1397,9 @@ module_init(ehci_hcd_init);
|
@@ -1380,6 +1395,9 @@ module_init(ehci_hcd_init);
|
||||||
|
|
||||||
static void __exit ehci_hcd_cleanup(void)
|
static void __exit ehci_hcd_cleanup(void)
|
||||||
{
|
{
|
||||||
|
@ -152,7 +152,7 @@
|
|||||||
+#endif
|
+#endif
|
||||||
--- a/drivers/usb/host/ehci-hcd.c
|
--- a/drivers/usb/host/ehci-hcd.c
|
||||||
+++ b/drivers/usb/host/ehci-hcd.c
|
+++ b/drivers/usb/host/ehci-hcd.c
|
||||||
@@ -1354,17 +1354,21 @@ static int __init ehci_hcd_init(void)
|
@@ -1352,17 +1352,21 @@ static int __init ehci_hcd_init(void)
|
||||||
goto clean4;
|
goto clean4;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -174,7 +174,7 @@
|
|||||||
#ifdef XILINX_OF_PLATFORM_DRIVER
|
#ifdef XILINX_OF_PLATFORM_DRIVER
|
||||||
platform_driver_unregister(&XILINX_OF_PLATFORM_DRIVER);
|
platform_driver_unregister(&XILINX_OF_PLATFORM_DRIVER);
|
||||||
clean4:
|
clean4:
|
||||||
@@ -1397,9 +1401,11 @@ module_init(ehci_hcd_init);
|
@@ -1395,9 +1399,11 @@ module_init(ehci_hcd_init);
|
||||||
|
|
||||||
static void __exit ehci_hcd_cleanup(void)
|
static void __exit ehci_hcd_cleanup(void)
|
||||||
{
|
{
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/net/bridge/br_private.h
|
--- a/net/bridge/br_private.h
|
||||||
+++ b/net/bridge/br_private.h
|
+++ b/net/bridge/br_private.h
|
||||||
@@ -133,6 +133,7 @@ struct net_bridge_port
|
@@ -134,6 +134,7 @@ struct net_bridge_port
|
||||||
|
|
||||||
unsigned long flags;
|
unsigned long flags;
|
||||||
#define BR_HAIRPIN_MODE 0x00000001
|
#define BR_HAIRPIN_MODE 0x00000001
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
|
|
||||||
--- a/drivers/usb/host/pci-quirks.c
|
--- a/drivers/usb/host/pci-quirks.c
|
||||||
+++ b/drivers/usb/host/pci-quirks.c
|
+++ b/drivers/usb/host/pci-quirks.c
|
||||||
@@ -427,6 +427,8 @@ reset_needed:
|
@@ -429,6 +429,8 @@ reset_needed:
|
||||||
}
|
}
|
||||||
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
|
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
|
||||||
|
|
||||||
@ -10,7 +10,7 @@
|
|||||||
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
|
||||||
{
|
{
|
||||||
u16 cmd;
|
u16 cmd;
|
||||||
@@ -841,3 +843,5 @@ static void __devinit quirk_usb_early_ha
|
@@ -869,3 +871,5 @@ static void __devinit quirk_usb_early_ha
|
||||||
quirk_usb_handoff_xhci(pdev);
|
quirk_usb_handoff_xhci(pdev);
|
||||||
}
|
}
|
||||||
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
|
||||||
|
@ -79,7 +79,7 @@
|
|||||||
|
|
||||||
/**
|
/**
|
||||||
* zap_vma_ptes - remove ptes mapping the vma
|
* zap_vma_ptes - remove ptes mapping the vma
|
||||||
@@ -3015,6 +3016,7 @@ static inline int check_stack_guard_page
|
@@ -3071,6 +3072,7 @@ static inline int check_stack_guard_page
|
||||||
}
|
}
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=le be
|
|||||||
INITRAMFS_EXTRA_FILES:=
|
INITRAMFS_EXTRA_FILES:=
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
|
|||||||
CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
|
CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
|
|||||||
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.0
|
LINUX_VERSION:=3.0.1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user