uboot-tools: dumpimage: get rid of libopenssl dependency

Get rid of of dependency on libopenssl and refresh patches.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
Daniel Golle 2025-03-29 03:53:58 +00:00
parent a3b2689e88
commit 51b0abae52
3 changed files with 3 additions and 38 deletions

View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_DISTNAME:=u-boot
PKG_VERSION:=2025.01
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
@ -26,7 +26,6 @@ define Package/dumpimage
SECTION:=utils
CATEGORY:=Utilities
SUBMENU:=Boot Loaders
DEPENDS := +libopenssl
TITLE:=dumpimage lists and extracts data from U-Boot images.
URL:=http://www.denx.de/wiki/U-Boot
endef
@ -62,6 +61,7 @@ define Build/Configure
$(call Build/Compile/Default,tools-only_defconfig)
$(call Build/Compile/Default,syncconfig)
$(SED) 's/CONFIG_TOOLS_LIBCRYPTO=y/# CONFIG_TOOLS_LIBCRYPTO is not set/' $(PKG_BUILD_DIR)/.config
$(SED) 's/CONFIG_TOOLS_KWBIMAGE=y/# CONFIG_TOOLS_KWBIMAGE is not set/' $(PKG_BUILD_DIR)/.config
endef
MAKE_FLAGS += \

View File

@ -1,32 +0,0 @@
diff --git a/package/boot/u-boot-tools/patches/0001-tools-disable-kwbimage.patch b/package/boot/u-boot-tools/patches/0001-tools-disable-kwbimage.patch
new file mode 100644
index 0000000000..69a42ec383
--- /dev/null
+++ b/package/boot/u-boot-tools/patches/0001-tools-disable-kwbimage.patch
@@ -0,0 +1,25 @@
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal at milecki.pl>
+Date: Tue, 30 Nov 2021 11:29:19 +0100
+Subject: [PATCH] tools: disable kwbimage
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Without CONFIG_TOOLS_LIBCRYPTO kwbimage doesn't compile because of
+multiple "undefined reference"s to SSL functions.
+
+Signed-off-by: Rafał Miłecki <rafal at milecki.pl>
+---
+ tools/Makefile | 1 -
+ 1 file changed, 1 deletion(-)
+
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -117,7 +117,6 @@ dumpimage-mkimage-objs := aisimage.o \
+ imximage.o \
+ imx8image.o \
+ imx8mimage.o \
+- kwbimage.o \
+ lib/md5.o \
+ lpc32xximage.o \
+ mxsimage.o \

View File

@ -17,8 +17,6 @@ Signed-off-by: Scott Mercer <TheRootEd24@gmail.com>
tools/Makefile | 38 ++++++++++++++++++++++++++------------
1 file changed, 26 insertions(+), 12 deletions(-)
diff --git a/tools/Makefile b/tools/Makefile
index ee08a9675df8..a72b7909a066 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -22,6 +22,26 @@
@ -68,7 +66,7 @@ index ee08a9675df8..a72b7909a066 100644
mkfwumdata-objs := mkfwumdata.o generated/lib/crc32.o
HOSTLDLIBS_mkfwumdata += -luuid
@@ -313,10 +328,9 @@ HOST_EXTRACFLAGS += -include $(srctree)/include/compiler.h \
@@ -313,10 +328,9 @@ HOST_EXTRACFLAGS += -include $(srctree)/
-I$(srctree)/scripts/dtc/libfdt \
-I$(srctree)/tools \
-DUSE_HOSTCC \
@ -81,4 +79,3 @@ index ee08a9675df8..a72b7909a066 100644
$(LOGO_H): $(obj)/bmp_logo $(LOGO_BMP)
$(obj)/bmp_logo --gen-info $(LOGO_BMP) > $@