From 4abcae7a1cd1092e8fd3ef5aee4c97108917a4ad Mon Sep 17 00:00:00 2001
From: Steven Barth <cyrus@openwrt.org>
Date: Tue, 8 Apr 2014 06:19:37 +0000
Subject: [PATCH] ds-lite: compatibility with ISPs that only offer public PDs

SVN-Revision: 40422
---
 package/network/ipv6/ds-lite/Makefile        |  2 +-
 package/network/ipv6/ds-lite/files/dslite.sh | 12 ++++++++----
 2 files changed, 9 insertions(+), 5 deletions(-)

diff --git a/package/network/ipv6/ds-lite/Makefile b/package/network/ipv6/ds-lite/Makefile
index a806f67ab93..61c57c092c4 100644
--- a/package/network/ipv6/ds-lite/Makefile
+++ b/package/network/ipv6/ds-lite/Makefile
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ds-lite
-PKG_VERSION:=2
+PKG_VERSION:=3
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/ds-lite/files/dslite.sh b/package/network/ipv6/ds-lite/files/dslite.sh
index f4efa1c4c33..670f93cd6ec 100755
--- a/package/network/ipv6/ds-lite/files/dslite.sh
+++ b/package/network/ipv6/ds-lite/files/dslite.sh
@@ -14,8 +14,8 @@ proto_dslite_setup() {
 	local iface="$2"
 	local link="dslite-$cfg"
 
-	local mtu ttl peeraddr ip6addr tunlink zone
-	json_get_vars mtu ttl peeraddr ip6addr tunlink zone
+	local mtu ttl peeraddr ip6addr tunlink zone weakif
+	json_get_vars mtu ttl peeraddr ip6addr tunlink zone weakif
 
 	[ -z "$peeraddr" ] && {
 		proto_notify_error "$cfg" "MISSING_ADDRESS"
@@ -33,8 +33,11 @@ proto_dslite_setup() {
 		fi
 
 		if ! network_get_ipaddr6 ip6addr "$wanif"; then
-			proto_notify_error "$cfg" "NO_WAN_LINK"
-			return
+			[ -z "$weakif" ] && weakif="lan"
+			if ! network_get_ipaddr6 ip6addr "$weakif"; then
+				proto_notify_error "$cfg" "NO_WAN_LINK"
+				return
+			fi
 		fi
 	}
 
@@ -72,6 +75,7 @@ proto_dslite_init_config() {
 	proto_config_add_int "mtu"
 	proto_config_add_int "ttl"
 	proto_config_add_string "zone"
+	proto_config_add_string "weakif"
 }
 
 [ -n "$INCLUDE_ONLY" ] || {