From 4710134f128e9c784c3576c7f97530c11ea538ae Mon Sep 17 00:00:00 2001
From: Michael Pratt <mcpratt@pm.me>
Date: Tue, 25 Jun 2024 02:30:22 -0400
Subject: [PATCH] tools/coreutils: remove 64-bit time disable flag

This was added to support building coreutils on host systems
that still only have 32-bit time support.

Because other tools now also require the flag for building
with 32-bit time when support for 64-bit time is not present,
this flag is now added to all host builds
on a variable basis using the same test before building,
so it can now be removed from specific tools.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
Link: https://github.com/openwrt/openwrt/pull/15799
Signed-off-by: Robert Marko <robimarko@gmail.com>
---
 tools/coreutils/Makefile | 1 -
 1 file changed, 1 deletion(-)

diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index 5ef780d7d2f..73b95912ee1 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -29,7 +29,6 @@ HOST_GNULIB_SKIP := \
 	lib/locale.in.h
 
 HOST_CONFIGURE_ARGS += \
-	--disable-year2038 \
 	 --enable-install-program=$(subst $(space),$(comma),$(strip $(PKG_PROGRAMS)))
 
 HOST_MAKE_FLAGS += \