ksmbd: update to latest 3.4.8 release

Changelog: https://github.com/cifsd-team/ksmbd/releases/tag/3.4.8

Signed-off-by: Andrew Sim <andrewsimz@gmail.com>
(cherry picked from commit a247f49794)
Link: https://github.com/openwrt/openwrt/pull/15871
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
Andrew Sim 2023-04-18 18:54:01 +02:00 committed by Hauke Mehrtens
parent 456fd63e8f
commit 466198c9eb
2 changed files with 3 additions and 3 deletions

View File

@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ksmbd
PKG_VERSION:=3.4.7
PKG_VERSION:=3.4.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/cifsd-team/ksmbd/releases/download/$(PKG_VERSION)
PKG_HASH:=ed9ecb2232046054bf0c1fef41690890f99d93b1d72b7e7d158746ac9be18c7f
PKG_HASH:=209bfba4dc5c50007942a3ec24f86a7f7c628618ac07f79c62e3404dc247d495
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING

View File

@ -3,7 +3,7 @@ https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux
--- a/vfs.c
+++ b/vfs.c
@@ -1074,12 +1074,18 @@ static int __ksmbd_vfs_rename(struct ksm
@@ -1081,12 +1081,18 @@ static int __ksmbd_vfs_rename(struct ksm
err = -ENOTEMPTY;
if (dst_dent != trap_dent && !d_really_is_positive(dst_dent)) {