mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-07 11:30:37 +00:00
cleanup trailing whitespaces in 2.6.26 patches
SVN-Revision: 11945
This commit is contained in:
parent
4bc51e20f2
commit
44b51440ce
@ -35,23 +35,20 @@
|
|||||||
+
|
+
|
||||||
if (!dev->mtd.name)
|
if (!dev->mtd.name)
|
||||||
goto devinit_err;
|
goto devinit_err;
|
||||||
+
|
|
||||||
+ strcpy(dev->mtd.name, mtdname);
|
|
||||||
|
|
||||||
- sprintf(dev->mtd.name, "block2mtd: %s", devname);
|
- sprintf(dev->mtd.name, "block2mtd: %s", devname);
|
||||||
-
|
+ strcpy(dev->mtd.name, mtdname);
|
||||||
|
|
||||||
- dev->mtd.size = dev->blkdev->bd_inode->i_size & PAGE_MASK;
|
- dev->mtd.size = dev->blkdev->bd_inode->i_size & PAGE_MASK;
|
||||||
+ dev->mtd.size = dev->blkdev->bd_inode->i_size & PAGE_MASK & ~(erase_size - 1);
|
+ dev->mtd.size = dev->blkdev->bd_inode->i_size & PAGE_MASK & ~(erase_size - 1);
|
||||||
dev->mtd.erasesize = erase_size;
|
dev->mtd.erasesize = erase_size;
|
||||||
dev->mtd.writesize = 1;
|
dev->mtd.writesize = 1;
|
||||||
dev->mtd.type = MTD_RAM;
|
dev->mtd.type = MTD_RAM;
|
||||||
@@ -298,15 +304,18 @@
|
@@ -299,14 +305,17 @@
|
||||||
dev->mtd.read = block2mtd_read;
|
|
||||||
dev->mtd.priv = dev;
|
dev->mtd.priv = dev;
|
||||||
dev->mtd.owner = THIS_MODULE;
|
dev->mtd.owner = THIS_MODULE;
|
||||||
-
|
|
||||||
- if (add_mtd_device(&dev->mtd)) {
|
- if (add_mtd_device(&dev->mtd)) {
|
||||||
+
|
|
||||||
+ part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
+ part = kzalloc(sizeof(struct mtd_partition), GFP_KERNEL);
|
||||||
+ part->name = dev->mtd.name;
|
+ part->name = dev->mtd.name;
|
||||||
+ part->offset = 0;
|
+ part->offset = 0;
|
||||||
|
@ -20,13 +20,12 @@
|
|||||||
{
|
{
|
||||||
int length = 0, i;
|
int length = 0, i;
|
||||||
- int oldlength = master_conntrack->layer7.app_data_len;
|
- int oldlength = master_conntrack->layer7.app_data_len;
|
||||||
-
|
|
||||||
- /* This is a fix for a race condition by Deti Fliegl. However, I'm not
|
- /* This is a fix for a race condition by Deti Fliegl. However, I'm not
|
||||||
- clear on whether the race condition exists or whether this really
|
- clear on whether the race condition exists or whether this really
|
||||||
- fixes it. I might just be being dense... Anyway, if it's not really
|
- fixes it. I might just be being dense... Anyway, if it's not really
|
||||||
- a fix, all it does is waste a very small amount of time. */
|
- a fix, all it does is waste a very small amount of time. */
|
||||||
- if(!master_conntrack->layer7.app_data) return 0;
|
- if(!master_conntrack->layer7.app_data) return 0;
|
||||||
+
|
|
||||||
+ if (!target) return 0;
|
+ if (!target) return 0;
|
||||||
|
|
||||||
/* Strip nulls. Make everything lower case (our regex lib doesn't
|
/* Strip nulls. Make everything lower case (our regex lib doesn't
|
||||||
|
@ -20,14 +20,21 @@
|
|||||||
/* Now scan the directory tree, increasing nlink according to every dirent found. */
|
/* Now scan the directory tree, increasing nlink according to every dirent found. */
|
||||||
--- a/fs/jffs2/scan.c
|
--- a/fs/jffs2/scan.c
|
||||||
+++ b/fs/jffs2/scan.c
|
+++ b/fs/jffs2/scan.c
|
||||||
@@ -143,9 +143,12 @@
|
@@ -72,7 +72,7 @@
|
||||||
|
return ret;
|
||||||
|
if ((ret = jffs2_scan_dirty_space(c, jeb, jeb->free_size)))
|
||||||
|
return ret;
|
||||||
|
- /* Turned wasted size into dirty, since we apparently
|
||||||
|
+ /* Turned wasted size into dirty, since we apparently
|
||||||
|
think it's recoverable now. */
|
||||||
|
jeb->dirty_size += jeb->wasted_size;
|
||||||
|
c->dirty_size += jeb->wasted_size;
|
||||||
|
@@ -144,8 +144,11 @@
|
||||||
/* reset summary info for next eraseblock scan */
|
/* reset summary info for next eraseblock scan */
|
||||||
jffs2_sum_reset_collected(s);
|
jffs2_sum_reset_collected(s);
|
||||||
-
|
|
||||||
- ret = jffs2_scan_eraseblock(c, jeb, buf_size?flashbuf:(flashbuf+jeb->offset),
|
- ret = jffs2_scan_eraseblock(c, jeb, buf_size?flashbuf:(flashbuf+jeb->offset),
|
||||||
- buf_size, s);
|
- buf_size, s);
|
||||||
+
|
|
||||||
+ if (c->flags & (1 << 7))
|
+ if (c->flags & (1 << 7))
|
||||||
+ ret = BLK_STATE_ALLFF;
|
+ ret = BLK_STATE_ALLFF;
|
||||||
+ else
|
+ else
|
||||||
@ -36,6 +43,57 @@
|
|||||||
|
|
||||||
if (ret < 0)
|
if (ret < 0)
|
||||||
goto out;
|
goto out;
|
||||||
|
@@ -400,7 +403,7 @@
|
||||||
|
if (!ref)
|
||||||
|
return -ENOMEM;
|
||||||
|
|
||||||
|
- /* BEFORE jffs2_build_xattr_subsystem() called,
|
||||||
|
+ /* BEFORE jffs2_build_xattr_subsystem() called,
|
||||||
|
* and AFTER xattr_ref is marked as a dead xref,
|
||||||
|
* ref->xid is used to store 32bit xid, xd is not used
|
||||||
|
* ref->ino is used to store 32bit inode-number, ic is not used
|
||||||
|
@@ -473,7 +476,7 @@
|
||||||
|
struct jffs2_sum_marker *sm;
|
||||||
|
void *sumptr = NULL;
|
||||||
|
uint32_t sumlen;
|
||||||
|
-
|
||||||
|
+
|
||||||
|
if (!buf_size) {
|
||||||
|
/* XIP case. Just look, point at the summary if it's there */
|
||||||
|
sm = (void *)buf + c->sector_size - sizeof(*sm);
|
||||||
|
@@ -489,9 +492,9 @@
|
||||||
|
buf_len = sizeof(*sm);
|
||||||
|
|
||||||
|
/* Read as much as we want into the _end_ of the preallocated buffer */
|
||||||
|
- err = jffs2_fill_scan_buf(c, buf + buf_size - buf_len,
|
||||||
|
+ err = jffs2_fill_scan_buf(c, buf + buf_size - buf_len,
|
||||||
|
jeb->offset + c->sector_size - buf_len,
|
||||||
|
- buf_len);
|
||||||
|
+ buf_len);
|
||||||
|
if (err)
|
||||||
|
return err;
|
||||||
|
|
||||||
|
@@ -510,9 +513,9 @@
|
||||||
|
}
|
||||||
|
if (buf_len < sumlen) {
|
||||||
|
/* Need to read more so that the entire summary node is present */
|
||||||
|
- err = jffs2_fill_scan_buf(c, sumptr,
|
||||||
|
+ err = jffs2_fill_scan_buf(c, sumptr,
|
||||||
|
jeb->offset + c->sector_size - sumlen,
|
||||||
|
- sumlen - buf_len);
|
||||||
|
+ sumlen - buf_len);
|
||||||
|
if (err)
|
||||||
|
return err;
|
||||||
|
}
|
||||||
|
@@ -525,7 +528,7 @@
|
||||||
|
|
||||||
|
if (buf_size && sumlen > buf_size)
|
||||||
|
kfree(sumptr);
|
||||||
|
- /* If it returns with a real error, bail.
|
||||||
|
+ /* If it returns with a real error, bail.
|
||||||
|
If it returns positive, that's a block classification
|
||||||
|
(i.e. BLK_STATE_xxx) so return that too.
|
||||||
|
If it returns zero, fall through to full scan. */
|
||||||
@@ -546,6 +549,17 @@
|
@@ -546,6 +549,17 @@
|
||||||
return err;
|
return err;
|
||||||
}
|
}
|
||||||
@ -54,3 +112,21 @@
|
|||||||
/* We temporarily use 'ofs' as a pointer into the buffer/jeb */
|
/* We temporarily use 'ofs' as a pointer into the buffer/jeb */
|
||||||
ofs = 0;
|
ofs = 0;
|
||||||
|
|
||||||
|
@@ -671,7 +685,7 @@
|
||||||
|
scan_end = buf_len;
|
||||||
|
goto more_empty;
|
||||||
|
}
|
||||||
|
-
|
||||||
|
+
|
||||||
|
/* See how much more there is to read in this eraseblock... */
|
||||||
|
buf_len = min_t(uint32_t, buf_size, jeb->offset + c->sector_size - ofs);
|
||||||
|
if (!buf_len) {
|
||||||
|
@@ -907,7 +921,7 @@
|
||||||
|
|
||||||
|
D1(printk(KERN_DEBUG "Block at 0x%08x: free 0x%08x, dirty 0x%08x, unchecked 0x%08x, used 0x%08x, wasted 0x%08x\n",
|
||||||
|
jeb->offset,jeb->free_size, jeb->dirty_size, jeb->unchecked_size, jeb->used_size, jeb->wasted_size));
|
||||||
|
-
|
||||||
|
+
|
||||||
|
/* mark_node_obsolete can add to wasted !! */
|
||||||
|
if (jeb->wasted_size) {
|
||||||
|
jeb->dirty_size += jeb->wasted_size;
|
||||||
|
@ -51,6 +51,26 @@
|
|||||||
/**
|
/**
|
||||||
* phy_mii_ioctl - generic PHY MII ioctl interface
|
* phy_mii_ioctl - generic PHY MII ioctl interface
|
||||||
* @phydev: the phy_device struct
|
* @phydev: the phy_device struct
|
||||||
|
@@ -403,8 +447,8 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
phy_write(phydev, mii_data->reg_num, val);
|
||||||
|
-
|
||||||
|
- if (mii_data->reg_num == MII_BMCR
|
||||||
|
+
|
||||||
|
+ if (mii_data->reg_num == MII_BMCR
|
||||||
|
&& val & BMCR_RESET
|
||||||
|
&& phydev->drv->config_init) {
|
||||||
|
phy_scan_fixups(phydev);
|
||||||
|
@@ -524,7 +568,7 @@
|
||||||
|
int idx;
|
||||||
|
|
||||||
|
idx = phy_find_setting(phydev->speed, phydev->duplex);
|
||||||
|
-
|
||||||
|
+
|
||||||
|
idx++;
|
||||||
|
|
||||||
|
idx = phy_find_valid(idx, phydev->supported);
|
||||||
--- a/include/linux/phy.h
|
--- a/include/linux/phy.h
|
||||||
+++ b/include/linux/phy.h
|
+++ b/include/linux/phy.h
|
||||||
@@ -434,6 +434,7 @@
|
@@ -434,6 +434,7 @@
|
||||||
|
@ -573,7 +573,12 @@
|
|||||||
/* max = 24: 128bit encrypt, max = 32: 256bit encrypt */
|
/* max = 24: 128bit encrypt, max = 32: 256bit encrypt */
|
||||||
--- a/crypto/crc32c.c
|
--- a/crypto/crc32c.c
|
||||||
+++ b/crypto/crc32c.c
|
+++ b/crypto/crc32c.c
|
||||||
@@ -5,20 +5,23 @@
|
@@ -1,24 +1,27 @@
|
||||||
|
-/*
|
||||||
|
+/*
|
||||||
|
* Cryptographic API.
|
||||||
|
*
|
||||||
|
* CRC32C chksum
|
||||||
*
|
*
|
||||||
* This module file is a wrapper to invoke the lib/crc32c routines.
|
* This module file is a wrapper to invoke the lib/crc32c routines.
|
||||||
*
|
*
|
||||||
@ -581,7 +586,8 @@
|
|||||||
+ *
|
+ *
|
||||||
* This program is free software; you can redistribute it and/or modify it
|
* This program is free software; you can redistribute it and/or modify it
|
||||||
* under the terms of the GNU General Public License as published by the Free
|
* under the terms of the GNU General Public License as published by the Free
|
||||||
* Software Foundation; either version 2 of the License, or (at your option)
|
- * Software Foundation; either version 2 of the License, or (at your option)
|
||||||
|
+ * Software Foundation; either version 2 of the License, or (at your option)
|
||||||
* any later version.
|
* any later version.
|
||||||
*
|
*
|
||||||
*/
|
*/
|
||||||
@ -599,7 +605,21 @@
|
|||||||
#define CHKSUM_DIGEST_SIZE 4
|
#define CHKSUM_DIGEST_SIZE 4
|
||||||
|
|
||||||
struct chksum_ctx {
|
struct chksum_ctx {
|
||||||
@@ -71,7 +74,7 @@
|
@@ -27,7 +30,7 @@
|
||||||
|
};
|
||||||
|
|
||||||
|
/*
|
||||||
|
- * Steps through buffer one byte at at time, calculates reflected
|
||||||
|
+ * Steps through buffer one byte at at time, calculates reflected
|
||||||
|
* crc using table.
|
||||||
|
*/
|
||||||
|
|
||||||
|
@@ -67,11 +70,11 @@
|
||||||
|
static void chksum_final(struct crypto_tfm *tfm, u8 *out)
|
||||||
|
{
|
||||||
|
struct chksum_ctx *mctx = crypto_tfm_ctx(tfm);
|
||||||
|
-
|
||||||
|
+
|
||||||
*(__le32 *)out = ~cpu_to_le32(mctx->crc);
|
*(__le32 *)out = ~cpu_to_le32(mctx->crc);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -26,11 +26,9 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
|
|||||||
Signed-off-by: Jeff Garzik <jgarzik@redhat.com>
|
Signed-off-by: Jeff Garzik <jgarzik@redhat.com>
|
||||||
---
|
---
|
||||||
|
|
||||||
diff --git a/drivers/net/Makefile b/drivers/net/Makefile
|
|
||||||
index c52738a..c96fe20 100644
|
|
||||||
--- a/drivers/net/Makefile
|
--- a/drivers/net/Makefile
|
||||||
+++ b/drivers/net/Makefile
|
+++ b/drivers/net/Makefile
|
||||||
@@ -237,6 +237,7 @@ obj-$(CONFIG_USB_CATC) += usb/
|
@@ -237,6 +237,7 @@
|
||||||
obj-$(CONFIG_USB_KAWETH) += usb/
|
obj-$(CONFIG_USB_KAWETH) += usb/
|
||||||
obj-$(CONFIG_USB_PEGASUS) += usb/
|
obj-$(CONFIG_USB_PEGASUS) += usb/
|
||||||
obj-$(CONFIG_USB_RTL8150) += usb/
|
obj-$(CONFIG_USB_RTL8150) += usb/
|
||||||
@ -38,11 +36,9 @@ index c52738a..c96fe20 100644
|
|||||||
obj-$(CONFIG_USB_USBNET) += usb/
|
obj-$(CONFIG_USB_USBNET) += usb/
|
||||||
obj-$(CONFIG_USB_ZD1201) += usb/
|
obj-$(CONFIG_USB_ZD1201) += usb/
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/Kconfig b/drivers/net/usb/Kconfig
|
|
||||||
index 0604f3f..68e198b 100644
|
|
||||||
--- a/drivers/net/usb/Kconfig
|
--- a/drivers/net/usb/Kconfig
|
||||||
+++ b/drivers/net/usb/Kconfig
|
+++ b/drivers/net/usb/Kconfig
|
||||||
@@ -154,6 +154,16 @@ config USB_NET_AX8817X
|
@@ -154,6 +154,16 @@
|
||||||
This driver creates an interface named "ethX", where X depends on
|
This driver creates an interface named "ethX", where X depends on
|
||||||
what other networking devices you have in use.
|
what other networking devices you have in use.
|
||||||
|
|
||||||
@ -59,11 +55,9 @@ index 0604f3f..68e198b 100644
|
|||||||
|
|
||||||
config USB_NET_CDCETHER
|
config USB_NET_CDCETHER
|
||||||
tristate "CDC Ethernet support (smart devices such as cable modems)"
|
tristate "CDC Ethernet support (smart devices such as cable modems)"
|
||||||
diff --git a/drivers/net/usb/Makefile b/drivers/net/usb/Makefile
|
|
||||||
index 595a539..24800c1 100644
|
|
||||||
--- a/drivers/net/usb/Makefile
|
--- a/drivers/net/usb/Makefile
|
||||||
+++ b/drivers/net/usb/Makefile
|
+++ b/drivers/net/usb/Makefile
|
||||||
@@ -6,6 +6,7 @@ obj-$(CONFIG_USB_CATC) += catc.o
|
@@ -6,6 +6,7 @@
|
||||||
obj-$(CONFIG_USB_KAWETH) += kaweth.o
|
obj-$(CONFIG_USB_KAWETH) += kaweth.o
|
||||||
obj-$(CONFIG_USB_PEGASUS) += pegasus.o
|
obj-$(CONFIG_USB_PEGASUS) += pegasus.o
|
||||||
obj-$(CONFIG_USB_RTL8150) += rtl8150.o
|
obj-$(CONFIG_USB_RTL8150) += rtl8150.o
|
||||||
@ -71,9 +65,6 @@ index 595a539..24800c1 100644
|
|||||||
obj-$(CONFIG_USB_NET_AX8817X) += asix.o
|
obj-$(CONFIG_USB_NET_AX8817X) += asix.o
|
||||||
obj-$(CONFIG_USB_NET_CDCETHER) += cdc_ether.o
|
obj-$(CONFIG_USB_NET_CDCETHER) += cdc_ether.o
|
||||||
obj-$(CONFIG_USB_NET_DM9601) += dm9601.o
|
obj-$(CONFIG_USB_NET_DM9601) += dm9601.o
|
||||||
diff --git a/drivers/net/usb/hso.c b/drivers/net/usb/hso.c
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..031d07b
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/drivers/net/usb/hso.c
|
+++ b/drivers/net/usb/hso.c
|
||||||
@@ -0,0 +1,2836 @@
|
@@ -0,0 +1,2836 @@
|
||||||
|
Loading…
x
Reference in New Issue
Block a user