diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index 3811f33aa1d..9baae6fcd45 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.27.10
+LINUX_VERSION:=2.6.28
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/avr32/config-default b/target/linux/avr32/config-default
index 7650a1294be..e8ebea5512b 100644
--- a/target/linux/avr32/config-default
+++ b/target/linux/avr32/config-default
@@ -18,8 +18,11 @@ CONFIG_ATMEL_TCLIB=y
 CONFIG_AVR32=y
 CONFIG_BASE_SMALL=0
 CONFIG_BITREVERSE=y
+# CONFIG_BOARD_ATNGW100_EVKLCD10X is not set
 CONFIG_BOARD_ATNGW100=y
 # CONFIG_BOARD_ATSTK1000 is not set
+# CONFIG_BOARD_FAVR_32 is not set
+# CONFIG_BOARD_MIMC200 is not set
 # CONFIG_BROADCOM_PHY is not set
 # CONFIG_BT is not set
 CONFIG_CLASSIC_RCU=y
@@ -96,6 +99,8 @@ CONFIG_MTD_CMDLINE_PARTS=y
 # CONFIG_MTD_COMPLEX_MAPPINGS is not set
 # CONFIG_MTD_CONCAT is not set
 CONFIG_MTD_DATAFLASH=y
+# CONFIG_MTD_DATAFLASH_OTP is not set
+# CONFIG_MTD_DATAFLASH_WRITE_VERIFY is not set
 CONFIG_MTD_GEN_PROBE=y
 # CONFIG_MTD_JEDECPROBE is not set
 CONFIG_MTD_MAP_BANK_WIDTH_1=y
diff --git a/target/linux/avr32/patches/100-remove_build-id.patch b/target/linux/avr32/patches/100-remove_build-id.patch
deleted file mode 100644
index 1125d557a2c..00000000000
--- a/target/linux/avr32/patches/100-remove_build-id.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/avr32/boot/images/Makefile
-+++ b/arch/avr32/boot/images/Makefile
-@@ -10,7 +10,7 @@ MKIMAGE		:= $(srctree)/scripts/mkuboot.s
- 
- extra-y		:= vmlinux.bin vmlinux.gz
- 
--OBJCOPYFLAGS_vmlinux.bin := -O binary
-+OBJCOPYFLAGS_vmlinux.bin := -O binary -R .note.gnu.build-id
- $(obj)/vmlinux.bin: vmlinux FORCE
- 	$(call if_changed,objcopy)
- 
diff --git a/target/linux/generic-2.6/config-2.6.28 b/target/linux/generic-2.6/config-2.6.28
index 5408f9719e8..79329aa641a 100644
--- a/target/linux/generic-2.6/config-2.6.28
+++ b/target/linux/generic-2.6/config-2.6.28
@@ -1284,7 +1284,9 @@ CONFIG_RPCSEC_GSS_KRB5=m
 # CONFIG_RTC_DRV_BQ4802 is not set
 CONFIG_RTC_DRV_CMOS=y
 # CONFIG_RTC_DRV_DS1286 is not set
+# CONFIG_RTC_DRV_DS1390 is not set
 # CONFIG_RTC_DRV_DS1511 is not set
+# CONFIG_RTC_DRV_DS3234 is not set
 # CONFIG_RTC_DRV_FM3130 is not set
 # CONFIG_RTC_DRV_M48T35 is not set
 # CONFIG_RTC_DRV_MAX6900 is not set
@@ -1638,6 +1640,7 @@ CONFIG_SQUASHFS_FRAGMENT_CACHE_SIZE=3
 # CONFIG_SSB_SILENT is not set
 # CONFIG_SSFDC is not set
 CONFIG_STACKTRACE_SUPPORT=y
+# CONFIG_STAGING is not set
 CONFIG_STANDALONE=y
 CONFIG_STP=y
 # CONFIG_STRIP is not set