mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
use u-boot v2010.12
SVN-Revision: 24809
This commit is contained in:
parent
acb5e80846
commit
3d501f9403
@ -7,11 +7,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mkimage
|
PKG_NAME:=mkimage
|
||||||
PKG_VERSION:=2009.11
|
PKG_VERSION:=2010.12
|
||||||
|
|
||||||
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
|
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
|
||||||
PKG_MD5SUM:=d94700614225f53c853dfe714eb5fa47
|
PKG_MD5SUM:=9024bbceabd176ae1d52df6db2e84bda
|
||||||
PKG_CAT:=bzcat
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
||||||
@ -20,8 +20,8 @@ include $(INCLUDE_DIR)/host-build.mk
|
|||||||
|
|
||||||
define Host/Compile
|
define Host/Compile
|
||||||
rm -f $(HOST_BUILD_DIR)/tools/.depend
|
rm -f $(HOST_BUILD_DIR)/tools/.depend
|
||||||
touch $(HOST_BUILD_DIR)/include/config.{h,mk} $(HOST_BUILD_DIR)/include/autoconf.mk{.dep,}
|
touch $(HOST_BUILD_DIR)/include/config.h
|
||||||
$(MAKE) -C $(HOST_BUILD_DIR) BUILD_DIR= SUBDIRS=tools BIN_FILES-y="mkimage" tools
|
$(MAKE) -C $(HOST_BUILD_DIR) BUILD_DIR= BIN_FILES-y="mkimage" tools
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Install
|
define Host/Install
|
||||||
|
@ -33,7 +33,7 @@
|
|||||||
* 1. Abstracting input command line arguments data
|
* 1. Abstracting input command line arguments data
|
||||||
--- a/include/image.h
|
--- a/include/image.h
|
||||||
+++ b/include/image.h
|
+++ b/include/image.h
|
||||||
@@ -49,6 +49,10 @@
|
@@ -50,6 +50,10 @@
|
||||||
|
|
||||||
#endif /* USE_HOSTCC */
|
#endif /* USE_HOSTCC */
|
||||||
|
|
||||||
@ -41,6 +41,6 @@
|
|||||||
+#define ulong unsigned long
|
+#define ulong unsigned long
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
#include <command.h>
|
|
||||||
|
|
||||||
#if defined(CONFIG_FIT)
|
#if defined(CONFIG_FIT)
|
||||||
|
#include <fdt.h>
|
||||||
|
#include <libfdt.h>
|
||||||
|
Loading…
Reference in New Issue
Block a user