mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-31 16:35:44 +00:00
ath79: remove SPI driver link order hack
This hack is used to make sure that the mfd device starts before the mtd driver[1]. Now the linux driver framework "struct spi_driver {}" can always ensure this. [1] 47f8fd1dde5d ("ar71xx: rewrite SPI drivers for the RB4xx boards") Signed-off-by: Shiji Yang <yangshiji66@qq.com>
This commit is contained in:
parent
f444dea428
commit
354690ebc9
@ -1,20 +0,0 @@
|
||||
From: Gabor Juhos <juhosg@openwrt.org>
|
||||
Subject: [PATCH] ar71xx: Link SPI before MTD
|
||||
|
||||
SVN-Revision: 22863
|
||||
---
|
||||
drivers/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/drivers/Makefile
|
||||
+++ b/drivers/Makefile
|
||||
@@ -87,8 +87,8 @@ obj-y += scsi/
|
||||
obj-y += nvme/
|
||||
obj-$(CONFIG_ATA) += ata/
|
||||
obj-$(CONFIG_TARGET_CORE) += target/
|
||||
-obj-$(CONFIG_MTD) += mtd/
|
||||
obj-$(CONFIG_SPI) += spi/
|
||||
+obj-$(CONFIG_MTD) += mtd/
|
||||
obj-$(CONFIG_SPMI) += spmi/
|
||||
obj-$(CONFIG_HSI) += hsi/
|
||||
obj-$(CONFIG_SLIMBUS) += slimbus/
|
Loading…
x
Reference in New Issue
Block a user