tools: refresh all patches

Refresh all tools patches now that tools/refresh correctly works.

CI now checks for them and actively complain if tools have unrefreshed
patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
[ reword commit message ]
Link: https://github.com/openwrt/openwrt/pull/15524
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
Rosen Penev 2024-05-18 12:14:20 -07:00 committed by Christian Marangi
parent 8097aa0b32
commit 337b0c80cb
No known key found for this signature in database
GPG Key ID: AC001D09ADBFEAD7
9 changed files with 44 additions and 71 deletions

View File

@ -1,6 +1,6 @@
--- elftosb-10.12.01/makefile.rules 2012-03-15 11:01:44.979020178 -0400 --- a/makefile.rules
+++ elftosb-10.12.01/makefile.rules 2012-03-15 11:01:16.332761989 -0400 +++ b/makefile.rules
@@ -101,7 +101,7 @@ @@ -101,7 +101,7 @@ OBJ_FILES_KEYGEN = \
keygen.o keygen.o

View File

@ -5,9 +5,8 @@ others once multiarch becomes more common.
This patch makes the types a relative path, and allows the system This patch makes the types a relative path, and allows the system
to use whatever include paths it feels are correct. to use whatever include paths it feels are correct.
diff -Naurp elftosb-10.12.01-orig/common/stdafx.h elftosb-10.12.01/common/stdafx.h --- a/common/stdafx.h
--- elftosb-10.12.01-orig/common/stdafx.h 2012-07-12 13:30:10.990249396 -0400 +++ b/common/stdafx.h
+++ elftosb-10.12.01/common/stdafx.h 2012-07-12 13:30:06.858249391 -0400
@@ -27,7 +27,7 @@ @@ -27,7 +27,7 @@
// For Linux systems only, types.h only defines the signed // For Linux systems only, types.h only defines the signed
// integer types. This is not professional code. // integer types. This is not professional code.

View File

@ -1,6 +1,6 @@
--- a/CMakeLists.txt 2022-11-28 06:34:39.171209779 -0800 --- a/CMakeLists.txt
+++ b/CMakeLists.txt 2022-11-28 06:33:13.368239757 -0800 +++ b/CMakeLists.txt
@@ -51,8 +51,11 @@ @@ -51,8 +51,11 @@ endif()
project(lzo VERSION 2.10 LANGUAGES C) project(lzo VERSION 2.10 LANGUAGES C)
# configuration options # configuration options
@ -14,7 +14,7 @@
if(NOT ENABLE_STATIC AND NOT ENABLE_SHARED) if(NOT ENABLE_STATIC AND NOT ENABLE_SHARED)
set(ENABLE_STATIC ON) set(ENABLE_STATIC ON)
endif() endif()
@@ -127,14 +130,20 @@ @@ -127,14 +130,20 @@ macro(lzo_add_executable t)
endif() endif()
endmacro() endmacro()
# main test driver # main test driver
@ -35,7 +35,7 @@
# some boring internal test programs # some boring internal test programs
if(0) if(0)
lzo_add_executable(align tests/align.c) lzo_add_executable(align tests/align.c)
@@ -144,7 +153,7 @@ @@ -144,7 +153,7 @@ if(0)
endif() endif()
# miniLZO # miniLZO
@ -44,7 +44,7 @@
add_executable(testmini minilzo/testmini.c minilzo/minilzo.c) add_executable(testmini minilzo/testmini.c minilzo/minilzo.c)
target_include_directories(testmini PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include/lzo") # needed for "lzoconf.h" target_include_directories(testmini PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include/lzo") # needed for "lzoconf.h"
endif() endif()
@@ -263,8 +272,10 @@ @@ -263,8 +272,10 @@ add_test(NAME lzotest-03 COMMAND lzotest
if(DEFINED CMAKE_INSTALL_FULL_LIBDIR) if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)
@ -57,7 +57,7 @@
set(f include/lzo/lzo1.h include/lzo/lzo1a.h include/lzo/lzo1b.h set(f include/lzo/lzo1.h include/lzo/lzo1a.h include/lzo/lzo1b.h
include/lzo/lzo1c.h include/lzo/lzo1f.h include/lzo/lzo1x.h include/lzo/lzo1c.h include/lzo/lzo1f.h include/lzo/lzo1x.h
@@ -285,7 +296,7 @@ @@ -285,7 +296,7 @@ if(ENABLE_SHARED)
) )
endif() endif()

View File

@ -1,8 +1,6 @@
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc --- a/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
=================================================================== +++ b/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
--- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-05-15 23:33:51.000000000 +0200 @@ -3,7 +3,7 @@ CXX = g++ -O2 -Wall
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:00:54.000000000 +0200
@@ -3,7 +3,7 @@
CXX_C = gcc -O2 -Wall CXX_C = gcc -O2 -Wall
LIB = -lm LIB = -lm
RM = rm -f RM = rm -f

View File

@ -1,7 +1,5 @@
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp --- /dev/null
=================================================================== +++ b/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp 2009-06-01 22:01:10.000000000 +0200
@@ -0,0 +1,895 @@ @@ -0,0 +1,895 @@
+/* +/*
+ * LZMA command line tool similar to gzip to encode and decode LZMA files. + * LZMA command line tool similar to gzip to encode and decode LZMA files.
@ -898,10 +896,8 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
+ return STATUS_OK; + return STATUS_OK;
+} +}
+ +
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h --- /dev/null
=================================================================== +++ b/CPP/7zip/Compress/LZMA_Alone/Exception.h
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h 2009-06-01 22:01:10.000000000 +0200
@@ -0,0 +1,45 @@ @@ -0,0 +1,45 @@
+/* A couple of exceptions for lzmp. +/* A couple of exceptions for lzmp.
+ * + *
@ -948,10 +944,8 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h
+ +
+#endif +#endif
+ +
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc --- a/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
=================================================================== +++ b/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
--- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:00:54.000000000 +0200
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:06:13.000000000 +0200
@@ -1,9 +1,10 @@ @@ -1,9 +1,10 @@
-PROG = lzma -PROG = lzma
+PROG = lzma_alone +PROG = lzma_alone
@ -965,7 +959,7 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
ifdef SystemDrive ifdef SystemDrive
IS_MINGW = 1 IS_MINGW = 1
@@ -45,12 +46,35 @@ @@ -45,12 +46,35 @@ OBJS = \
Lzma86Dec.o \ Lzma86Dec.o \
Lzma86Enc.o \ Lzma86Enc.o \
@ -1002,17 +996,15 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
LzmaAlone.o: LzmaAlone.cpp LzmaAlone.o: LzmaAlone.cpp
$(CXX) $(CFLAGS) LzmaAlone.cpp $(CXX) $(CFLAGS) LzmaAlone.cpp
@@ -131,5 +153,5 @@ @@ -131,5 +155,5 @@ Lzma86Enc.o: ../../../../C/LzmaUtil/Lzma
$(CXX_C) $(CFLAGS) ../../../../C/LzmaUtil/Lzma86Enc.c $(CXX_C) $(CFLAGS) ../../../../C/LzmaUtil/Lzma86Enc.c
clean: clean:
- -$(RM) $(PROG) $(OBJS) - -$(RM) $(PROG) $(OBJS)
+ -$(RM) $(PROG) $(PROG2) $(OBJS) + -$(RM) $(PROG) $(PROG2) $(OBJS)
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h --- /dev/null
=================================================================== +++ b/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h 2009-06-01 22:01:10.000000000 +0200
@@ -0,0 +1,31 @@ @@ -0,0 +1,31 @@
+#ifndef LZMA_VERSION_H +#ifndef LZMA_VERSION_H
+#define LZMA_VERSION_H +#define LZMA_VERSION_H
@ -1045,11 +1037,9 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
+ "named COPYING.\n"; + "named COPYING.\n";
+ +
+#endif /* ifndef LZMA_VERSION_H */ +#endif /* ifndef LZMA_VERSION_H */
Index: lzma-4.65/CPP/Common/C_FileIO.h --- a/CPP/Common/C_FileIO.h
=================================================================== +++ b/CPP/Common/C_FileIO.h
--- lzma-4.65.orig/CPP/Common/C_FileIO.h 2009-05-15 23:33:51.000000000 +0200 @@ -24,6 +24,7 @@ public:
+++ lzma-4.65/CPP/Common/C_FileIO.h 2009-06-01 22:06:56.000000000 +0200
@@ -24,6 +24,7 @@
bool Close(); bool Close();
bool GetLength(UInt64 &length) const; bool GetLength(UInt64 &length) const;
off_t Seek(off_t distanceToMove, int moveMethod) const; off_t Seek(off_t distanceToMove, int moveMethod) const;

View File

@ -1,7 +1,6 @@
diff -urN lzma-4.65/CPP/7zip/Common/FileStreams.h lzma-4.65.new/CPP/7zip/Common/FileStreams.h --- a/CPP/7zip/Common/FileStreams.h
--- lzma-4.65/CPP/7zip/Common/FileStreams.h 2009-05-15 23:33:51.000000000 +0200 +++ b/CPP/7zip/Common/FileStreams.h
+++ lzma-4.65.new/CPP/7zip/Common/FileStreams.h 2009-06-01 22:30:01.000000000 +0200 @@ -72,6 +72,7 @@ class COutFileStream:
@@ -72,6 +72,7 @@
public IOutStream, public IOutStream,
public CMyUnknownImp public CMyUnknownImp
{ {
@ -9,10 +8,9 @@ diff -urN lzma-4.65/CPP/7zip/Common/FileStreams.h lzma-4.65.new/CPP/7zip/Common/
#ifdef USE_WIN_FILE #ifdef USE_WIN_FILE
NWindows::NFile::NIO::COutFile File; NWindows::NFile::NIO::COutFile File;
#else #else
diff -urN lzma-4.65/CPP/Common/MyWindows.h lzma-4.65.new/CPP/Common/MyWindows.h --- a/CPP/Common/MyWindows.h
--- lzma-4.65/CPP/Common/MyWindows.h 2009-05-15 23:33:51.000000000 +0200 +++ b/CPP/Common/MyWindows.h
+++ lzma-4.65.new/CPP/Common/MyWindows.h 2009-06-01 22:29:26.000000000 +0200 @@ -101,8 +101,11 @@ typedef LONG SCODE;
@@ -101,8 +101,11 @@
#ifdef __cplusplus #ifdef __cplusplus

View File

@ -1,6 +1,6 @@
--- a/CMakeLists.txt 2017-08-10 04:19:45.000000000 -0700 --- a/CMakeLists.txt
+++ b/CMakeLists.txt 2022-11-28 17:21:03.453548350 -0800 +++ b/CMakeLists.txt
@@ -50,6 +50,9 @@ @@ -50,6 +50,9 @@ endif()
project(lzop VERSION 1.04 LANGUAGES C) project(lzop VERSION 1.04 LANGUAGES C)
@ -10,7 +10,7 @@
# install directories # install directories
if(NOT CMAKE_INSTALL_PREFIX) if(NOT CMAKE_INSTALL_PREFIX)
message(FATAL_ERROR "ERROR: CMAKE_INSTALL_PREFIX is not defined.") message(FATAL_ERROR "ERROR: CMAKE_INSTALL_PREFIX is not defined.")
@@ -186,9 +189,11 @@ @@ -186,9 +189,11 @@ if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)
install(TARGETS lzop DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}") install(TARGETS lzop DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}")

View File

@ -14,8 +14,6 @@ with O_CREAT | O_EXCL to avoid following symlinks in that case as well.
src/util.c | 14 +++++++++++--- src/util.c | 14 +++++++++++---
2 files changed, 21 insertions(+), 5 deletions(-) 2 files changed, 21 insertions(+), 5 deletions(-)
diff --git a/src/inp.c b/src/inp.c
index 32d0919..22d7473 100644
--- a/src/inp.c --- a/src/inp.c
+++ b/src/inp.c +++ b/src/inp.c
@@ -238,8 +238,13 @@ plan_a (char const *filename) @@ -238,8 +238,13 @@ plan_a (char const *filename)
@ -52,11 +50,9 @@ index 32d0919..22d7473 100644
|| ! (ifp = fdopen (ifd, binary_transput ? "rb" : "r"))) || ! (ifp = fdopen (ifd, binary_transput ? "rb" : "r")))
pfatal ("Can't open file %s", quotearg (filename)); pfatal ("Can't open file %s", quotearg (filename));
if (TMPINNAME_needs_removal) if (TMPINNAME_needs_removal)
diff --git a/src/util.c b/src/util.c
index 1cc08ba..fb38307 100644
--- a/src/util.c --- a/src/util.c
+++ b/src/util.c +++ b/src/util.c
@@ -388,7 +388,7 @@ create_backup (char const *to, const struct stat *to_st, bool leave_original) @@ -388,7 +388,7 @@ create_backup (char const *to, const str
try_makedirs_errno = ENOENT; try_makedirs_errno = ENOENT;
safe_unlink (bakname); safe_unlink (bakname);
@ -65,7 +61,7 @@ index 1cc08ba..fb38307 100644
{ {
if (errno != try_makedirs_errno) if (errno != try_makedirs_errno)
pfatal ("Can't create file %s", quotearg (bakname)); pfatal ("Can't create file %s", quotearg (bakname));
@@ -579,10 +579,13 @@ create_file (char const *file, int open_flags, mode_t mode, @@ -579,10 +579,13 @@ create_file (char const *file, int open_
static void static void
copy_to_fd (const char *from, int tofd) copy_to_fd (const char *from, int tofd)
{ {
@ -80,7 +76,7 @@ index 1cc08ba..fb38307 100644
pfatal ("Can't reopen file %s", quotearg (from)); pfatal ("Can't reopen file %s", quotearg (from));
while ((i = read (fromfd, buf, bufsize)) != 0) while ((i = read (fromfd, buf, bufsize)) != 0)
{ {
@@ -625,6 +628,8 @@ copy_file (char const *from, char const *to, struct stat *tost, @@ -625,6 +628,8 @@ copy_file (char const *from, char const
else else
{ {
assert (S_ISREG (mode)); assert (S_ISREG (mode));
@ -89,7 +85,7 @@ index 1cc08ba..fb38307 100644
tofd = create_file (to, O_WRONLY | O_BINARY | to_flags, mode, tofd = create_file (to, O_WRONLY | O_BINARY | to_flags, mode,
to_dir_known_to_exist); to_dir_known_to_exist);
copy_to_fd (from, tofd); copy_to_fd (from, tofd);
@@ -640,9 +645,12 @@ copy_file (char const *from, char const *to, struct stat *tost, @@ -640,9 +645,12 @@ copy_file (char const *from, char const
void void
append_to_file (char const *from, char const *to) append_to_file (char const *from, char const *to)
{ {
@ -103,6 +99,3 @@ index 1cc08ba..fb38307 100644
pfatal ("Can't reopen file %s", quotearg (to)); pfatal ("Can't reopen file %s", quotearg (to));
copy_to_fd (from, tofd); copy_to_fd (from, tofd);
if (close (tofd) != 0) if (close (tofd) != 0)
--
cgit v1.0-41-gc330

View File

@ -9,11 +9,9 @@ command to avoid quoting vulnerabilities.
src/pch.c | 6 ++---- src/pch.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-) 1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/src/pch.c b/src/pch.c
index 4fd5a05..16e001a 100644
--- a/src/pch.c --- a/src/pch.c
+++ b/src/pch.c +++ b/src/pch.c
@@ -2459,9 +2459,6 @@ do_ed_script (char const *inname, char const *outname, @@ -2459,9 +2459,6 @@ do_ed_script (char const *inname, char c
*outname_needs_removal = true; *outname_needs_removal = true;
copy_file (inname, outname, 0, exclusive, instat.st_mode, true); copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
} }
@ -23,7 +21,7 @@ index 4fd5a05..16e001a 100644
fflush (stdout); fflush (stdout);
pid = fork(); pid = fork();
@@ -2470,7 +2467,8 @@ do_ed_script (char const *inname, char const *outname, @@ -2470,7 +2467,8 @@ do_ed_script (char const *inname, char c
else if (pid == 0) else if (pid == 0)
{ {
dup2 (tmpfd, 0); dup2 (tmpfd, 0);
@ -33,6 +31,3 @@ index 4fd5a05..16e001a 100644
_exit (2); _exit (2);
} }
else else
--
cgit v1.0-41-gc330