mirror of
https://github.com/openwrt/openwrt.git
synced 2025-04-09 20:31:59 +00:00
kernel: bump 4.9 to 4.9.171
Refreshed all patches. Altered patches: - 150-bridge_allow_receiption_on_disabled_port.patch - 201-extra_optimization.patch Compile-tested on: ar71xx Runtime-tested on: ar71xx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
e0505cc018
commit
2faceb1a39
@ -2,10 +2,10 @@
|
||||
|
||||
LINUX_RELEASE?=1
|
||||
|
||||
LINUX_VERSION-4.9 = .170
|
||||
LINUX_VERSION-4.9 = .171
|
||||
LINUX_VERSION-4.14 = .113
|
||||
|
||||
LINUX_KERNEL_HASH-4.9.170 = 33887b40fc8e0b71f423bb7afe112a4ae190378145f4a3f3892c563b7e43131d
|
||||
LINUX_KERNEL_HASH-4.9.171 = 431cd992bf74da9851dd5938dbe45ff7577219b84b237ae5e30067d483b57f01
|
||||
LINUX_KERNEL_HASH-4.14.113 = b24df2e37faaf2290999c507f9e29de98494f52429bcd35513c5b3e52eaddac2
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1227,7 +1227,6 @@ all: modules
|
||||
@@ -1226,7 +1226,6 @@ all: modules
|
||||
|
||||
PHONY += modules
|
||||
modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
|
||||
@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
@$(kecho) ' Building modules, stage 2.';
|
||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
|
||||
$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
|
||||
@@ -1257,7 +1256,6 @@ _modinst_:
|
||||
@@ -1256,7 +1255,6 @@ _modinst_:
|
||||
rm -f $(MODLIB)/build ; \
|
||||
ln -s $(CURDIR) $(MODLIB)/build ; \
|
||||
fi
|
||||
|
@ -43,8 +43,8 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
||||
-endif
|
||||
-
|
||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||
KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
|
||||
KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
|
||||
KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
|
||||
else
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -81,6 +81,7 @@ config ARM
|
||||
|
@ -244,7 +244,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
}
|
||||
--- a/mm/vmstat.c
|
||||
+++ b/mm/vmstat.c
|
||||
@@ -1798,10 +1798,12 @@ static int __init setup_vmstat(void)
|
||||
@@ -1793,10 +1793,12 @@ static int __init setup_vmstat(void)
|
||||
cpu_notifier_register_done();
|
||||
#endif
|
||||
#ifdef CONFIG_PROC_FS
|
||||
|
@ -15,17 +15,19 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
|
||||
--- a/net/bridge/br_input.c
|
||||
+++ b/net/bridge/br_input.c
|
||||
@@ -233,7 +233,8 @@ static int br_handle_local_finish(struct
|
||||
@@ -231,7 +231,10 @@ static void __br_handle_local_finish(str
|
||||
/* note: already called with rcu_read_lock */
|
||||
static int br_handle_local_finish(struct net *net, struct sock *sk, struct sk_buff *skb)
|
||||
{
|
||||
struct net_bridge_port *p = br_port_get_rcu(skb->dev);
|
||||
|
||||
- __br_handle_local_finish(skb);
|
||||
+ struct net_bridge_port *p = br_port_get_rcu(skb->dev);
|
||||
+
|
||||
+ if (p->state != BR_STATE_DISABLED)
|
||||
+ __br_handle_local_finish(skb);
|
||||
|
||||
BR_INPUT_SKB_CB(skb)->brdev = p->br->dev;
|
||||
br_pass_frame_up(skb);
|
||||
@@ -316,6 +317,15 @@ rx_handler_result_t br_handle_frame(stru
|
||||
/* return 1 to signal the okfn() was called so it's ok to use the skb */
|
||||
return 1;
|
||||
@@ -321,6 +324,15 @@ rx_handler_result_t br_handle_frame(stru
|
||||
|
||||
forward:
|
||||
switch (p->state) {
|
||||
|
@ -14,12 +14,12 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
||||
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -656,12 +656,12 @@ endif
|
||||
@@ -655,12 +655,12 @@ KBUILD_CFLAGS += $(call cc-option,-fdata
|
||||
endif
|
||||
|
||||
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
||||
KBUILD_CFLAGS += $(call cc-option,-Oz,-Os)
|
||||
-KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,)
|
||||
+KBUILD_CFLAGS += $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
|
||||
-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
|
||||
+KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,) $(EXTRA_OPTIMIZATION)
|
||||
else
|
||||
ifdef CONFIG_PROFILE_ALL_BRANCHES
|
||||
-KBUILD_CFLAGS += -O2 $(call cc-disable-warning,maybe-uninitialized,)
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -482,7 +482,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||
sdhci_get_of_property(pdev);
|
||||
--- a/drivers/mmc/host/sdhci.c
|
||||
+++ b/drivers/mmc/host/sdhci.c
|
||||
@@ -1631,26 +1631,24 @@ static void sdhci_set_ios(struct mmc_hos
|
||||
@@ -1629,26 +1629,24 @@ static void sdhci_set_ios(struct mmc_hos
|
||||
|
||||
ctrl = sdhci_readb(host, SDHCI_HOST_CONTROL);
|
||||
|
||||
@ -523,7 +523,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||
if (!host->preset_enabled) {
|
||||
sdhci_writeb(host, ctrl, SDHCI_HOST_CONTROL);
|
||||
/*
|
||||
@@ -1963,7 +1961,7 @@ static int sdhci_prepare_hs400_tuning(st
|
||||
@@ -1961,7 +1959,7 @@ static int sdhci_prepare_hs400_tuning(st
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -532,7 +532,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||
{
|
||||
struct sdhci_host *host = mmc_priv(mmc);
|
||||
u16 ctrl;
|
||||
@@ -2022,6 +2020,9 @@ static int sdhci_execute_tuning(struct m
|
||||
@@ -2020,6 +2018,9 @@ static int sdhci_execute_tuning(struct m
|
||||
return err;
|
||||
}
|
||||
|
||||
@ -542,7 +542,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||
ctrl = sdhci_readw(host, SDHCI_HOST_CONTROL2);
|
||||
ctrl |= SDHCI_CTRL_EXEC_TUNING;
|
||||
if (host->quirks2 & SDHCI_QUIRK2_TUNING_WORK_AROUND)
|
||||
@@ -2134,9 +2135,10 @@ static int sdhci_execute_tuning(struct m
|
||||
@@ -2132,9 +2133,10 @@ static int sdhci_execute_tuning(struct m
|
||||
|
||||
ctrl = sdhci_readw(host, SDHCI_HOST_CONTROL2);
|
||||
|
||||
@ -556,7 +556,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||
} while (ctrl & SDHCI_CTRL_EXEC_TUNING);
|
||||
|
||||
/*
|
||||
@@ -2172,6 +2174,7 @@ out_unlock:
|
||||
@@ -2170,6 +2172,7 @@ out_unlock:
|
||||
spin_unlock_irqrestore(&host->lock, flags);
|
||||
return err;
|
||||
}
|
||||
@ -564,7 +564,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
|
||||
|
||||
static int sdhci_select_drive_strength(struct mmc_card *card,
|
||||
unsigned int max_dtr, int host_drv,
|
||||
@@ -3004,6 +3007,8 @@ struct sdhci_host *sdhci_alloc_host(stru
|
||||
@@ -2994,6 +2997,8 @@ struct sdhci_host *sdhci_alloc_host(stru
|
||||
|
||||
host->flags = SDHCI_SIGNALING_330;
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user