mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
kernel: remove hack patch, move kirkwood specific kmods to target modules.mk
Tweaking the KCONFIG line of kmod-ata-marvell-sata makes the hack patch unnecessary Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
4363faef8a
commit
2e375e9b31
@ -90,21 +90,6 @@ endef
|
|||||||
$(eval $(call KernelPackage,ata-artop))
|
$(eval $(call KernelPackage,ata-artop))
|
||||||
|
|
||||||
|
|
||||||
define KernelPackage/ata-marvell-sata
|
|
||||||
TITLE:=Marvell Serial ATA support
|
|
||||||
KCONFIG:=CONFIG_SATA_MV
|
|
||||||
FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
|
|
||||||
AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
|
|
||||||
$(call AddDepends/ata)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/ata-marvell-sata/description
|
|
||||||
SATA support for marvell chipsets
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call KernelPackage,ata-marvell-sata))
|
|
||||||
|
|
||||||
|
|
||||||
define KernelPackage/ata-nvidia-sata
|
define KernelPackage/ata-nvidia-sata
|
||||||
TITLE:=Nvidia Serial ATA support
|
TITLE:=Nvidia Serial ATA support
|
||||||
KCONFIG:=CONFIG_SATA_NV
|
KCONFIG:=CONFIG_SATA_NV
|
||||||
|
@ -419,23 +419,6 @@ endef
|
|||||||
$(eval $(call KernelPackage,mmc))
|
$(eval $(call KernelPackage,mmc))
|
||||||
|
|
||||||
|
|
||||||
define KernelPackage/mvsdio
|
|
||||||
SUBMENU:=$(OTHER_MENU)
|
|
||||||
TITLE:=Marvell MMC/SD/SDIO host driver
|
|
||||||
DEPENDS:=+kmod-mmc @TARGET_kirkwood
|
|
||||||
KCONFIG:= CONFIG_MMC_MVSDIO
|
|
||||||
FILES:= \
|
|
||||||
$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
|
|
||||||
AUTOLOAD:=$(call AutoProbe,mvsdio,1)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define KernelPackage/mvsdio/description
|
|
||||||
Kernel support for the Marvell SDIO host driver.
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call KernelPackage,mvsdio))
|
|
||||||
|
|
||||||
|
|
||||||
define KernelPackage/sdhci
|
define KernelPackage/sdhci
|
||||||
SUBMENU:=$(OTHER_MENU)
|
SUBMENU:=$(OTHER_MENU)
|
||||||
TITLE:=Secure Digital Host Controller Interface support
|
TITLE:=Secure Digital Host Controller Interface support
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
From 8c817e33be829c7249c2cfd59ff48ad5fac6a31d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sungbo Eo <mans0n@gorani.run>
|
|
||||||
Date: Fri, 7 Jul 2017 17:09:21 +0200
|
|
||||||
Subject: [PATCH] kconfig: solidify SATA_PMP config
|
|
||||||
|
|
||||||
SATA_PMP option in kernel config file disappears for every kernel_oldconfig refresh.
|
|
||||||
To prevent this, SATA_HOST is now selected automatically when SATA_PMP is enabled.
|
|
||||||
This patch can be dropped if SATA_MV is ever re-added into the config.
|
|
||||||
---
|
|
||||||
drivers/ata/Kconfig | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/drivers/ata/Kconfig
|
|
||||||
+++ b/drivers/ata/Kconfig
|
|
||||||
@@ -112,7 +112,7 @@ config SATA_ZPODD
|
|
||||||
|
|
||||||
config SATA_PMP
|
|
||||||
bool "SATA Port Multiplier support"
|
|
||||||
- depends on SATA_HOST
|
|
||||||
+ select SATA_HOST
|
|
||||||
default y
|
|
||||||
help
|
|
||||||
This option adds support for SATA Port Multipliers
|
|
@ -1,23 +0,0 @@
|
|||||||
From 8c817e33be829c7249c2cfd59ff48ad5fac6a31d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sungbo Eo <mans0n@gorani.run>
|
|
||||||
Date: Fri, 7 Jul 2017 17:09:21 +0200
|
|
||||||
Subject: [PATCH] kconfig: solidify SATA_PMP config
|
|
||||||
|
|
||||||
SATA_PMP option in kernel config file disappears for every kernel_oldconfig refresh.
|
|
||||||
To prevent this, SATA_HOST is now selected automatically when SATA_PMP is enabled.
|
|
||||||
This patch can be dropped if SATA_MV is ever re-added into the config.
|
|
||||||
---
|
|
||||||
drivers/ata/Kconfig | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/drivers/ata/Kconfig
|
|
||||||
+++ b/drivers/ata/Kconfig
|
|
||||||
@@ -112,7 +112,7 @@ config SATA_ZPODD
|
|
||||||
|
|
||||||
config SATA_PMP
|
|
||||||
bool "SATA Port Multiplier support"
|
|
||||||
- depends on SATA_HOST
|
|
||||||
+ select SATA_HOST
|
|
||||||
default y
|
|
||||||
help
|
|
||||||
This option adds support for SATA Port Multipliers
|
|
30
target/linux/kirkwood/modules.mk
Normal file
30
target/linux/kirkwood/modules.mk
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
define KernelPackage/ata-marvell-sata
|
||||||
|
TITLE:=Marvell Serial ATA support
|
||||||
|
DEPENDS:=@TARGET_kirkwood
|
||||||
|
KCONFIG:=CONFIG_SATA_MV CONFIG_SATA_PMP=y
|
||||||
|
FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
|
||||||
|
AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
|
||||||
|
$(call AddDepends/ata)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/ata-marvell-sata/description
|
||||||
|
SATA support for marvell chipsets
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,ata-marvell-sata))
|
||||||
|
|
||||||
|
define KernelPackage/mvsdio
|
||||||
|
SUBMENU:=$(OTHER_MENU)
|
||||||
|
TITLE:=Marvell MMC/SD/SDIO host driver
|
||||||
|
DEPENDS:=+kmod-mmc @TARGET_kirkwood
|
||||||
|
KCONFIG:= CONFIG_MMC_MVSDIO
|
||||||
|
FILES:= \
|
||||||
|
$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
|
||||||
|
AUTOLOAD:=$(call AutoProbe,mvsdio,1)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define KernelPackage/mvsdio/description
|
||||||
|
Kernel support for the Marvell SDIO host driver.
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call KernelPackage,mvsdio))
|
Loading…
Reference in New Issue
Block a user