mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-25 08:21:14 +00:00
the mips -ffreestanding patch has been unnecessary for a long time now, remove it
SVN-Revision: 20149
This commit is contained in:
parent
c3ddcedf4a
commit
2d305bdc23
@ -1,7 +1,7 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -624,6 +624,13 @@ else
|
@@ -156,6 +156,13 @@ ifeq (,$(findstring march=octeon, $(cfla
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
|
||||||
endif
|
endif
|
||||||
|
|
||||||
+#
|
+#
|
||||||
@ -11,9 +11,9 @@
|
|||||||
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
||||||
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
||||||
+
|
+
|
||||||
# temporary until string.h is fixed
|
cflags-$(CONFIG_CPU_R4000_WORKAROUNDS) += $(call cc-option,-mfix-r4000,)
|
||||||
cflags-y += -ffreestanding
|
cflags-$(CONFIG_CPU_R4400_WORKAROUNDS) += $(call cc-option,-mfix-r4400,)
|
||||||
|
cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS) += $(call cc-option,-mno-daddi,)
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -43,6 +43,23 @@ config AR7
|
@@ -43,6 +43,23 @@ config AR7
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -169,6 +169,7 @@ endif
|
@@ -178,6 +178,7 @@ endif
|
||||||
#
|
#
|
||||||
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
||||||
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -637,6 +637,13 @@ else
|
@@ -166,6 +166,13 @@ ifeq (,$(findstring march=octeon, $(cfla
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
|
||||||
endif
|
endif
|
||||||
|
|
||||||
+#
|
+#
|
||||||
@ -11,9 +11,9 @@
|
|||||||
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
||||||
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
||||||
+
|
+
|
||||||
# temporary until string.h is fixed
|
cflags-$(CONFIG_CPU_R4000_WORKAROUNDS) += $(call cc-option,-mfix-r4000,)
|
||||||
cflags-y += -ffreestanding
|
cflags-$(CONFIG_CPU_R4400_WORKAROUNDS) += $(call cc-option,-mfix-r4400,)
|
||||||
|
cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS) += $(call cc-option,-mno-daddi,)
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -48,6 +48,23 @@ config AR7
|
@@ -48,6 +48,23 @@ config AR7
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -181,6 +181,7 @@ endif
|
@@ -188,6 +188,7 @@ endif
|
||||||
#
|
#
|
||||||
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
||||||
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -637,6 +637,13 @@ else
|
@@ -166,6 +166,13 @@ ifeq (,$(findstring march=octeon, $(cfla
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
|
||||||
endif
|
endif
|
||||||
|
|
||||||
+#
|
+#
|
||||||
@ -11,9 +11,9 @@
|
|||||||
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
||||||
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
||||||
+
|
+
|
||||||
# temporary until string.h is fixed
|
cflags-$(CONFIG_CPU_R4000_WORKAROUNDS) += $(call cc-option,-mfix-r4000,)
|
||||||
cflags-y += -ffreestanding
|
cflags-$(CONFIG_CPU_R4400_WORKAROUNDS) += $(call cc-option,-mfix-r4400,)
|
||||||
|
cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS) += $(call cc-option,-mno-daddi,)
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -48,6 +48,23 @@ config AR7
|
@@ -48,6 +48,23 @@ config AR7
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -181,6 +181,7 @@ endif
|
@@ -188,6 +188,7 @@ endif
|
||||||
#
|
#
|
||||||
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
|
||||||
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
--- a/arch/mips/Makefile
|
|
||||||
+++ b/arch/mips/Makefile
|
|
||||||
@@ -593,6 +593,9 @@ core-$(CONFIG_TOSHIBA_RBTX4938) += arch/
|
|
||||||
cflags-$(CONFIG_TOSHIBA_RBTX4938) += -Iinclude/asm-mips/mach-tx49xx
|
|
||||||
load-$(CONFIG_TOSHIBA_RBTX4938) += 0xffffffff80100000
|
|
||||||
|
|
||||||
+# temporary until string.h is fixed
|
|
||||||
+cflags-y += -ffreestanding
|
|
||||||
+
|
|
||||||
cflags-y += -Iinclude/asm-mips/mach-generic
|
|
||||||
drivers-$(CONFIG_PCI) += arch/mips/pci/
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/arch/mips/Makefile
|
|
||||||
+++ b/arch/mips/Makefile
|
|
||||||
@@ -607,6 +607,9 @@ ifdef CONFIG_PHYSICAL_START
|
|
||||||
load-y = $(CONFIG_PHYSICAL_START)
|
|
||||||
endif
|
|
||||||
|
|
||||||
+# temporary until string.h is fixed
|
|
||||||
+cflags-y += -ffreestanding
|
|
||||||
+
|
|
||||||
cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
|
|
||||||
drivers-$(CONFIG_PCI) += arch/mips/pci/
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/arch/mips/Makefile
|
|
||||||
+++ b/arch/mips/Makefile
|
|
||||||
@@ -612,6 +612,9 @@ else
|
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
|
||||||
endif
|
|
||||||
|
|
||||||
+# temporary until string.h is fixed
|
|
||||||
+cflags-y += -ffreestanding
|
|
||||||
+
|
|
||||||
cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
|
|
||||||
drivers-$(CONFIG_PCI) += arch/mips/pci/
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/arch/mips/Makefile
|
|
||||||
+++ b/arch/mips/Makefile
|
|
||||||
@@ -624,6 +624,9 @@ else
|
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
|
||||||
endif
|
|
||||||
|
|
||||||
+# temporary until string.h is fixed
|
|
||||||
+cflags-y += -ffreestanding
|
|
||||||
+
|
|
||||||
cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
|
|
||||||
drivers-$(CONFIG_PCI) += arch/mips/pci/
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/arch/mips/Makefile
|
|
||||||
+++ b/arch/mips/Makefile
|
|
||||||
@@ -637,6 +637,9 @@ else
|
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
|
||||||
endif
|
|
||||||
|
|
||||||
+# temporary until string.h is fixed
|
|
||||||
+cflags-y += -ffreestanding
|
|
||||||
+
|
|
||||||
cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
|
|
||||||
drivers-$(CONFIG_PCI) += arch/mips/pci/
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/arch/mips/Makefile
|
|
||||||
+++ b/arch/mips/Makefile
|
|
||||||
@@ -637,6 +637,9 @@ else
|
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
|
||||||
endif
|
|
||||||
|
|
||||||
+# temporary until string.h is fixed
|
|
||||||
+cflags-y += -ffreestanding
|
|
||||||
+
|
|
||||||
cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
|
|
||||||
drivers-$(CONFIG_PCI) += arch/mips/pci/
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -624,6 +624,26 @@ else
|
@@ -156,6 +156,26 @@ ifeq (,$(findstring march=octeon, $(cfla
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
|
||||||
endif
|
endif
|
||||||
|
|
||||||
+#
|
+#
|
||||||
@ -24,9 +24,9 @@
|
|||||||
+cflags-$(CONFIG_RALINK_RT305X) += -I$(srctree)/arch/mips/include/asm/mach-ralink/rt305x
|
+cflags-$(CONFIG_RALINK_RT305X) += -I$(srctree)/arch/mips/include/asm/mach-ralink/rt305x
|
||||||
+load-$(CONFIG_RALINK_RT305X) += 0xffffffff80000000
|
+load-$(CONFIG_RALINK_RT305X) += 0xffffffff80000000
|
||||||
+
|
+
|
||||||
# temporary until string.h is fixed
|
cflags-$(CONFIG_CPU_R4000_WORKAROUNDS) += $(call cc-option,-mfix-r4000,)
|
||||||
cflags-y += -ffreestanding
|
cflags-$(CONFIG_CPU_R4400_WORKAROUNDS) += $(call cc-option,-mfix-r4400,)
|
||||||
|
cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS) += $(call cc-option,-mno-daddi,)
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -43,6 +43,9 @@ config AR7
|
@@ -43,6 +43,9 @@ config AR7
|
||||||
|
Loading…
Reference in New Issue
Block a user