kernel: bump 4.14 to 4.14.156

Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
Koen Vandeputte 2019-11-25 11:32:58 +01:00
parent 7863a8f302
commit 2777947a75
22 changed files with 51 additions and 51 deletions

View File

@ -3,10 +3,10 @@
LINUX_RELEASE?=1 LINUX_RELEASE?=1
LINUX_VERSION-4.9 = .202 LINUX_VERSION-4.9 = .202
LINUX_VERSION-4.14 = .155 LINUX_VERSION-4.14 = .156
LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
LINUX_KERNEL_HASH-4.14.155 = 77d61979556b81c95b81452fa10e1fe9368cbe2f9f80a13e4669b0464722e481 LINUX_KERNEL_HASH-4.14.156 = f8889feb0cbd7df36ff35bd4c72c1e2010567621bfcb218fcfa501bc5c7787c0
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1)))) remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1))))))) sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))

View File

@ -1,6 +1,6 @@
--- a/drivers/i2c/busses/Kconfig --- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig +++ b/drivers/i2c/busses/Kconfig
@@ -473,6 +473,18 @@ config I2C_CBUS_GPIO @@ -474,6 +474,18 @@ config I2C_CBUS_GPIO
This driver can also be built as a module. If so, the module This driver can also be built as a module. If so, the module
will be called i2c-cbus-gpio. will be called i2c-cbus-gpio.

View File

@ -14,7 +14,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
--- a/drivers/pinctrl/pinctrl-gemini.c --- a/drivers/pinctrl/pinctrl-gemini.c
+++ b/drivers/pinctrl/pinctrl-gemini.c +++ b/drivers/pinctrl/pinctrl-gemini.c
@@ -2074,6 +2074,16 @@ static const struct gemini_pmx_func gemi @@ -2102,6 +2102,16 @@ static const struct gemini_pmx_func gemi
.num_groups = ARRAY_SIZE(satagrps), .num_groups = ARRAY_SIZE(satagrps),
}, },
{ {

View File

@ -34,7 +34,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
#include <linux/platform_device.h> #include <linux/platform_device.h>
#include <linux/slab.h> #include <linux/slab.h>
#include <linux/regmap.h> #include <linux/regmap.h>
@@ -1918,73 +1920,13 @@ static void gemini_pin_dbg_show(struct p @@ -1946,73 +1948,13 @@ static void gemini_pin_dbg_show(struct p
seq_printf(s, " " DRIVER_NAME); seq_printf(s, " " DRIVER_NAME);
} }

View File

@ -97,7 +97,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
#define GLOBAL_MISC_CTRL 0x30 #define GLOBAL_MISC_CTRL 0x30
#define TVC_CLK_PAD_ENABLE BIT(20) #define TVC_CLK_PAD_ENABLE BIT(20)
#define PCI_CLK_PAD_ENABLE BIT(17) #define PCI_CLK_PAD_ENABLE BIT(17)
@@ -1925,7 +1946,7 @@ static const struct pinctrl_ops gemini_p @@ -1953,7 +1974,7 @@ static const struct pinctrl_ops gemini_p
.get_group_name = gemini_get_group_name, .get_group_name = gemini_get_group_name,
.get_group_pins = gemini_get_group_pins, .get_group_pins = gemini_get_group_pins,
.pin_dbg_show = gemini_pin_dbg_show, .pin_dbg_show = gemini_pin_dbg_show,
@ -106,7 +106,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
.dt_free_map = pinconf_generic_dt_free_map, .dt_free_map = pinconf_generic_dt_free_map,
}; };
@@ -2203,10 +2224,155 @@ static const struct pinmux_ops gemini_pm @@ -2232,10 +2253,155 @@ static const struct pinmux_ops gemini_pm
.set_mux = gemini_pmx_set_mux, .set_mux = gemini_pmx_set_mux,
}; };
@ -262,7 +262,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
.owner = THIS_MODULE, .owner = THIS_MODULE,
}; };
@@ -2249,11 +2415,15 @@ static int gemini_pmx_probe(struct platf @@ -2278,11 +2444,15 @@ static int gemini_pmx_probe(struct platf
val &= 0xffff; val &= 0xffff;
if (val == 0x3512) { if (val == 0x3512) {
pmx->is_3512 = true; pmx->is_3512 = true;

View File

@ -55,7 +55,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}; };
static const unsigned int pci_3512_pins[] = { static const unsigned int pci_3512_pins[] = {
@@ -668,10 +678,10 @@ static const unsigned int gpio1c_3512_pi @@ -671,10 +681,10 @@ static const unsigned int gpio1c_3512_pi
/* The GPIO1D (28-31) pins overlap with LCD and TVC */ /* The GPIO1D (28-31) pins overlap with LCD and TVC */
static const unsigned int gpio1d_3512_pins[] = { 246, 319, 301, 283 }; static const unsigned int gpio1d_3512_pins[] = { 246, 319, 301, 283 };
@ -68,7 +68,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
static const unsigned int gpio2b_3512_pins[] = { 262, 244, 317, 299 }; static const unsigned int gpio2b_3512_pins[] = { 262, 244, 317, 299 };
/* The GPIO2C (8-31) pins overlap with PCI */ /* The GPIO2C (8-31) pins overlap with PCI */
@@ -738,9 +748,16 @@ static const struct gemini_pin_group gem @@ -741,9 +751,16 @@ static const struct gemini_pin_group gem
.num_pins = ARRAY_SIZE(usb_3512_pins), .num_pins = ARRAY_SIZE(usb_3512_pins),
}, },
{ {
@ -88,7 +88,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "pcigrp", .name = "pcigrp",
@@ -954,14 +971,15 @@ static const struct gemini_pin_group gem @@ -963,14 +980,15 @@ static const struct gemini_pin_group gem
.name = "gpio2agrp", .name = "gpio2agrp",
.pins = gpio2a_3512_pins, .pins = gpio2a_3512_pins,
.num_pins = ARRAY_SIZE(gpio2a_3512_pins), .num_pins = ARRAY_SIZE(gpio2a_3512_pins),
@ -107,7 +107,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "gpio2cgrp", .name = "gpio2cgrp",
@@ -1441,9 +1459,12 @@ static const unsigned int usb_3516_pins[ @@ -1450,9 +1468,12 @@ static const unsigned int usb_3516_pins[
}; };
/* GMII, ethernet pins */ /* GMII, ethernet pins */
@ -123,7 +123,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}; };
static const unsigned int pci_3516_pins[] = { static const unsigned int pci_3516_pins[] = {
@@ -1585,10 +1606,10 @@ static const unsigned int gpio1c_3516_pi @@ -1600,10 +1621,10 @@ static const unsigned int gpio1c_3516_pi
/* The GPIO1D (28-31) pins overlap with TVC */ /* The GPIO1D (28-31) pins overlap with TVC */
static const unsigned int gpio1d_3516_pins[] = { 353, 311, 394, 374 }; static const unsigned int gpio1d_3516_pins[] = { 353, 311, 394, 374 };
@ -136,7 +136,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
static const unsigned int gpio2b_3516_pins[] = { 391, 351, 310, 371 }; static const unsigned int gpio2b_3516_pins[] = { 391, 351, 310, 371 };
/* The GPIO2C (8-31) pins overlap with PCI */ /* The GPIO2C (8-31) pins overlap with PCI */
@@ -1660,9 +1681,16 @@ static const struct gemini_pin_group gem @@ -1675,9 +1696,16 @@ static const struct gemini_pin_group gem
.num_pins = ARRAY_SIZE(usb_3516_pins), .num_pins = ARRAY_SIZE(usb_3516_pins),
}, },
{ {
@ -156,7 +156,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "pcigrp", .name = "pcigrp",
@@ -1861,14 +1889,15 @@ static const struct gemini_pin_group gem @@ -1889,14 +1917,15 @@ static const struct gemini_pin_group gem
.name = "gpio2agrp", .name = "gpio2agrp",
.pins = gpio2a_3516_pins, .pins = gpio2a_3516_pins,
.num_pins = ARRAY_SIZE(gpio2a_3516_pins), .num_pins = ARRAY_SIZE(gpio2a_3516_pins),
@ -175,7 +175,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "gpio2cgrp", .name = "gpio2cgrp",
@@ -1971,7 +2000,7 @@ static const char * const icegrps[] = { @@ -1999,7 +2028,7 @@ static const char * const icegrps[] = {
static const char * const idegrps[] = { "idegrp" }; static const char * const idegrps[] = { "idegrp" };
static const char * const satagrps[] = { "satagrp" }; static const char * const satagrps[] = { "satagrp" };
static const char * const usbgrps[] = { "usbgrp" }; static const char * const usbgrps[] = { "usbgrp" };

View File

@ -13,7 +13,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
--- a/drivers/pinctrl/pinctrl-gemini.c --- a/drivers/pinctrl/pinctrl-gemini.c
+++ b/drivers/pinctrl/pinctrl-gemini.c +++ b/drivers/pinctrl/pinctrl-gemini.c
@@ -2015,7 +2015,8 @@ static const char * const sflashgrps[] = @@ -2043,7 +2043,8 @@ static const char * const sflashgrps[] =
static const char * const gpio0grps[] = { "gpio0agrp", "gpio0bgrp", "gpio0cgrp", static const char * const gpio0grps[] = { "gpio0agrp", "gpio0bgrp", "gpio0cgrp",
"gpio0dgrp", "gpio0egrp", "gpio0fgrp", "gpio0dgrp", "gpio0egrp", "gpio0fgrp",
"gpio0ggrp", "gpio0hgrp", "gpio0igrp", "gpio0ggrp", "gpio0hgrp", "gpio0igrp",

View File

@ -14,7 +14,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
--- a/drivers/pinctrl/pinctrl-gemini.c --- a/drivers/pinctrl/pinctrl-gemini.c
+++ b/drivers/pinctrl/pinctrl-gemini.c +++ b/drivers/pinctrl/pinctrl-gemini.c
@@ -2323,7 +2323,7 @@ static const struct gemini_pin_conf *gem @@ -2352,7 +2352,7 @@ static const struct gemini_pin_conf *gem
int i; int i;
for (i = 0; i < pmx->nconfs; i++) { for (i = 0; i < pmx->nconfs; i++) {

View File

@ -54,7 +54,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
#define GLOBAL_GMAC_CTRL_SKEW 0x1c #define GLOBAL_GMAC_CTRL_SKEW 0x1c
#define GLOBAL_GMAC0_DATA_SKEW 0x20 #define GLOBAL_GMAC0_DATA_SKEW 0x20
#define GLOBAL_GMAC1_DATA_SKEW 0x24 #define GLOBAL_GMAC1_DATA_SKEW 0x24
@@ -738,6 +743,7 @@ static const struct gemini_pin_group gem @@ -741,6 +746,7 @@ static const struct gemini_pin_group gem
/* Conflict with all flash usage */ /* Conflict with all flash usage */
.value = IDE_PADS_ENABLE | NAND_PADS_DISABLE | .value = IDE_PADS_ENABLE | NAND_PADS_DISABLE |
PFLASH_PADS_DISABLE | SFLASH_PADS_DISABLE, PFLASH_PADS_DISABLE | SFLASH_PADS_DISABLE,
@ -62,7 +62,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "satagrp", .name = "satagrp",
@@ -753,6 +759,7 @@ static const struct gemini_pin_group gem @@ -756,6 +762,7 @@ static const struct gemini_pin_group gem
.name = "gmii_gmac0_grp", .name = "gmii_gmac0_grp",
.pins = gmii_gmac0_3512_pins, .pins = gmii_gmac0_3512_pins,
.num_pins = ARRAY_SIZE(gmii_gmac0_3512_pins), .num_pins = ARRAY_SIZE(gmii_gmac0_3512_pins),
@ -70,7 +70,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "gmii_gmac1_grp", .name = "gmii_gmac1_grp",
@@ -760,6 +767,7 @@ static const struct gemini_pin_group gem @@ -763,6 +770,7 @@ static const struct gemini_pin_group gem
.num_pins = ARRAY_SIZE(gmii_gmac1_3512_pins), .num_pins = ARRAY_SIZE(gmii_gmac1_3512_pins),
/* Bring out RGMII on the GMAC1 pins */ /* Bring out RGMII on the GMAC1 pins */
.value = GEMINI_GMAC_IOSEL_GMAC0_GMAC1_RGMII, .value = GEMINI_GMAC_IOSEL_GMAC0_GMAC1_RGMII,
@ -78,7 +78,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "pcigrp", .name = "pcigrp",
@@ -767,6 +775,7 @@ static const struct gemini_pin_group gem @@ -770,6 +778,7 @@ static const struct gemini_pin_group gem
.num_pins = ARRAY_SIZE(pci_3512_pins), .num_pins = ARRAY_SIZE(pci_3512_pins),
/* Conflict only with GPIO2 */ /* Conflict only with GPIO2 */
.value = PCI_PADS_ENABLE | PCI_CLK_PAD_ENABLE, .value = PCI_PADS_ENABLE | PCI_CLK_PAD_ENABLE,
@ -86,7 +86,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "lpcgrp", .name = "lpcgrp",
@@ -1671,6 +1680,7 @@ static const struct gemini_pin_group gem @@ -1686,6 +1695,7 @@ static const struct gemini_pin_group gem
/* Conflict with all flash usage */ /* Conflict with all flash usage */
.value = IDE_PADS_ENABLE | NAND_PADS_DISABLE | .value = IDE_PADS_ENABLE | NAND_PADS_DISABLE |
PFLASH_PADS_DISABLE | SFLASH_PADS_DISABLE, PFLASH_PADS_DISABLE | SFLASH_PADS_DISABLE,
@ -94,7 +94,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "satagrp", .name = "satagrp",
@@ -1686,6 +1696,7 @@ static const struct gemini_pin_group gem @@ -1701,6 +1711,7 @@ static const struct gemini_pin_group gem
.name = "gmii_gmac0_grp", .name = "gmii_gmac0_grp",
.pins = gmii_gmac0_3516_pins, .pins = gmii_gmac0_3516_pins,
.num_pins = ARRAY_SIZE(gmii_gmac0_3516_pins), .num_pins = ARRAY_SIZE(gmii_gmac0_3516_pins),
@ -102,7 +102,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "gmii_gmac1_grp", .name = "gmii_gmac1_grp",
@@ -1693,6 +1704,7 @@ static const struct gemini_pin_group gem @@ -1708,6 +1719,7 @@ static const struct gemini_pin_group gem
.num_pins = ARRAY_SIZE(gmii_gmac1_3516_pins), .num_pins = ARRAY_SIZE(gmii_gmac1_3516_pins),
/* Bring out RGMII on the GMAC1 pins */ /* Bring out RGMII on the GMAC1 pins */
.value = GEMINI_GMAC_IOSEL_GMAC0_GMAC1_RGMII, .value = GEMINI_GMAC_IOSEL_GMAC0_GMAC1_RGMII,
@ -110,7 +110,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "pcigrp", .name = "pcigrp",
@@ -1700,6 +1712,7 @@ static const struct gemini_pin_group gem @@ -1715,6 +1727,7 @@ static const struct gemini_pin_group gem
.num_pins = ARRAY_SIZE(pci_3516_pins), .num_pins = ARRAY_SIZE(pci_3516_pins),
/* Conflict only with GPIO2 */ /* Conflict only with GPIO2 */
.value = PCI_PADS_ENABLE | PCI_CLK_PAD_ENABLE, .value = PCI_PADS_ENABLE | PCI_CLK_PAD_ENABLE,
@ -118,7 +118,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}, },
{ {
.name = "lpcgrp", .name = "lpcgrp",
@@ -2394,9 +2407,77 @@ static int gemini_pinconf_set(struct pin @@ -2423,9 +2436,77 @@ static int gemini_pinconf_set(struct pin
return ret; return ret;
} }

View File

@ -361,7 +361,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
par->hook_mask = 1 << ops->hooknum; par->hook_mask = 1 << ops->hooknum;
} else { } else {
@@ -318,7 +318,7 @@ static int nft_target_validate(const str @@ -337,7 +337,7 @@ static int nft_target_validate(const str
if (nft_is_base_chain(ctx->chain)) { if (nft_is_base_chain(ctx->chain)) {
const struct nft_base_chain *basechain = const struct nft_base_chain *basechain =
nft_base_chain(ctx->chain); nft_base_chain(ctx->chain);
@ -370,7 +370,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
hook_mask = 1 << ops->hooknum; hook_mask = 1 << ops->hooknum;
if (target->hooks && !(hook_mask & target->hooks)) if (target->hooks && !(hook_mask & target->hooks))
@@ -415,7 +415,7 @@ nft_match_set_mtchk_param(struct xt_mtch @@ -434,7 +434,7 @@ nft_match_set_mtchk_param(struct xt_mtch
if (nft_is_base_chain(ctx->chain)) { if (nft_is_base_chain(ctx->chain)) {
const struct nft_base_chain *basechain = const struct nft_base_chain *basechain =
nft_base_chain(ctx->chain); nft_base_chain(ctx->chain);
@ -379,7 +379,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
par->hook_mask = 1 << ops->hooknum; par->hook_mask = 1 << ops->hooknum;
} else { } else {
@@ -566,7 +566,7 @@ static int nft_match_validate(const stru @@ -586,7 +586,7 @@ static int nft_match_validate(const stru
if (nft_is_base_chain(ctx->chain)) { if (nft_is_base_chain(ctx->chain)) {
const struct nft_base_chain *basechain = const struct nft_base_chain *basechain =
nft_base_chain(ctx->chain); nft_base_chain(ctx->chain);

View File

@ -1237,7 +1237,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
if (par.target->destroy != NULL) if (par.target->destroy != NULL)
par.target->destroy(&par); par.target->destroy(&par);
@@ -390,7 +390,7 @@ nft_match_set_mtchk_param(struct xt_mtch @@ -409,7 +409,7 @@ nft_match_set_mtchk_param(struct xt_mtch
{ {
par->net = ctx->net; par->net = ctx->net;
par->table = ctx->table->name; par->table = ctx->table->name;
@ -1246,7 +1246,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
case AF_INET: case AF_INET:
entry->e4.ip.proto = proto; entry->e4.ip.proto = proto;
entry->e4.ip.invflags = inv ? IPT_INV_PROTO : 0; entry->e4.ip.invflags = inv ? IPT_INV_PROTO : 0;
@@ -421,7 +421,7 @@ nft_match_set_mtchk_param(struct xt_mtch @@ -440,7 +440,7 @@ nft_match_set_mtchk_param(struct xt_mtch
} else { } else {
par->hook_mask = 0; par->hook_mask = 0;
} }
@ -1255,7 +1255,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
par->nft_compat = true; par->nft_compat = true;
} }
@@ -504,7 +504,7 @@ __nft_match_destroy(const struct nft_ctx @@ -523,7 +523,7 @@ __nft_match_destroy(const struct nft_ctx
par.net = ctx->net; par.net = ctx->net;
par.match = match; par.match = match;
par.matchinfo = info; par.matchinfo = info;
@ -1264,7 +1264,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
if (par.match->destroy != NULL) if (par.match->destroy != NULL)
par.match->destroy(&par); par.match->destroy(&par);
@@ -734,7 +734,7 @@ nft_match_select_ops(const struct nft_ct @@ -754,7 +754,7 @@ nft_match_select_ops(const struct nft_ct
mt_name = nla_data(tb[NFTA_MATCH_NAME]); mt_name = nla_data(tb[NFTA_MATCH_NAME]);
rev = ntohl(nla_get_be32(tb[NFTA_MATCH_REV])); rev = ntohl(nla_get_be32(tb[NFTA_MATCH_REV]));
@ -1273,7 +1273,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
/* Re-use the existing match if it's already loaded. */ /* Re-use the existing match if it's already loaded. */
list_for_each_entry(nft_match, &nft_match_list, head) { list_for_each_entry(nft_match, &nft_match_list, head) {
@@ -825,7 +825,7 @@ nft_target_select_ops(const struct nft_c @@ -845,7 +845,7 @@ nft_target_select_ops(const struct nft_c
tg_name = nla_data(tb[NFTA_TARGET_NAME]); tg_name = nla_data(tb[NFTA_TARGET_NAME]);
rev = ntohl(nla_get_be32(tb[NFTA_TARGET_REV])); rev = ntohl(nla_get_be32(tb[NFTA_TARGET_REV]));

View File

@ -40,7 +40,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
errors per {size} bytes". errors per {size} bytes".
--- a/drivers/mtd/maps/physmap_of_core.c --- a/drivers/mtd/maps/physmap_of_core.c
+++ b/drivers/mtd/maps/physmap_of_core.c +++ b/drivers/mtd/maps/physmap_of_core.c
@@ -114,37 +114,9 @@ static struct mtd_info *obsolete_probe(s @@ -105,37 +105,9 @@ static struct mtd_info *obsolete_probe(s
static const char * const part_probe_types_def[] = { static const char * const part_probe_types_def[] = {
"cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL }; "cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL };
@ -78,7 +78,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
const struct of_device_id *match; const struct of_device_id *match;
struct device_node *dp = dev->dev.of_node; struct device_node *dp = dev->dev.of_node;
struct resource res; struct resource res;
@@ -310,14 +282,8 @@ static int of_flash_probe(struct platfor @@ -293,14 +265,8 @@ static int of_flash_probe(struct platfor
info->cmtd->dev.parent = &dev->dev; info->cmtd->dev.parent = &dev->dev;
mtd_set_of_node(info->cmtd, dp); mtd_set_of_node(info->cmtd, dp);

View File

@ -10,7 +10,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
--- a/drivers/base/power/opp/core.c --- a/drivers/base/power/opp/core.c
+++ b/drivers/base/power/opp/core.c +++ b/drivers/base/power/opp/core.c
@@ -1292,11 +1292,13 @@ struct opp_table *dev_pm_opp_set_regulat @@ -1280,11 +1280,13 @@ struct opp_table *dev_pm_opp_set_regulat
if (!opp_table) if (!opp_table)
return ERR_PTR(-ENOMEM); return ERR_PTR(-ENOMEM);

View File

@ -27,7 +27,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
--- a/drivers/base/power/opp/core.c --- a/drivers/base/power/opp/core.c
+++ b/drivers/base/power/opp/core.c +++ b/drivers/base/power/opp/core.c
@@ -1620,6 +1620,83 @@ put_table: @@ -1608,6 +1608,83 @@ put_table:
} }
/** /**

View File

@ -12,7 +12,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
--- a/drivers/base/power/opp/core.c --- a/drivers/base/power/opp/core.c
+++ b/drivers/base/power/opp/core.c +++ b/drivers/base/power/opp/core.c
@@ -131,6 +131,27 @@ unsigned long dev_pm_opp_get_freq(struct @@ -126,6 +126,27 @@ unsigned long dev_pm_opp_get_freq(struct
} }
EXPORT_SYMBOL_GPL(dev_pm_opp_get_freq); EXPORT_SYMBOL_GPL(dev_pm_opp_get_freq);

View File

@ -17,7 +17,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
--- a/drivers/base/power/opp/core.c --- a/drivers/base/power/opp/core.c
+++ b/drivers/base/power/opp/core.c +++ b/drivers/base/power/opp/core.c
@@ -1664,6 +1664,7 @@ int dev_pm_opp_adjust_voltage(struct dev @@ -1652,6 +1652,7 @@ int dev_pm_opp_adjust_voltage(struct dev
struct opp_table *opp_table; struct opp_table *opp_table;
struct dev_pm_opp *new_opp, *tmp_opp, *opp = ERR_PTR(-ENODEV); struct dev_pm_opp *new_opp, *tmp_opp, *opp = ERR_PTR(-ENODEV);
int r = 0; int r = 0;
@ -25,7 +25,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
/* keep the node allocated */ /* keep the node allocated */
new_opp = kmalloc(sizeof(*new_opp), GFP_KERNEL); new_opp = kmalloc(sizeof(*new_opp), GFP_KERNEL);
@@ -1700,6 +1701,10 @@ int dev_pm_opp_adjust_voltage(struct dev @@ -1688,6 +1689,10 @@ int dev_pm_opp_adjust_voltage(struct dev
/* plug in new node */ /* plug in new node */
new_opp->supplies[0].u_volt = u_volt; new_opp->supplies[0].u_volt = u_volt;

View File

@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/i2c/busses/Kconfig --- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig +++ b/drivers/i2c/busses/Kconfig
@@ -696,6 +696,16 @@ config I2C_MESON @@ -697,6 +697,16 @@ config I2C_MESON
If you say yes to this option, support will be included for the If you say yes to this option, support will be included for the
I2C interface on the Amlogic Meson family of SoCs. I2C interface on the Amlogic Meson family of SoCs.

View File

@ -16,8 +16,8 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
--- a/drivers/clk/Makefile --- a/drivers/clk/Makefile
+++ b/drivers/clk/Makefile +++ b/drivers/clk/Makefile
@@ -67,7 +67,7 @@ obj-$(CONFIG_ARCH_MXC) += imx/ @@ -68,7 +68,7 @@ obj-$(CONFIG_MACH_INGENIC) += ingenic/
obj-$(CONFIG_MACH_INGENIC) += ingenic/ obj-$(CONFIG_ARCH_K3) += keystone/
obj-$(CONFIG_ARCH_KEYSTONE) += keystone/ obj-$(CONFIG_ARCH_KEYSTONE) += keystone/
obj-$(CONFIG_MACH_LOONGSON32) += loongson1/ obj-$(CONFIG_MACH_LOONGSON32) += loongson1/
-obj-$(CONFIG_ARCH_MEDIATEK) += mediatek/ -obj-$(CONFIG_ARCH_MEDIATEK) += mediatek/

View File

@ -1,6 +1,6 @@
--- a/drivers/crypto/mxs-dcp.c --- a/drivers/crypto/mxs-dcp.c
+++ b/drivers/crypto/mxs-dcp.c +++ b/drivers/crypto/mxs-dcp.c
@@ -777,6 +777,24 @@ static void dcp_sha_cra_exit(struct cryp @@ -833,6 +833,24 @@ static void dcp_sha_cra_exit(struct cryp
{ {
} }
@ -25,7 +25,7 @@
/* AES 128 ECB and AES 128 CBC */ /* AES 128 ECB and AES 128 CBC */
static struct crypto_alg dcp_aes_algs[] = { static struct crypto_alg dcp_aes_algs[] = {
{ {
@@ -836,8 +854,11 @@ static struct ahash_alg dcp_sha1_alg = { @@ -892,8 +910,11 @@ static struct ahash_alg dcp_sha1_alg = {
.final = dcp_sha_final, .final = dcp_sha_final,
.finup = dcp_sha_finup, .finup = dcp_sha_finup,
.digest = dcp_sha_digest, .digest = dcp_sha_digest,
@ -37,7 +37,7 @@
.base = { .base = {
.cra_name = "sha1", .cra_name = "sha1",
.cra_driver_name = "sha1-dcp", .cra_driver_name = "sha1-dcp",
@@ -860,8 +881,11 @@ static struct ahash_alg dcp_sha256_alg = @@ -916,8 +937,11 @@ static struct ahash_alg dcp_sha256_alg =
.final = dcp_sha_final, .final = dcp_sha_final,
.finup = dcp_sha_finup, .finup = dcp_sha_finup,
.digest = dcp_sha_digest, .digest = dcp_sha_digest,

View File

@ -1,6 +1,6 @@
--- a/drivers/ata/Kconfig --- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig +++ b/drivers/ata/Kconfig
@@ -492,6 +492,13 @@ config SATA_VITESSE @@ -493,6 +493,13 @@ config SATA_VITESSE
If unsure, say N. If unsure, say N.

View File

@ -45,7 +45,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+}; +};
--- a/drivers/i2c/busses/Kconfig --- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig +++ b/drivers/i2c/busses/Kconfig
@@ -863,6 +863,11 @@ config I2C_RK3X @@ -864,6 +864,11 @@ config I2C_RK3X
This driver can also be built as a module. If so, the module will This driver can also be built as a module. If so, the module will
be called i2c-rk3x. be called i2c-rk3x.

View File

@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/i2c/busses/Kconfig --- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig +++ b/drivers/i2c/busses/Kconfig
@@ -868,6 +868,11 @@ config I2C_RALINK @@ -869,6 +869,11 @@ config I2C_RALINK
depends on RALINK && !SOC_MT7621 depends on RALINK && !SOC_MT7621
select OF_I2C select OF_I2C