lua: fix build with MacOS's make

It apparently requires passing V variable explicitly.

Fixes: fe59b46ca7 ("lua: include version number in installed files")
Reported-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
This commit is contained in:
Rafał Miłecki 2019-06-28 11:38:23 +02:00
parent 6b161bb8d5
commit 24645c0ee1
2 changed files with 18 additions and 0 deletions

View File

@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
# Lua version and release. # Lua version and release.
V= 5.1 V= 5.1
@@ -53,7 +53,7 @@ R= 5.1.5
all: $(PLAT)
$(PLATS) clean:
- cd src && $(MAKE) $@
+ cd src && $(MAKE) $@ V=$V
test: dummy
src/lua test/hello.lua
diff --git a/doc/lua.1 b/doc/lua5.1.1 diff --git a/doc/lua.1 b/doc/lua5.1.1
rename from doc/lua.1 rename from doc/lua.1
rename to doc/lua5.1.1 rename to doc/lua5.1.1

View File

@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
# Lua version and release. # Lua version and release.
V= 5.1 V= 5.1
@@ -53,7 +53,7 @@ R= 5.1.5
all: $(PLAT)
$(PLATS) clean:
- cd src && $(MAKE) $@
+ cd src && $(MAKE) $@ V=$V
test: dummy
src/lua test/hello.lua
diff --git a/doc/lua.1 b/doc/lua5.1.1 diff --git a/doc/lua.1 b/doc/lua5.1.1
rename from doc/lua.1 rename from doc/lua.1
rename to doc/lua5.1.1 rename to doc/lua5.1.1