mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 21:28:02 +00:00
lua: fix build with MacOS's make
It apparently requires passing V variable explicitly.
Fixes: fe59b46ca7
("lua: include version number in installed files")
Reported-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
This commit is contained in:
parent
6b161bb8d5
commit
24645c0ee1
@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
|
||||
|
||||
# Lua version and release.
|
||||
V= 5.1
|
||||
@@ -53,7 +53,7 @@ R= 5.1.5
|
||||
all: $(PLAT)
|
||||
|
||||
$(PLATS) clean:
|
||||
- cd src && $(MAKE) $@
|
||||
+ cd src && $(MAKE) $@ V=$V
|
||||
|
||||
test: dummy
|
||||
src/lua test/hello.lua
|
||||
diff --git a/doc/lua.1 b/doc/lua5.1.1
|
||||
rename from doc/lua.1
|
||||
rename to doc/lua5.1.1
|
||||
|
@ -24,6 +24,15 @@ diff --git a/Makefile b/Makefile
|
||||
|
||||
# Lua version and release.
|
||||
V= 5.1
|
||||
@@ -53,7 +53,7 @@ R= 5.1.5
|
||||
all: $(PLAT)
|
||||
|
||||
$(PLATS) clean:
|
||||
- cd src && $(MAKE) $@
|
||||
+ cd src && $(MAKE) $@ V=$V
|
||||
|
||||
test: dummy
|
||||
src/lua test/hello.lua
|
||||
diff --git a/doc/lua.1 b/doc/lua5.1.1
|
||||
rename from doc/lua.1
|
||||
rename to doc/lua5.1.1
|
||||
|
Loading…
Reference in New Issue
Block a user