mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-24 07:46:48 +00:00
kernel: fallback-sprom: create separate header files
Create a separate header files fallback-sprom.h for BCMA and SSB Fallback SPROM Driver to add function prototypes to fallback-sprom.c as well. This prevents missing function prototype errors. Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com> Link: https://github.com/openwrt/openwrt/pull/17138 Signed-off-by: Robert Marko <robimarko@gmail.com>
This commit is contained in:
parent
1b6f7ec679
commit
22d2aa65e8
@ -16,6 +16,7 @@
|
|||||||
#include <linux/mtd/mtd.h>
|
#include <linux/mtd/mtd.h>
|
||||||
#include <linux/of_net.h>
|
#include <linux/of_net.h>
|
||||||
#include <linux/of_platform.h>
|
#include <linux/of_platform.h>
|
||||||
|
#include "fallback-sprom.h"
|
||||||
|
|
||||||
#define BCMA_FBS_MAX_SIZE 468
|
#define BCMA_FBS_MAX_SIZE 468
|
||||||
|
|
||||||
|
7
target/linux/generic/files/drivers/bcma/fallback-sprom.h
Normal file
7
target/linux/generic/files/drivers/bcma/fallback-sprom.h
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
#ifndef _FALLBACK_SPROM_H
|
||||||
|
#define _FALLBACK_SPROM_H
|
||||||
|
|
||||||
|
int __init bcma_fbs_register(void);
|
||||||
|
int bcma_get_fallback_sprom(struct bcma_bus *dev, struct ssb_sprom *out);
|
||||||
|
|
||||||
|
#endif /* _FALLBACK_SPROM_H */
|
@ -16,6 +16,7 @@
|
|||||||
#include <linux/of_net.h>
|
#include <linux/of_net.h>
|
||||||
#include <linux/of_platform.h>
|
#include <linux/of_platform.h>
|
||||||
#include <linux/ssb/ssb.h>
|
#include <linux/ssb/ssb.h>
|
||||||
|
#include "fallback-sprom.h"
|
||||||
|
|
||||||
#define SSB_FBS_MAX_SIZE 440
|
#define SSB_FBS_MAX_SIZE 440
|
||||||
|
|
||||||
|
7
target/linux/generic/files/drivers/ssb/fallback-sprom.h
Normal file
7
target/linux/generic/files/drivers/ssb/fallback-sprom.h
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
#ifndef _FALLBACK_SPROM_H
|
||||||
|
#define _FALLBACK_SPROM_H
|
||||||
|
|
||||||
|
int __init ssb_fbs_register(void);
|
||||||
|
int ssb_get_fallback_sprom(struct ssb_bus *dev, struct ssb_sprom *out);
|
||||||
|
|
||||||
|
#endif /* _FALLBACK_SPROM_H */
|
@ -6,15 +6,15 @@ Subject: [PATCH] ssb_sprom: add generic kernel support for Broadcom Fallback SP
|
|||||||
---
|
---
|
||||||
drivers/bcma/Kconfig | 4 ++++
|
drivers/bcma/Kconfig | 4 ++++
|
||||||
drivers/bcma/Makefile | 1 +
|
drivers/bcma/Makefile | 1 +
|
||||||
drivers/bcma/bcma_private.h | 4 ++++
|
drivers/bcma/bcma_private.h | 1 +
|
||||||
drivers/bcma/main.c | 8 ++++++++
|
drivers/bcma/main.c | 8 ++++++++
|
||||||
drivers/bcma/sprom.c | 23 ++++++++++++++---------
|
drivers/bcma/sprom.c | 23 ++++++++++++++---------
|
||||||
drivers/ssb/Kconfig | 5 +++++
|
drivers/ssb/Kconfig | 5 +++++
|
||||||
drivers/ssb/Makefile | 1 +
|
drivers/ssb/Makefile | 1 +
|
||||||
drivers/ssb/main.c | 8 ++++++++
|
drivers/ssb/main.c | 8 ++++++++
|
||||||
drivers/ssb/sprom.c | 12 +++++++++++-
|
drivers/ssb/sprom.c | 12 +++++++++++-
|
||||||
drivers/ssb/ssb_private.h | 4 ++++
|
drivers/ssb/ssb_private.h | 2 +-
|
||||||
10 files changed, 60 insertions(+), 10 deletions(-)
|
10 files changed, 54 insertions(+), 11 deletions(-)
|
||||||
|
|
||||||
--- a/drivers/bcma/Kconfig
|
--- a/drivers/bcma/Kconfig
|
||||||
+++ b/drivers/bcma/Kconfig
|
+++ b/drivers/bcma/Kconfig
|
||||||
@ -41,17 +41,14 @@ Subject: [PATCH] ssb_sprom: add generic kernel support for Broadcom Fallback SP
|
|||||||
obj-$(CONFIG_BCMA) += bcma.o
|
obj-$(CONFIG_BCMA) += bcma.o
|
||||||
--- a/drivers/bcma/bcma_private.h
|
--- a/drivers/bcma/bcma_private.h
|
||||||
+++ b/drivers/bcma/bcma_private.h
|
+++ b/drivers/bcma/bcma_private.h
|
||||||
@@ -38,6 +38,10 @@ int bcma_bus_resume(struct bcma_bus *bus
|
@@ -8,6 +8,7 @@
|
||||||
void bcma_detect_chip(struct bcma_bus *bus);
|
|
||||||
int bcma_bus_scan(struct bcma_bus *bus);
|
|
||||||
|
|
||||||
+/* fallback-sprom.c */
|
#include <linux/bcma/bcma.h>
|
||||||
+int __init bcma_fbs_register(void);
|
#include <linux/delay.h>
|
||||||
+int bcma_get_fallback_sprom(struct bcma_bus *dev, struct ssb_sprom *out);
|
+#include "fallback-sprom.h"
|
||||||
+
|
|
||||||
/* sprom.c */
|
|
||||||
int bcma_sprom_get(struct bcma_bus *bus);
|
|
||||||
|
|
||||||
|
#define bcma_err(bus, fmt, ...) \
|
||||||
|
dev_err((bus)->dev, "bus%d: " fmt, (bus)->num, ##__VA_ARGS__)
|
||||||
--- a/drivers/bcma/main.c
|
--- a/drivers/bcma/main.c
|
||||||
+++ b/drivers/bcma/main.c
|
+++ b/drivers/bcma/main.c
|
||||||
@@ -671,6 +671,14 @@ static int __init bcma_modinit(void)
|
@@ -671,6 +671,14 @@ static int __init bcma_modinit(void)
|
||||||
@ -174,14 +171,12 @@ Subject: [PATCH] ssb_sprom: add generic kernel support for Broadcom Fallback SP
|
|||||||
/* https://bcm-v4.sipsolutions.net/802.11/IsSpromAvailable */
|
/* https://bcm-v4.sipsolutions.net/802.11/IsSpromAvailable */
|
||||||
--- a/drivers/ssb/ssb_private.h
|
--- a/drivers/ssb/ssb_private.h
|
||||||
+++ b/drivers/ssb/ssb_private.h
|
+++ b/drivers/ssb/ssb_private.h
|
||||||
@@ -143,6 +143,10 @@ extern int ssb_bus_scan(struct ssb_bus *
|
@@ -8,7 +8,7 @@
|
||||||
extern void ssb_iounmap(struct ssb_bus *ssb);
|
#include <linux/ssb/ssb.h>
|
||||||
|
#include <linux/types.h>
|
||||||
|
#include <linux/bcm47xx_wdt.h>
|
||||||
|
-
|
||||||
|
+#include "fallback-sprom.h"
|
||||||
|
|
||||||
|
/* pci.c */
|
||||||
+/* fallback-sprom.c */
|
#ifdef CONFIG_SSB_PCIHOST
|
||||||
+int __init ssb_fbs_register(void);
|
|
||||||
+int ssb_get_fallback_sprom(struct ssb_bus *dev, struct ssb_sprom *out);
|
|
||||||
+
|
|
||||||
/* sprom.c */
|
|
||||||
extern
|
|
||||||
ssize_t ssb_attr_sprom_show(struct ssb_bus *bus, char *buf,
|
|
||||||
|
Loading…
Reference in New Issue
Block a user