mirror of
https://github.com/openwrt/openwrt.git
synced 2025-04-09 12:22:00 +00:00
qualcommax: backport unmerged ipq60xx pwm support
Because of the dt-bindings error, these patches have not been merged yet, and the driver part is fine. Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn> Link: https://github.com/openwrt/openwrt/pull/14950 Signed-off-by: Robert Marko <robimarko@gmail.com>
This commit is contained in:
parent
ddc4f216c6
commit
227222f357
@ -1,6 +1,9 @@
|
||||
CONFIG_IPQ_GCC_6018=y
|
||||
CONFIG_MTD_SPLIT_FIT_FW=y
|
||||
CONFIG_PINCTRL_IPQ6018=y
|
||||
CONFIG_PWM=y
|
||||
CONFIG_PWM_IPQ=y
|
||||
CONFIG_PWM_SYSFS=y
|
||||
CONFIG_QCOM_APM=y
|
||||
# CONFIG_QCOM_CLK_SMD_RPM is not set
|
||||
# CONFIG_QCOM_RPMPD is not set
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
|
||||
|
||||
--- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
@@ -199,6 +199,11 @@
|
||||
@@ -194,6 +194,11 @@
|
||||
no-map;
|
||||
};
|
||||
|
@ -13,7 +13,7 @@ Tested-by: Robert Marko <robimarko@gmail.com>
|
||||
|
||||
--- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
@@ -470,6 +470,29 @@
|
||||
@@ -475,6 +475,29 @@
|
||||
};
|
||||
};
|
||||
|
||||
|
@ -0,0 +1,45 @@
|
||||
From b4a32d218d424b81a58fbd419e1114b1c1f76168 Mon Sep 17 00:00:00 2001
|
||||
From: Devi Priya <quic_devipriy@quicinc.com>
|
||||
Date: Thu, 5 Oct 2023 21:35:50 +0530
|
||||
Subject: [PATCH] arm64: dts: qcom: ipq6018: add pwm node
|
||||
|
||||
Describe the PWM block on IPQ6018.
|
||||
|
||||
The PWM is in the TCSR area. Make &tcsr "simple-mfd" compatible, and add
|
||||
&pwm as child of &tcsr.
|
||||
|
||||
Add also ipq6018 specific compatible string.
|
||||
|
||||
Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
|
||||
Co-developed-by: Baruch Siach <baruch.siach@siklu.com>
|
||||
Signed-off-by: Baruch Siach <baruch.siach@siklu.com>
|
||||
Signed-off-by: Devi Priya <quic_devipriy@quicinc.com>
|
||||
---
|
||||
arch/arm64/boot/dts/qcom/ipq6018.dtsi | 15 ++++++++++++++-
|
||||
1 file changed, 14 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
@@ -430,8 +430,21 @@
|
||||
};
|
||||
|
||||
tcsr: syscon@1937000 {
|
||||
- compatible = "qcom,tcsr-ipq6018", "syscon";
|
||||
+ compatible = "qcom,tcsr-ipq6018", "syscon", "simple-mfd";
|
||||
reg = <0x0 0x01937000 0x0 0x21000>;
|
||||
+ ranges = <0x0 0x0 0x01937000 0x21000>;
|
||||
+ #address-cells = <1>;
|
||||
+ #size-cells = <1>;
|
||||
+
|
||||
+ pwm: pwm@a010 {
|
||||
+ compatible = "qcom,ipq6018-pwm";
|
||||
+ reg = <0xa010 0x20>;
|
||||
+ clocks = <&gcc GCC_ADSS_PWM_CLK>;
|
||||
+ assigned-clocks = <&gcc GCC_ADSS_PWM_CLK>;
|
||||
+ assigned-clock-rates = <100000000>;
|
||||
+ #pwm-cells = <2>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
};
|
||||
|
||||
usb2: usb@70f8800 {
|
@ -12,6 +12,12 @@ Co-developed-by: Baruch Siach <baruch.siach@siklu.com>
|
||||
Signed-off-by: Baruch Siach <baruch.siach@siklu.com>
|
||||
Signed-off-by: Devi Priya <quic_devipriy@quicinc.com>
|
||||
---
|
||||
drivers/pwm/Kconfig | 12 ++
|
||||
drivers/pwm/Makefile | 1 +
|
||||
drivers/pwm/pwm-ipq.c | 282 ++++++++++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 295 insertions(+)
|
||||
create mode 100644 drivers/pwm/pwm-ipq.c
|
||||
|
||||
--- a/drivers/pwm/Kconfig
|
||||
+++ b/drivers/pwm/Kconfig
|
||||
@@ -282,6 +282,18 @@ config PWM_INTEL_LGM
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Mantas Pucka <mantas@8devices.com>
|
||||
|
||||
--- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
@@ -814,6 +814,102 @@
|
||||
@@ -827,6 +827,102 @@
|
||||
};
|
||||
};
|
||||
|
||||
|
@ -15,7 +15,7 @@ Signed-off-by: Mantas Pucka <mantas@8devices.com>
|
||||
|
||||
--- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
@@ -1162,6 +1162,7 @@
|
||||
@@ -1175,6 +1175,7 @@
|
||||
|
||||
wcss_smp2p_out: master-kernel {
|
||||
qcom,entry-name = "master-kernel";
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Mantas Pucka <mantas@8devices.com>
|
||||
|
||||
--- a/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/ipq6018.dtsi
|
||||
@@ -935,8 +935,8 @@
|
||||
@@ -948,8 +948,8 @@
|
||||
"wcss_reset",
|
||||
"wcss_q6_reset";
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user