mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-21 09:42:09 +00:00
ipq806x: 6.6: refresh kernel patches
Refresh kernel patches using make target/linux/refresh. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
parent
4693100b3f
commit
224f2fd567
@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
|
|
||||||
--- a/drivers/mtd/mtdpart.c
|
--- a/drivers/mtd/mtdpart.c
|
||||||
+++ b/drivers/mtd/mtdpart.c
|
+++ b/drivers/mtd/mtdpart.c
|
||||||
@@ -51,7 +51,11 @@ static struct mtd_info *allocate_partiti
|
@@ -57,7 +57,11 @@ static struct mtd_info *allocate_partiti
|
||||||
|
|
||||||
/* allocate the partition structure */
|
/* allocate the partition structure */
|
||||||
child = kzalloc(sizeof(*child), GFP_KERNEL);
|
child = kzalloc(sizeof(*child), GFP_KERNEL);
|
||||||
|
@ -16,7 +16,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
|
|||||||
|
|
||||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
@@ -301,6 +301,12 @@
|
@@ -302,6 +302,12 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
clocks {
|
clocks {
|
||||||
@ -29,7 +29,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
|
|||||||
cxo_board: cxo_board {
|
cxo_board: cxo_board {
|
||||||
compatible = "fixed-clock";
|
compatible = "fixed-clock";
|
||||||
#clock-cells = <0>;
|
#clock-cells = <0>;
|
||||||
@@ -575,7 +581,7 @@
|
@@ -587,7 +593,7 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
saw0: regulator@2089000 {
|
saw0: regulator@2089000 {
|
||||||
@ -38,7 +38,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
|
|||||||
reg = <0x02089000 0x1000>, <0x02009000 0x1000>;
|
reg = <0x02089000 0x1000>, <0x02009000 0x1000>;
|
||||||
regulator;
|
regulator;
|
||||||
};
|
};
|
||||||
@@ -591,11 +612,27 @@
|
@@ -602,11 +608,27 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
saw1: regulator@2099000 {
|
saw1: regulator@2099000 {
|
||||||
|
@ -23,7 +23,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
|
|||||||
|
|
||||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
@@ -48,6 +48,105 @@
|
@@ -49,6 +49,105 @@
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -59,7 +59,7 @@ Tested-by: Jonathan McDowell <noodles@earth.li>
|
|||||||
L2: l2-cache {
|
L2: l2-cache {
|
||||||
compatible = "cache";
|
compatible = "cache";
|
||||||
cache-level = <2>;
|
cache-level = <2>;
|
||||||
cache-unified;
|
cache-unified;
|
||||||
+ qcom,saw = <&saw_l2>;
|
+ qcom,saw = <&saw_l2>;
|
||||||
+
|
+
|
||||||
+ clocks = <&kraitcc 4>;
|
+ clocks = <&kraitcc 4>;
|
||||||
|
@ -12,7 +12,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
|
|||||||
|
|
||||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
@@ -599,12 +599,9 @@
|
@@ -600,12 +600,9 @@
|
||||||
};
|
};
|
||||||
|
|
||||||
nand_pins: nand_pins {
|
nand_pins: nand_pins {
|
||||||
|
@ -147,7 +147,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
|
|||||||
mdio1: mdio-1 {
|
mdio1: mdio-1 {
|
||||||
status = "okay";
|
status = "okay";
|
||||||
compatible = "virtual,mdio-gpio";
|
compatible = "virtual,mdio-gpio";
|
||||||
@@ -222,6 +155,131 @@
|
@@ -337,6 +212,131 @@
|
||||||
status = "okay";
|
status = "okay";
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -281,7 +281,7 @@ Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
|
|||||||
|
|
||||||
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
--- a/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
+++ b/arch/arm/boot/dts/qcom/qcom-ipq8064.dtsi
|
||||||
@@ -476,6 +476,20 @@
|
@@ -1429,6 +1429,20 @@
|
||||||
status = "disabled";
|
status = "disabled";
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -21,7 +21,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
|
|
||||||
--- a/drivers/devfreq/Kconfig
|
--- a/drivers/devfreq/Kconfig
|
||||||
+++ b/drivers/devfreq/Kconfig
|
+++ b/drivers/devfreq/Kconfig
|
||||||
@@ -151,6 +151,17 @@ config ARM_SUN8I_A33_MBUS_DEVFREQ
|
@@ -150,6 +150,17 @@ config ARM_SUN8I_A33_MBUS_DEVFREQ
|
||||||
This adds the DEVFREQ driver for the MBUS controller in some
|
This adds the DEVFREQ driver for the MBUS controller in some
|
||||||
Allwinner sun8i (A33 through H3) and sun50i (A64 and H5) SoCs.
|
Allwinner sun8i (A33 through H3) and sun50i (A64 and H5) SoCs.
|
||||||
|
|
||||||
|
@ -32,7 +32,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
};
|
};
|
||||||
|
|
||||||
opp_table_l2: opp_table_l2 {
|
opp_table_l2: opp_table_l2 {
|
||||||
@@ -1409,6 +1399,17 @@
|
@@ -1392,6 +1381,17 @@
|
||||||
#reset-cells = <1>;
|
#reset-cells = <1>;
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -15,7 +15,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
|
|
||||||
--- a/drivers/devfreq/Kconfig
|
--- a/drivers/devfreq/Kconfig
|
||||||
+++ b/drivers/devfreq/Kconfig
|
+++ b/drivers/devfreq/Kconfig
|
||||||
@@ -162,6 +162,17 @@ config ARM_KRAIT_CACHE_DEVFREQ
|
@@ -161,6 +161,17 @@ config ARM_KRAIT_CACHE_DEVFREQ
|
||||||
based on the max frequency across all core and the range set in the device
|
based on the max frequency across all core and the range set in the device
|
||||||
dts. If provided this scale also the regulator attached to the l2 cache.
|
dts. If provided this scale also the regulator attached to the l2 cache.
|
||||||
|
|
||||||
|
@ -32,7 +32,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
thermal-zones {
|
thermal-zones {
|
||||||
sensor0-thermal {
|
sensor0-thermal {
|
||||||
polling-delay-passive = <0>;
|
polling-delay-passive = <0>;
|
||||||
@@ -1409,6 +1421,13 @@
|
@@ -1392,6 +1404,13 @@
|
||||||
operating-points-v2 = <&opp_table_l2>;
|
operating-points-v2 = <&opp_table_l2>;
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -30,7 +30,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
+ req->best_parent_rate = clk_hw_round_rate(clk_hw_get_parent(hw),
|
+ req->best_parent_rate = clk_hw_round_rate(clk_hw_get_parent(hw),
|
||||||
+ req->rate * d->divisor);
|
+ req->rate * d->divisor);
|
||||||
+ req->rate = DIV_ROUND_UP(req->best_parent_rate, d->divisor);
|
+ req->rate = DIV_ROUND_UP(req->best_parent_rate, d->divisor);
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
-static int krait_div2_set_rate(struct clk_hw *hw, unsigned long rate,
|
-static int krait_div2_set_rate(struct clk_hw *hw, unsigned long rate,
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From b25aac1f55c29048e5a6ab24ab0e2aea12cb4887 Mon Sep 17 00:00:00 2001
|
From 9732c4f2d93a4a39ffc903c88ab7d531a8bb2e74 Mon Sep 17 00:00:00 2001
|
||||||
From: Christian Marangi <ansuelsmth@gmail.com>
|
From: Christian Marangi <ansuelsmth@gmail.com>
|
||||||
Date: Wed, 20 Mar 2024 00:47:58 +0100
|
Date: Wed, 20 Mar 2024 00:47:58 +0100
|
||||||
Subject: [PATCH] mtd: rawnand: qcom: Fix broken misc_cmd_type in exec_op
|
Subject: [PATCH] mtd: rawnand: qcom: Fix broken misc_cmd_type in exec_op
|
||||||
@ -8,10 +8,6 @@ misc_cmd_type in exec_op have multiple problems. With commit a82990c8a409
|
|||||||
reworked and generalized but actually dropped the handling of the
|
reworked and generalized but actually dropped the handling of the
|
||||||
RESET_DEVICE command.
|
RESET_DEVICE command.
|
||||||
|
|
||||||
The rework itself was correct with supporting case where a single misc
|
|
||||||
command is handled, but became problematic by the addition of exiting
|
|
||||||
early if we didn't had an ERASE or an OP_PROGRAM_PAGE operation.
|
|
||||||
|
|
||||||
Also additional logic was added without clear explaination causing the
|
Also additional logic was added without clear explaination causing the
|
||||||
erase command to be broken on testing it on a ipq806x nandc.
|
erase command to be broken on testing it on a ipq806x nandc.
|
||||||
|
|
||||||
@ -25,11 +21,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
drivers/mtd/nand/raw/qcom_nandc.c | 7 +++----
|
drivers/mtd/nand/raw/qcom_nandc.c | 7 +++----
|
||||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/drivers/mtd/nand/raw/qcom_nandc.c b/drivers/mtd/nand/raw/qcom_nandc.c
|
|
||||||
index b079605c84d3..b8cff9240b28 100644
|
|
||||||
--- a/drivers/mtd/nand/raw/qcom_nandc.c
|
--- a/drivers/mtd/nand/raw/qcom_nandc.c
|
||||||
+++ b/drivers/mtd/nand/raw/qcom_nandc.c
|
+++ b/drivers/mtd/nand/raw/qcom_nandc.c
|
||||||
@@ -2815,7 +2815,7 @@ static int qcom_misc_cmd_type_exec(struct nand_chip *chip, const struct nand_sub
|
@@ -2815,7 +2815,7 @@ static int qcom_misc_cmd_type_exec(struc
|
||||||
host->cfg0_raw & ~(7 << CW_PER_PAGE));
|
host->cfg0_raw & ~(7 << CW_PER_PAGE));
|
||||||
nandc_set_reg(chip, NAND_DEV0_CFG1, host->cfg1_raw);
|
nandc_set_reg(chip, NAND_DEV0_CFG1, host->cfg1_raw);
|
||||||
instrs = 3;
|
instrs = 3;
|
||||||
@ -38,7 +32,7 @@ index b079605c84d3..b8cff9240b28 100644
|
|||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -2830,9 +2830,8 @@ static int qcom_misc_cmd_type_exec(struct nand_chip *chip, const struct nand_sub
|
@@ -2830,9 +2830,8 @@ static int qcom_misc_cmd_type_exec(struc
|
||||||
nandc_set_reg(chip, NAND_EXEC_CMD, 1);
|
nandc_set_reg(chip, NAND_EXEC_CMD, 1);
|
||||||
|
|
||||||
write_reg_dma(nandc, NAND_FLASH_CMD, instrs, NAND_BAM_NEXT_SGL);
|
write_reg_dma(nandc, NAND_FLASH_CMD, instrs, NAND_BAM_NEXT_SGL);
|
||||||
@ -50,6 +44,3 @@ index b079605c84d3..b8cff9240b28 100644
|
|||||||
|
|
||||||
write_reg_dma(nandc, NAND_EXEC_CMD, 1, NAND_BAM_NEXT_SGL);
|
write_reg_dma(nandc, NAND_EXEC_CMD, 1, NAND_BAM_NEXT_SGL);
|
||||||
read_reg_dma(nandc, NAND_FLASH_STATUS, 1, NAND_BAM_NEXT_SGL);
|
read_reg_dma(nandc, NAND_FLASH_STATUS, 1, NAND_BAM_NEXT_SGL);
|
||||||
--
|
|
||||||
2.43.0
|
|
||||||
|
|
||||||
|
@ -2,17 +2,17 @@ From: Christian Lamparter <chunkeey@googlemail.com>
|
|||||||
Subject: SoC: add qualcomm syscon
|
Subject: SoC: add qualcomm syscon
|
||||||
--- a/drivers/soc/qcom/Makefile
|
--- a/drivers/soc/qcom/Makefile
|
||||||
+++ b/drivers/soc/qcom/Makefile
|
+++ b/drivers/soc/qcom/Makefile
|
||||||
@@ -23,6 +23,7 @@ obj-$(CONFIG_QCOM_SOCINFO) += socinfo.o
|
@@ -26,6 +26,7 @@ obj-$(CONFIG_QCOM_SOCINFO) += socinfo.o
|
||||||
obj-$(CONFIG_QCOM_SPM) += spm.o
|
obj-$(CONFIG_QCOM_SPM) += spm.o
|
||||||
obj-$(CONFIG_QCOM_STATS) += qcom_stats.o
|
obj-$(CONFIG_QCOM_STATS) += qcom_stats.o
|
||||||
obj-$(CONFIG_QCOM_WCNSS_CTRL) += wcnss_ctrl.o
|
obj-$(CONFIG_QCOM_WCNSS_CTRL) += wcnss_ctrl.o
|
||||||
+obj-$(CONFIG_QCOM_TCSR) += qcom_tcsr.o
|
+obj-$(CONFIG_QCOM_TCSR) += qcom_tcsr.o
|
||||||
obj-$(CONFIG_QCOM_APR) += apr.o
|
obj-$(CONFIG_QCOM_APR) += apr.o
|
||||||
obj-$(CONFIG_QCOM_LLCC) += llcc-qcom.o
|
obj-$(CONFIG_QCOM_LLCC) += llcc-qcom.o
|
||||||
obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
|
obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) += kryo-l2-accessors.o
|
||||||
--- a/drivers/soc/qcom/Kconfig
|
--- a/drivers/soc/qcom/Kconfig
|
||||||
+++ b/drivers/soc/qcom/Kconfig
|
+++ b/drivers/soc/qcom/Kconfig
|
||||||
@@ -213,6 +213,13 @@ config QCOM_STATS
|
@@ -252,6 +252,13 @@ config QCOM_STATS
|
||||||
various SoC level low power modes statistics and export to debugfs
|
various SoC level low power modes statistics and export to debugfs
|
||||||
interface.
|
interface.
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -1589,6 +1589,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
|
@@ -1568,6 +1568,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
|
||||||
|
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
@ -17,7 +17,7 @@
|
|||||||
default ""
|
default ""
|
||||||
--- a/drivers/of/fdt.c
|
--- a/drivers/of/fdt.c
|
||||||
+++ b/drivers/of/fdt.c
|
+++ b/drivers/of/fdt.c
|
||||||
@@ -1187,6 +1187,17 @@ int __init early_init_dt_scan_chosen(cha
|
@@ -1189,6 +1189,17 @@ int __init early_init_dt_scan_chosen(cha
|
||||||
if (p != NULL && l > 0)
|
if (p != NULL && l > 0)
|
||||||
strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE));
|
strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE));
|
||||||
|
|
||||||
|
@ -20,7 +20,7 @@ Acked-by: Linus Walleij <linus.walleij@linaro.org>
|
|||||||
|
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -1570,6 +1570,18 @@ config ARM_ATAG_DTB_COMPAT
|
@@ -1549,6 +1549,18 @@ config ARM_ATAG_DTB_COMPAT
|
||||||
bootloaders, this option allows zImage to extract the information
|
bootloaders, this option allows zImage to extract the information
|
||||||
from the ATAG list and store it at run time into the appended DTB.
|
from the ATAG list and store it at run time into the appended DTB.
|
||||||
|
|
||||||
@ -41,7 +41,7 @@ Acked-by: Linus Walleij <linus.walleij@linaro.org>
|
|||||||
default ARM_ATAG_DTB_COMPAT_CMDLINE_FROM_BOOTLOADER
|
default ARM_ATAG_DTB_COMPAT_CMDLINE_FROM_BOOTLOADER
|
||||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
@@ -169,6 +169,10 @@ int atags_to_fdt(void *atag_list, void *
|
@@ -170,6 +170,10 @@ int atags_to_fdt(void *atag_list, void *
|
||||||
setprop_string(fdt, "/chosen", "bootargs",
|
setprop_string(fdt, "/chosen", "bootargs",
|
||||||
atag->u.cmdline.cmdline);
|
atag->u.cmdline.cmdline);
|
||||||
} else if (atag->hdr.tag == ATAG_MEM) {
|
} else if (atag->hdr.tag == ATAG_MEM) {
|
||||||
|
@ -24,7 +24,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
|
|
||||||
--- a/arch/arm/Kconfig
|
--- a/arch/arm/Kconfig
|
||||||
+++ b/arch/arm/Kconfig
|
+++ b/arch/arm/Kconfig
|
||||||
@@ -1599,6 +1599,16 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
|
@@ -1578,6 +1578,16 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
|
||||||
The command-line arguments provided by the boot loader will be
|
The command-line arguments provided by the boot loader will be
|
||||||
appended to the the device tree bootargs property.
|
appended to the the device tree bootargs property.
|
||||||
|
|
||||||
@ -43,9 +43,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
config CMDLINE_OVERRIDE
|
config CMDLINE_OVERRIDE
|
||||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||||
@@ -3,7 +3,8 @@
|
@@ -4,7 +4,8 @@
|
||||||
#include <asm/setup.h>
|
|
||||||
#include <libfdt.h>
|
#include <libfdt.h>
|
||||||
|
#include "misc.h"
|
||||||
|
|
||||||
-#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND)
|
-#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND)
|
||||||
+#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND) || \
|
+#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND) || \
|
||||||
@ -53,7 +53,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
#define do_extend_cmdline 1
|
#define do_extend_cmdline 1
|
||||||
#else
|
#else
|
||||||
#define do_extend_cmdline 0
|
#define do_extend_cmdline 0
|
||||||
@@ -69,6 +70,83 @@ static uint32_t get_cell_size(const void
|
@@ -70,6 +71,83 @@ static uint32_t get_cell_size(const void
|
||||||
return cell_size;
|
return cell_size;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -137,7 +137,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
static void merge_fdt_bootargs(void *fdt, const char *fdt_cmdline)
|
static void merge_fdt_bootargs(void *fdt, const char *fdt_cmdline)
|
||||||
{
|
{
|
||||||
char cmdline[COMMAND_LINE_SIZE];
|
char cmdline[COMMAND_LINE_SIZE];
|
||||||
@@ -86,13 +164,23 @@ static void merge_fdt_bootargs(void *fdt
|
@@ -87,13 +165,23 @@ static void merge_fdt_bootargs(void *fdt
|
||||||
ptr += len - 1;
|
ptr += len - 1;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -177,7 +177,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|||||||
#include <linux/bootconfig.h>
|
#include <linux/bootconfig.h>
|
||||||
#include <linux/console.h>
|
#include <linux/console.h>
|
||||||
#include <linux/nmi.h>
|
#include <linux/nmi.h>
|
||||||
@@ -995,6 +996,17 @@ asmlinkage __visible void __init __no_sa
|
@@ -929,6 +930,17 @@ void start_kernel(void)
|
||||||
pr_notice("Kernel command line: %s\n", saved_command_line);
|
pr_notice("Kernel command line: %s\n", saved_command_line);
|
||||||
/* parameters may set static keys */
|
/* parameters may set static keys */
|
||||||
jump_label_init();
|
jump_label_init();
|
||||||
|
Loading…
x
Reference in New Issue
Block a user