diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index c4895add120..1025b7ec5eb 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -38,9 +38,8 @@ define Host/Prepare
 	rm -rf $(HOST_BUILD_DIR)/doc
 endef
 
-define Host/Clean
-	rm -f $(STAGING_DIR_HOST)/bin/e2fsck
-	rm -f $(STAGING_DIR_HOST)/bin/tune2fs
+define Host/Uninstall
+	-$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))