mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
bump to 2.6.29.6 and refresh patches
SVN-Revision: 16698
This commit is contained in:
parent
f74d16548d
commit
1981fd14a7
@ -25,8 +25,8 @@ endif
|
|||||||
ifeq ($(LINUX_VERSION),2.6.28.10)
|
ifeq ($(LINUX_VERSION),2.6.28.10)
|
||||||
LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
|
LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),2.6.29.2)
|
ifeq ($(LINUX_VERSION),2.6.29.6)
|
||||||
LINUX_KERNEL_MD5SUM:=a6839571a9e70baf821d2fb752f9c4c6
|
LINUX_KERNEL_MD5SUM:=7cd24826fd3c7b0f83d9f662731a7865
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),2.6.30.1)
|
ifeq ($(LINUX_VERSION),2.6.30.1)
|
||||||
LINUX_KERNEL_MD5SUM:=7da2e2e31f1c00f2673d2dc50de76b33
|
LINUX_KERNEL_MD5SUM:=7da2e2e31f1c00f2673d2dc50de76b33
|
||||||
|
@ -21,11 +21,9 @@ Signed-off-by: Wu Zhangjin <wuzhangjin@gmail.com>
|
|||||||
arch/mips/include/asm/delay.h | 58 +++++++++++++++++++++++++------------
|
arch/mips/include/asm/delay.h | 58 +++++++++++++++++++++++++------------
|
||||||
3 files changed, 57 insertions(+), 20 deletions(-)
|
3 files changed, 57 insertions(+), 20 deletions(-)
|
||||||
|
|
||||||
diff --git a/arch/mips/Makefile b/arch/mips/Makefile
|
|
||||||
index a25c2e5..1ee5504 100644
|
|
||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -120,7 +120,14 @@ cflags-$(CONFIG_CPU_R4300) += -march=r4300 -Wa,--trap
|
@@ -119,7 +119,14 @@ cflags-$(CONFIG_CPU_R4300) += -march=r43
|
||||||
cflags-$(CONFIG_CPU_VR41XX) += -march=r4100 -Wa,--trap
|
cflags-$(CONFIG_CPU_VR41XX) += -march=r4100 -Wa,--trap
|
||||||
cflags-$(CONFIG_CPU_R4X00) += -march=r4600 -Wa,--trap
|
cflags-$(CONFIG_CPU_R4X00) += -march=r4600 -Wa,--trap
|
||||||
cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
|
cflags-$(CONFIG_CPU_TX49XX) += -march=r4600 -Wa,--trap
|
||||||
@ -41,8 +39,6 @@ index a25c2e5..1ee5504 100644
|
|||||||
cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
|
cflags-$(CONFIG_CPU_MIPS32_R1) += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
|
||||||
-Wa,-mips32 -Wa,--trap
|
-Wa,-mips32 -Wa,--trap
|
||||||
cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
|
cflags-$(CONFIG_CPU_MIPS32_R2) += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
|
||||||
diff --git a/arch/mips/include/asm/compiler.h b/arch/mips/include/asm/compiler.h
|
|
||||||
index 71f5c5c..95256a8 100644
|
|
||||||
--- a/arch/mips/include/asm/compiler.h
|
--- a/arch/mips/include/asm/compiler.h
|
||||||
+++ b/arch/mips/include/asm/compiler.h
|
+++ b/arch/mips/include/asm/compiler.h
|
||||||
@@ -1,5 +1,6 @@
|
@@ -1,5 +1,6 @@
|
||||||
@ -66,8 +62,6 @@ index 71f5c5c..95256a8 100644
|
|||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
#endif /* _ASM_COMPILER_H */
|
#endif /* _ASM_COMPILER_H */
|
||||||
diff --git a/arch/mips/include/asm/delay.h b/arch/mips/include/asm/delay.h
|
|
||||||
index b0bccd2..00d7969 100644
|
|
||||||
--- a/arch/mips/include/asm/delay.h
|
--- a/arch/mips/include/asm/delay.h
|
||||||
+++ b/arch/mips/include/asm/delay.h
|
+++ b/arch/mips/include/asm/delay.h
|
||||||
@@ -7,6 +7,7 @@
|
@@ -7,6 +7,7 @@
|
||||||
@ -78,7 +72,7 @@ index b0bccd2..00d7969 100644
|
|||||||
*/
|
*/
|
||||||
#ifndef _ASM_DELAY_H
|
#ifndef _ASM_DELAY_H
|
||||||
#define _ASM_DELAY_H
|
#define _ASM_DELAY_H
|
||||||
@@ -48,6 +49,43 @@ static inline void __delay(unsigned long loops)
|
@@ -48,6 +49,43 @@ static inline void __delay(unsigned long
|
||||||
: "0" (loops), "r" (1));
|
: "0" (loops), "r" (1));
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -122,7 +116,7 @@ index b0bccd2..00d7969 100644
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* Division by multiplication: you don't have to worry about
|
* Division by multiplication: you don't have to worry about
|
||||||
@@ -62,8 +100,6 @@ static inline void __delay(unsigned long loops)
|
@@ -62,8 +100,6 @@ static inline void __delay(unsigned long
|
||||||
|
|
||||||
static inline void __udelay(unsigned long usecs, unsigned long lpj)
|
static inline void __udelay(unsigned long usecs, unsigned long lpj)
|
||||||
{
|
{
|
||||||
@ -131,7 +125,7 @@ index b0bccd2..00d7969 100644
|
|||||||
/*
|
/*
|
||||||
* The rates of 128 is rounded wrongly by the catchall case
|
* The rates of 128 is rounded wrongly by the catchall case
|
||||||
* for 64-bit. Excessive precission? Probably ...
|
* for 64-bit. Excessive precission? Probably ...
|
||||||
@@ -77,23 +113,7 @@ static inline void __udelay(unsigned long usecs, unsigned long lpj)
|
@@ -77,23 +113,7 @@ static inline void __udelay(unsigned lon
|
||||||
0x80000000ULL) >> 32);
|
0x80000000ULL) >> 32);
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -156,8 +150,3 @@ index b0bccd2..00d7969 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
#define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
|
#define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
|
||||||
--
|
|
||||||
1.6.0.4
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -6,11 +6,9 @@ precious blocks on an embedded system.
|
|||||||
|
|
||||||
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
||||||
--
|
--
|
||||||
diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
|
|
||||||
index 65d3b19..a467ee5 100644
|
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -811,6 +811,17 @@ config I8259
|
@@ -798,6 +798,17 @@ config I8259
|
||||||
config MIPS_BONITO64
|
config MIPS_BONITO64
|
||||||
bool
|
bool
|
||||||
|
|
||||||
@ -28,8 +26,6 @@ index 65d3b19..a467ee5 100644
|
|||||||
config MIPS_MSC
|
config MIPS_MSC
|
||||||
bool
|
bool
|
||||||
|
|
||||||
diff --git a/arch/mips/math-emu/Makefile b/arch/mips/math-emu/Makefile
|
|
||||||
index d547efd..7fdef24 100644
|
|
||||||
--- a/arch/mips/math-emu/Makefile
|
--- a/arch/mips/math-emu/Makefile
|
||||||
+++ b/arch/mips/math-emu/Makefile
|
+++ b/arch/mips/math-emu/Makefile
|
||||||
@@ -2,12 +2,14 @@
|
@@ -2,12 +2,14 @@
|
||||||
@ -49,8 +45,6 @@ index d547efd..7fdef24 100644
|
|||||||
+ dp_sqrt.o sp_sqrt.o
|
+ dp_sqrt.o sp_sqrt.o
|
||||||
|
|
||||||
EXTRA_CFLAGS += -Werror
|
EXTRA_CFLAGS += -Werror
|
||||||
diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
|
|
||||||
index 890f779..9f4c767 100644
|
|
||||||
--- a/arch/mips/math-emu/cp1emu.c
|
--- a/arch/mips/math-emu/cp1emu.c
|
||||||
+++ b/arch/mips/math-emu/cp1emu.c
|
+++ b/arch/mips/math-emu/cp1emu.c
|
||||||
@@ -56,6 +56,12 @@
|
@@ -56,6 +56,12 @@
|
||||||
@ -77,7 +71,7 @@ index 890f779..9f4c767 100644
|
|||||||
/* Control registers */
|
/* Control registers */
|
||||||
|
|
||||||
#define FPCREG_RID 0 /* $0 = revision id */
|
#define FPCREG_RID 0 /* $0 = revision id */
|
||||||
@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
|
@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_r
|
||||||
|
|
||||||
return sig;
|
return sig;
|
||||||
}
|
}
|
||||||
@ -91,11 +85,9 @@ index 890f779..9f4c767 100644
|
|||||||
|
|
||||||
#ifdef CONFIG_DEBUG_FS
|
#ifdef CONFIG_DEBUG_FS
|
||||||
extern struct dentry *mips_debugfs_dir;
|
extern struct dentry *mips_debugfs_dir;
|
||||||
diff --git a/arch/mips/math-emu/dsemul.c b/arch/mips/math-emu/dsemul.c
|
|
||||||
index df7b9d9..9b42bfd 100644
|
|
||||||
--- a/arch/mips/math-emu/dsemul.c
|
--- a/arch/mips/math-emu/dsemul.c
|
||||||
+++ b/arch/mips/math-emu/dsemul.c
|
+++ b/arch/mips/math-emu/dsemul.c
|
||||||
@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mips_instruction ir, unsigned long cpc)
|
@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mi
|
||||||
return SIGILL; /* force out of emulation loop */
|
return SIGILL; /* force out of emulation loop */
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -113,8 +105,6 @@ index df7b9d9..9b42bfd 100644
|
|||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
+#endif /* CONFIG_MIPS_FPU_EMU */
|
+#endif /* CONFIG_MIPS_FPU_EMU */
|
||||||
diff --git a/arch/mips/math-emu/kernel_linkage.c b/arch/mips/math-emu/kernel_linkage.c
|
|
||||||
index 52e6c58..211a399 100644
|
|
||||||
--- a/arch/mips/math-emu/kernel_linkage.c
|
--- a/arch/mips/math-emu/kernel_linkage.c
|
||||||
+++ b/arch/mips/math-emu/kernel_linkage.c
|
+++ b/arch/mips/math-emu/kernel_linkage.c
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
@ -125,7 +115,7 @@ index 52e6c58..211a399 100644
|
|||||||
void fpu_emulator_init_fpu(void)
|
void fpu_emulator_init_fpu(void)
|
||||||
{
|
{
|
||||||
static int first = 1;
|
static int first = 1;
|
||||||
@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
|
@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struc
|
||||||
|
|
||||||
return err;
|
return err;
|
||||||
}
|
}
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/arch/mips/Makefile
|
--- a/arch/mips/Makefile
|
||||||
+++ b/arch/mips/Makefile
|
+++ b/arch/mips/Makefile
|
||||||
@@ -602,6 +602,9 @@ else
|
@@ -609,6 +609,9 @@ else
|
||||||
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/r8169.c
|
--- a/drivers/net/r8169.c
|
||||||
+++ b/drivers/net/r8169.c
|
+++ b/drivers/net/r8169.c
|
||||||
@@ -1890,7 +1890,7 @@ static const struct rtl_cfg_info {
|
@@ -1889,7 +1889,7 @@ static const struct rtl_cfg_info {
|
||||||
.hw_start = rtl_hw_start_8169,
|
.hw_start = rtl_hw_start_8169,
|
||||||
.region = 1,
|
.region = 1,
|
||||||
.align = 0,
|
.align = 0,
|
||||||
@ -9,7 +9,7 @@
|
|||||||
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
||||||
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
||||||
.features = RTL_FEATURE_GMII
|
.features = RTL_FEATURE_GMII
|
||||||
@@ -1899,7 +1899,7 @@ static const struct rtl_cfg_info {
|
@@ -1898,7 +1898,7 @@ static const struct rtl_cfg_info {
|
||||||
.hw_start = rtl_hw_start_8168,
|
.hw_start = rtl_hw_start_8168,
|
||||||
.region = 2,
|
.region = 2,
|
||||||
.align = 8,
|
.align = 8,
|
||||||
@ -18,7 +18,7 @@
|
|||||||
TxErr | TxOK | RxOK | RxErr,
|
TxErr | TxOK | RxOK | RxErr,
|
||||||
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
|
.napi_event = TxErr | TxOK | RxOK | RxOverflow,
|
||||||
.features = RTL_FEATURE_GMII | RTL_FEATURE_MSI
|
.features = RTL_FEATURE_GMII | RTL_FEATURE_MSI
|
||||||
@@ -1908,7 +1908,7 @@ static const struct rtl_cfg_info {
|
@@ -1907,7 +1907,7 @@ static const struct rtl_cfg_info {
|
||||||
.hw_start = rtl_hw_start_8101,
|
.hw_start = rtl_hw_start_8101,
|
||||||
.region = 2,
|
.region = 2,
|
||||||
.align = 8,
|
.align = 8,
|
||||||
@ -27,16 +27,16 @@
|
|||||||
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
|
||||||
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
.napi_event = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
|
||||||
.features = RTL_FEATURE_MSI
|
.features = RTL_FEATURE_MSI
|
||||||
@@ -3582,10 +3582,12 @@ static irqreturn_t rtl8169_interrupt(int
|
@@ -3576,10 +3576,12 @@ static irqreturn_t rtl8169_interrupt(int
|
||||||
goto out;
|
break;
|
||||||
}
|
}
|
||||||
|
|
||||||
+#if 0
|
+#if 0
|
||||||
if (unlikely(status & SYSErr)) {
|
if (unlikely(status & SYSErr)) {
|
||||||
rtl8169_pcierr_interrupt(dev);
|
rtl8169_pcierr_interrupt(dev);
|
||||||
goto out;
|
break;
|
||||||
}
|
}
|
||||||
+#endif
|
+#endif
|
||||||
|
|
||||||
if (status & LinkChg)
|
if (status & LinkChg)
|
||||||
rtl8169_check_link_status(dev, tp, ioaddr);
|
rtl8169_check_link_status(dev, tp, ioaddr);
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/net/pppoe.c
|
--- a/drivers/net/pppoe.c
|
||||||
+++ b/drivers/net/pppoe.c
|
+++ b/drivers/net/pppoe.c
|
||||||
@@ -863,7 +863,7 @@ static int pppoe_sendmsg(struct kiocb *i
|
@@ -812,7 +812,7 @@ static int pppoe_sendmsg(struct kiocb *i
|
||||||
goto end;
|
goto end;
|
||||||
|
|
||||||
|
|
||||||
@ -9,7 +9,7 @@
|
|||||||
0, GFP_KERNEL);
|
0, GFP_KERNEL);
|
||||||
if (!skb) {
|
if (!skb) {
|
||||||
error = -ENOMEM;
|
error = -ENOMEM;
|
||||||
@@ -871,7 +871,7 @@ static int pppoe_sendmsg(struct kiocb *i
|
@@ -820,7 +820,7 @@ static int pppoe_sendmsg(struct kiocb *i
|
||||||
}
|
}
|
||||||
|
|
||||||
/* Reserve space for headers. */
|
/* Reserve space for headers. */
|
||||||
|
@ -17,7 +17,7 @@
|
|||||||
port->bulk_in_size = buffer_size;
|
port->bulk_in_size = buffer_size;
|
||||||
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
|
||||||
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
|
||||||
@@ -1306,3 +1307,5 @@ MODULE_LICENSE("GPL");
|
@@ -1307,3 +1308,5 @@ MODULE_LICENSE("GPL");
|
||||||
|
|
||||||
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
module_param(debug, bool, S_IRUGO | S_IWUSR);
|
||||||
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
MODULE_PARM_DESC(debug, "Debug enabled or not");
|
||||||
|
Loading…
Reference in New Issue
Block a user