mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
trace-cmd: update to v3.1.3
Remove upstremed patch: - 100-tracecmd-add-NO_LIBZSTD-option-to-disable-libzstd.patch Changes: c65c02c trace-cmd: Version 3.1.3 14a7aca trace-cmd library: Add API for mapping between host and guests 9191b8e tracecmd extract: Allow using --compression. d63ae35 trace-cmd report: Add callback for kvm plugin to show guest functions 0c7ef72 trace-cmd library: Add man pages for iterator functions 3cd1b55 trace-cmd library: Add tracecmd_follow_event() 27ea9e1 libtracecmd: Add documentation on tracecmd_set/get_private() 3c544ad libtracecmd: Add a man pages for handling of time stamps 5baf7a3 libtracecmd: Add check-manpages.sh ee007a1 trace-cmd library: Make tracecmd_filter_match() local cb04105 tracecmd library documentation: Use star and not underscore for function names 54931be trace-cmd: Do not return zero length name for guest by name 43ffa27 trace-cmd: Close socket descriptor on failed connection 4744ca3 trace-cmd record/agent: Add --notimeout option e512b22 trace-cmd: Add compile time overrides for libraries a6fe935 trace-cmd: README: Add note on installing libtracecmd 067f45f trace-cmd: libtracecmd: Fixing linking to C++ code 689a0d4 tracecmd: Add NO_LIBZSTD option to disable libzstd 6bbcd3e trace-cmd report: Use library tracecmd_filter_*() logic 955d05f trace-cmd report: Make filter arguments match their files 82ed4a9 trace-cmd library: Add filtering logic for iterating events dbd8777 trace-cmd report: Use tracecmd_iterate_events_multi() 78a74b1 trace-cmd library: Allow callers to save private data in tracecmd_input handlers b37903a tracecmd library: Add tracecmd_iterate_events_multi() d83b662 tracecmd utest: Add test to test using the libraries to read 2cb6cc2 tracecmd library: Add tracecmd_iterate_events() 762839a tracecmd: Use make variable instead of if statement for zlib test 1504f3f trace-cmd: Document new proxy args for {agent,record} 9a1c5d7 trace-cmd record: Keep --proxy from being passed to agents ef8a8d7 trace-cmd libs: Initialize msg to NULL tracecmd_msg_read_data() 39ec10a trace-cmd: Do not use instance from trace context Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
parent
4f70380ff1
commit
17c1bf7e6c
@ -1,12 +1,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=trace-cmd
|
PKG_NAME:=trace-cmd
|
||||||
PKG_VERSION:=v3.1.2
|
PKG_VERSION:=v3.1.3
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/
|
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/
|
||||||
PKG_HASH:=206672af60aa0bc35cfc44a4be746efa575bac729060e54b6453f7d5dfbcd979
|
PKG_HASH:=1fd8515f38fc29fd7a66e7b6b5931856906522e8a1845999fc9033fc80d7b676
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-2.0-only
|
PKG_LICENSE:=GPL-2.0-only
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From 4fcc23ee4291f445cada012b6bef6879274a25f1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nick Hainke <vincent@systemli.org>
|
|
||||||
Date: Sun, 7 Aug 2022 10:11:06 +0200
|
|
||||||
Subject: [PATCH] tracecmd: add NO_LIBZSTD option to disable libzstd
|
|
||||||
|
|
||||||
Other Linux kernel tools like perf already include options to disable
|
|
||||||
libzstd manually. Add this option also to trace-cmd.
|
|
||||||
|
|
||||||
The OpenWrt SDK fails to build trace-cmd due to the autodetection of
|
|
||||||
libzstd. The package is present in some feed repositories but should
|
|
||||||
not be used by trace-cmd. The compilation will fail with:
|
|
||||||
|
|
||||||
Package trace-cmd is missing dependencies for the following libraries:
|
|
||||||
libzstd.so.1
|
|
||||||
|
|
||||||
Signed-off-by: Nick Hainke <vincent@systemli.org>
|
|
||||||
---
|
|
||||||
Makefile | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -320,6 +320,7 @@ CFLAGS += -DHAVE_ZLIB
|
|
||||||
$(info Have zlib compression support)
|
|
||||||
endif
|
|
||||||
|
|
||||||
+ifndef NO_LIBZSTD
|
|
||||||
TEST_LIBZSTD = $(shell sh -c "$(PKG_CONFIG) --atleast-version 1.4.0 libzstd > /dev/null 2>&1 && echo y")
|
|
||||||
|
|
||||||
ifeq ("$(TEST_LIBZSTD)", "y")
|
|
||||||
@@ -335,6 +336,7 @@ $(info *******************************
|
|
||||||
endif
|
|
||||||
|
|
||||||
export LIBZSTD_CFLAGS LIBZSTD_LDLAGS ZSTD_INSTALLED
|
|
||||||
+endif
|
|
||||||
|
|
||||||
CUNIT_INSTALLED := $(shell if (printf "$(pound)include <CUnit/Basic.h>\n void main(){CU_initialize_registry();}" | $(CC) -o /dev/null -x c - -lcunit >/dev/null 2>&1) ; then echo 1; else echo 0 ; fi)
|
|
||||||
export CUNIT_INSTALLED
|
|
Loading…
Reference in New Issue
Block a user