mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 06:33:41 +00:00
elfutils: update to 0.182
Add --disable-libdebuginfod with remove libcurl dependency. Remove totally unused host elfutils. Refreshed and rebased patches. Also happens to fix compilation with GCC11. Newer versions of elfutils seem to have some kind of dependency on obstack. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
30fb675847
commit
1795bd2f1b
@ -7,12 +7,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=elfutils
|
||||
PKG_VERSION:=0.180
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.182
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
|
||||
PKG_HASH:=b827b6e35c59d188ba97d7cf148fa8dc6f5c68eb6c5981888dfdbb758c0b569d
|
||||
PKG_HASH:=ecc406914edf335f0b7fc084ebe6c460c4d6d5175bfdd6688c1c78d9146b8858
|
||||
|
||||
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
@ -63,7 +63,9 @@ endif
|
||||
CONFIGURE_ARGS += \
|
||||
--program-prefix=eu- \
|
||||
--disable-debuginfod \
|
||||
--without-lzma
|
||||
--disable-libdebuginfod \
|
||||
--without-lzma \
|
||||
--without-zstd
|
||||
|
||||
TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral
|
||||
|
||||
|
@ -17,8 +17,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
backends/ppc_initreg.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/backends/ppc_initreg.c b/backends/ppc_initreg.c
|
||||
index 0e0d359..e5cca7e 100644
|
||||
--- a/backends/ppc_initreg.c
|
||||
+++ b/backends/ppc_initreg.c
|
||||
@@ -33,6 +33,7 @@
|
||||
@ -29,6 +27,3 @@ index 0e0d359..e5cca7e 100644
|
||||
# include <sys/user.h>
|
||||
#endif
|
||||
|
||||
--
|
||||
2.23.0
|
||||
|
||||
|
@ -11,7 +11,7 @@
|
||||
Requires.private: zlib
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -586,6 +586,9 @@ AC_CONFIG_FILES([config/libelf.pc config
|
||||
@@ -590,6 +590,9 @@ AC_CONFIG_FILES([config/libelf.pc config
|
||||
AC_SUBST(USE_NLS, yes)
|
||||
AM_PO_SUBDIRS
|
||||
|
||||
@ -47,7 +47,7 @@
|
||||
#define _(Str) dgettext ("elfutils", Str)
|
||||
--- a/libdwfl/libdwflP.h
|
||||
+++ b/libdwfl/libdwflP.h
|
||||
@@ -44,6 +44,9 @@
|
||||
@@ -47,6 +47,9 @@
|
||||
|
||||
typedef struct Dwfl_Process Dwfl_Process;
|
||||
|
||||
|
@ -4,8 +4,8 @@
|
||||
pkginclude_HEADERS = version.h
|
||||
|
||||
SUBDIRS = config m4 lib libelf libcpu backends libebl libdwelf libdwfl libdw \
|
||||
- libasm src po doc tests
|
||||
- libasm debuginfod src po doc tests
|
||||
+ libasm
|
||||
|
||||
if DEBUGINFOD
|
||||
SUBDIRS += debuginfod
|
||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
||||
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
||||
|
@ -22,8 +22,6 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
|
||||
backends/arm_initreg.c | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/backends/aarch64_initreg.c b/backends/aarch64_initreg.c
|
||||
index daf6f37..6445276 100644
|
||||
--- a/backends/aarch64_initreg.c
|
||||
+++ b/backends/aarch64_initreg.c
|
||||
@@ -33,7 +33,7 @@
|
||||
@ -35,7 +33,7 @@ index daf6f37..6445276 100644
|
||||
# include <sys/user.h>
|
||||
# include <sys/ptrace.h>
|
||||
/* Deal with old glibc defining user_pt_regs instead of user_regs_struct. */
|
||||
@@ -82,7 +82,7 @@ aarch64_set_initial_registers_tid (pid_t tid __attribute__ ((unused)),
|
||||
@@ -82,7 +82,7 @@ aarch64_set_initial_registers_tid (pid_t
|
||||
|
||||
Dwarf_Word dwarf_fregs[32];
|
||||
for (int r = 0; r < 32; r++)
|
||||
@ -44,8 +42,6 @@ index daf6f37..6445276 100644
|
||||
|
||||
if (! setfunc (64, 32, dwarf_fregs, arg))
|
||||
return false;
|
||||
diff --git a/backends/arm_initreg.c b/backends/arm_initreg.c
|
||||
index efcabaf..062bb9e 100644
|
||||
--- a/backends/arm_initreg.c
|
||||
+++ b/backends/arm_initreg.c
|
||||
@@ -38,7 +38,7 @@
|
||||
|
@ -24,28 +24,3 @@ Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
||||
|
||||
#include <system.h>
|
||||
|
||||
--- a/libelf/elf.h
|
||||
+++ b/libelf/elf.h
|
||||
@@ -19,9 +19,9 @@
|
||||
#ifndef _ELF_H
|
||||
#define _ELF_H 1
|
||||
|
||||
-#include <features.h>
|
||||
-
|
||||
-__BEGIN_DECLS
|
||||
+#ifdef __cplusplus
|
||||
+extern "C" {
|
||||
+#endif
|
||||
|
||||
/* Standard ELF types. */
|
||||
|
||||
@@ -4103,6 +4103,8 @@ enum
|
||||
#define R_ARC_TLS_LE_S9 0x4a
|
||||
#define R_ARC_TLS_LE_32 0x4b
|
||||
|
||||
-__END_DECLS
|
||||
+#ifdef __cplusplus
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#endif /* elf.h */
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- a/libebl/libebl.h
|
||||
+++ b/libebl/libebl.h
|
||||
@@ -245,7 +245,7 @@ extern ssize_t ebl_register_info (Ebl *e
|
||||
Each of these is filled with the DWARF register number corresponding,
|
||||
or -1 if there is none. Returns zero when the information is available. */
|
||||
extern int ebl_syscall_abi (Ebl *ebl, int *sp, int *pc,
|
||||
- int *callno, int args[6]);
|
||||
+ int *callno, int args[]);
|
||||
|
||||
/* Supply the ABI-specified state of DWARF CFI before CIE initial programs.
|
||||
|
||||
--- a/libdw/libdw.h
|
||||
+++ b/libdw/libdw.h
|
||||
@@ -1065,7 +1065,7 @@ extern int dwarf_frame_cfa (Dwarf_Frame
|
||||
expressions in the CFI, *OPS is an internal pointer that can be used as
|
||||
long as the Dwarf_CFI used to create FRAME remains alive. */
|
||||
extern int dwarf_frame_register (Dwarf_Frame *frame, int regno,
|
||||
- Dwarf_Op ops_mem[3],
|
||||
+ Dwarf_Op ops_mem[],
|
||||
Dwarf_Op **ops, size_t *nops)
|
||||
__nonnull_attribute__ (3, 4, 5);
|
||||
|
Loading…
Reference in New Issue
Block a user