mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-18 10:46:41 +00:00
iproute2: fix ip monitor can't work when NET_NS is not enabled
The bug appeared in v4.1.0 and was fixed since v4.8.0 Fixes FS#620 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
This commit is contained in:
parent
111cf1b9f3
commit
0f23e80c27
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=iproute2
|
PKG_NAME:=iproute2
|
||||||
PKG_VERSION:=4.4.0
|
PKG_VERSION:=4.4.0
|
||||||
PKG_RELEASE:=8
|
PKG_RELEASE:=9
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||||
|
@ -0,0 +1,40 @@
|
|||||||
|
From c44003f7e7254ac972eaa1b22a686471ea4ce2d7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Liping Zhang <liping.zhang@spreadtrum.com>
|
||||||
|
Date: Tue, 20 Sep 2016 02:09:02 -0700
|
||||||
|
Subject: [PATCH] ipmonitor: fix ip monitor can't work when NET_NS is not
|
||||||
|
enabled
|
||||||
|
|
||||||
|
In ip monitor, netns_map_init will check getnsid is supported or not.
|
||||||
|
But when /proc/self/ns/net does not exist, we just print out error
|
||||||
|
messages and exit. So user cannot use ip monitor anymore when
|
||||||
|
CONFIG_NET_NS is disabled:
|
||||||
|
# ip monitor
|
||||||
|
open("/proc/self/ns/net"): No such file or directory
|
||||||
|
|
||||||
|
If open "/proc/self/ns/net" failed, set have_rtnl_getnsid to false.
|
||||||
|
|
||||||
|
Fixes: d652ccbf8195 ("netns: allow to dump and monitor nsid")
|
||||||
|
Signed-off-by: Liping Zhang <liping.zhang@spreadtrum.com>
|
||||||
|
Acked-by: Nicolas Dichtel <nicolas.dichtel@6wind.com>
|
||||||
|
---
|
||||||
|
ip/ipnetns.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/ip/ipnetns.c b/ip/ipnetns.c
|
||||||
|
index af87065..ccc652c 100644
|
||||||
|
--- a/ip/ipnetns.c
|
||||||
|
+++ b/ip/ipnetns.c
|
||||||
|
@@ -72,8 +72,8 @@ static int ipnetns_have_nsid(void)
|
||||||
|
if (have_rtnl_getnsid < 0) {
|
||||||
|
fd = open("/proc/self/ns/net", O_RDONLY);
|
||||||
|
if (fd < 0) {
|
||||||
|
- perror("open(\"/proc/self/ns/net\")");
|
||||||
|
- exit(1);
|
||||||
|
+ have_rtnl_getnsid = 0;
|
||||||
|
+ return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
addattr32(&req.n, 1024, NETNSA_FD, fd);
|
||||||
|
--
|
||||||
|
2.6.4
|
||||||
|
|
Loading…
Reference in New Issue
Block a user