ramips: 6.6: refresh patches

Refresh kernel patches.

Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
This commit is contained in:
Mieczyslaw Nalewaj 2024-03-14 23:27:46 +01:00 committed by Nick Hainke
parent 4b8b7438f7
commit 0e5fb421a9
21 changed files with 71 additions and 71 deletions

View File

@ -1,6 +1,6 @@
--- a/arch/mips/include/asm/mach-ralink/mt7620.h --- a/arch/mips/include/asm/mach-ralink/mt7620.h
+++ b/arch/mips/include/asm/mach-ralink/mt7620.h +++ b/arch/mips/include/asm/mach-ralink/mt7620.h
@@ -61,4 +61,16 @@ static inline int mt7620_get_eco(void) @@ -62,4 +62,16 @@ static inline int mt7620_get_eco(void)
return rt_sysc_r32(SYSC_REG_CHIP_REV) & CHIP_REV_ECO_MASK; return rt_sysc_r32(SYSC_REG_CHIP_REV) & CHIP_REV_ECO_MASK;
} }

View File

@ -17,7 +17,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
--- a/arch/mips/kernel/setup.c --- a/arch/mips/kernel/setup.c
+++ b/arch/mips/kernel/setup.c +++ b/arch/mips/kernel/setup.c
@@ -557,8 +557,28 @@ static int __init bootcmdline_scan_chose @@ -563,8 +563,28 @@ static int __init bootcmdline_scan_chose
#endif /* CONFIG_OF_EARLY_FLATTREE */ #endif /* CONFIG_OF_EARLY_FLATTREE */
@ -46,7 +46,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
bool dt_bootargs = false; bool dt_bootargs = false;
/* /*
@@ -572,6 +592,14 @@ static void __init bootcmdline_init(void @@ -578,6 +598,14 @@ static void __init bootcmdline_init(void
} }
/* /*

View File

@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/arch/mips/kernel/setup.c --- a/arch/mips/kernel/setup.c
+++ b/arch/mips/kernel/setup.c +++ b/arch/mips/kernel/setup.c
@@ -699,7 +699,6 @@ static void __init arch_mem_init(char ** @@ -705,7 +705,6 @@ static void __init arch_mem_init(char **
mips_reserve_vmcore(); mips_reserve_vmcore();
mips_parse_crashkernel(); mips_parse_crashkernel();
@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/* /*
* In order to reduce the possibility of kernel panic when failed to * In order to reduce the possibility of kernel panic when failed to
@@ -834,6 +833,7 @@ void __init setup_arch(char **cmdline_p) @@ -841,6 +840,7 @@ void __init setup_arch(char **cmdline_p)
cpu_cache_init(); cpu_cache_init();
paging_init(); paging_init();

View File

@ -9,7 +9,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
--- a/drivers/mtd/chips/cfi_cmdset_0002.c --- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -40,7 +40,7 @@ @@ -38,7 +38,7 @@
#include <linux/mtd/xip.h> #include <linux/mtd/xip.h>
#define AMD_BOOTLOC_BUG #define AMD_BOOTLOC_BUG

View File

@ -55,7 +55,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
+}; +};
--- a/drivers/mtd/spi-nor/core.c --- a/drivers/mtd/spi-nor/core.c
+++ b/drivers/mtd/spi-nor/core.c +++ b/drivers/mtd/spi-nor/core.c
@@ -1620,6 +1620,7 @@ int spi_nor_sr2_bit7_quad_enable(struct @@ -2001,6 +2001,7 @@ int spi_nor_sr2_bit7_quad_enable(struct
static const struct spi_nor_manufacturer *manufacturers[] = { static const struct spi_nor_manufacturer *manufacturers[] = {
&spi_nor_atmel, &spi_nor_atmel,
@ -65,7 +65,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
&spi_nor_esmt, &spi_nor_esmt,
--- a/drivers/mtd/spi-nor/core.h --- a/drivers/mtd/spi-nor/core.h
+++ b/drivers/mtd/spi-nor/core.h +++ b/drivers/mtd/spi-nor/core.h
@@ -617,6 +617,7 @@ struct sfdp { @@ -631,6 +631,7 @@ struct sfdp {
/* Manufacturer drivers. */ /* Manufacturer drivers. */
extern const struct spi_nor_manufacturer spi_nor_atmel; extern const struct spi_nor_manufacturer spi_nor_atmel;

View File

@ -20,7 +20,7 @@ Signed-off-by: Weijie Gao <weijie.gao@mediatek.com>
--- a/drivers/mtd/nand/raw/Kconfig --- a/drivers/mtd/nand/raw/Kconfig
+++ b/drivers/mtd/nand/raw/Kconfig +++ b/drivers/mtd/nand/raw/Kconfig
@@ -352,6 +352,14 @@ config MTD_NAND_QCOM @@ -338,6 +338,14 @@ config MTD_NAND_QCOM
Enables support for NAND flash chips on SoCs containing the EBI2 NAND Enables support for NAND flash chips on SoCs containing the EBI2 NAND
controller. This controller is found on IPQ806x SoC. controller. This controller is found on IPQ806x SoC.
@ -37,7 +37,7 @@ Signed-off-by: Weijie Gao <weijie.gao@mediatek.com>
depends on MTD_NAND_ECC_MEDIATEK depends on MTD_NAND_ECC_MEDIATEK
--- a/drivers/mtd/nand/raw/Makefile --- a/drivers/mtd/nand/raw/Makefile
+++ b/drivers/mtd/nand/raw/Makefile +++ b/drivers/mtd/nand/raw/Makefile
@@ -48,6 +48,7 @@ obj-$(CONFIG_MTD_NAND_SUNXI) += sunxi_n @@ -46,6 +46,7 @@ obj-$(CONFIG_MTD_NAND_SUNXI) += sunxi_n
obj-$(CONFIG_MTD_NAND_HISI504) += hisi504_nand.o obj-$(CONFIG_MTD_NAND_HISI504) += hisi504_nand.o
obj-$(CONFIG_MTD_NAND_BRCMNAND) += brcmnand/ obj-$(CONFIG_MTD_NAND_BRCMNAND) += brcmnand/
obj-$(CONFIG_MTD_NAND_QCOM) += qcom_nandc.o obj-$(CONFIG_MTD_NAND_QCOM) += qcom_nandc.o

View File

@ -14,7 +14,7 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
--- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
+++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
@@ -4643,6 +4643,7 @@ static const struct net_device_ops mtk_n @@ -4662,6 +4662,7 @@ static const struct net_device_ops mtk_n
static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np) static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np)
{ {
@ -22,9 +22,9 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
const __be32 *_id = of_get_property(np, "reg", NULL); const __be32 *_id = of_get_property(np, "reg", NULL);
struct device_node *pcs_np; struct device_node *pcs_np;
phy_interface_t phy_mode; phy_interface_t phy_mode;
@@ -4840,6 +4841,9 @@ static int mtk_add_mac(struct mtk_eth *e @@ -4875,6 +4876,9 @@ static int mtk_add_mac(struct mtk_eth *e
register_netdevice_notifier(&mac->device_notifier); NETDEV_XDP_ACT_NDO_XMIT |
} NETDEV_XDP_ACT_NDO_XMIT_SG;
+ if (name) + if (name)
+ strlcpy(eth->netdev[id]->name, name, IFNAMSIZ); + strlcpy(eth->netdev[id]->name, name, IFNAMSIZ);

View File

@ -16,7 +16,7 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
--- a/drivers/net/phy/phy.c --- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c +++ b/drivers/net/phy/phy.c
@@ -71,13 +71,13 @@ static void phy_process_state_change(str @@ -72,13 +72,13 @@ static void phy_process_state_change(str
static void phy_link_up(struct phy_device *phydev) static void phy_link_up(struct phy_device *phydev)
{ {
@ -31,9 +31,9 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
- phydev->phy_link_change(phydev, false); - phydev->phy_link_change(phydev, false);
+ phydev->phy_link_change(phydev, false, do_carrier); + phydev->phy_link_change(phydev, false, do_carrier);
phy_led_trigger_change_speed(phydev); phy_led_trigger_change_speed(phydev);
WRITE_ONCE(phydev->link_down_events, phydev->link_down_events + 1);
} }
@@ -823,7 +823,7 @@ int phy_start_cable_test(struct phy_devi
@@ -595,7 +595,7 @@ int phy_start_cable_test(struct phy_devi
goto out; goto out;
/* Mark the carrier down until the test is complete */ /* Mark the carrier down until the test is complete */
@ -42,7 +42,7 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
netif_testing_on(dev); netif_testing_on(dev);
err = phydev->drv->cable_test_start(phydev); err = phydev->drv->cable_test_start(phydev);
@@ -666,7 +666,7 @@ int phy_start_cable_test_tdr(struct phy_ @@ -894,7 +894,7 @@ int phy_start_cable_test_tdr(struct phy_
goto out; goto out;
/* Mark the carrier down until the test is complete */ /* Mark the carrier down until the test is complete */
@ -51,7 +51,7 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
netif_testing_on(dev); netif_testing_on(dev);
err = phydev->drv->cable_test_tdr_start(phydev, config); err = phydev->drv->cable_test_tdr_start(phydev, config);
@@ -738,7 +738,7 @@ static int phy_check_link_status(struct @@ -966,7 +966,7 @@ static int phy_check_link_status(struct
phy_link_up(phydev); phy_link_up(phydev);
} else if (!phydev->link && phydev->state != PHY_NOLINK) { } else if (!phydev->link && phydev->state != PHY_NOLINK) {
phydev->state = PHY_NOLINK; phydev->state = PHY_NOLINK;
@ -60,8 +60,8 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
} }
return 0; return 0;
@@ -1224,7 +1224,7 @@ void phy_state_machine(struct work_struc @@ -1485,7 +1485,7 @@ void phy_state_machine(struct work_struc
case PHY_HALTED: case PHY_ERROR:
if (phydev->link) { if (phydev->link) {
phydev->link = 0; phydev->link = 0;
- phy_link_down(phydev); - phy_link_down(phydev);
@ -71,7 +71,7 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
break; break;
--- a/drivers/net/phy/phy_device.c --- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c +++ b/drivers/net/phy/phy_device.c
@@ -1037,14 +1037,16 @@ struct phy_device *phy_find_first(struct @@ -1069,14 +1069,16 @@ struct phy_device *phy_find_first(struct
} }
EXPORT_SYMBOL(phy_find_first); EXPORT_SYMBOL(phy_find_first);
@ -95,7 +95,7 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
phydev->mii_ts->link_state(phydev->mii_ts, phydev); phydev->mii_ts->link_state(phydev->mii_ts, phydev);
--- a/drivers/net/phy/phylink.c --- a/drivers/net/phy/phylink.c
+++ b/drivers/net/phy/phylink.c +++ b/drivers/net/phy/phylink.c
@@ -1687,7 +1687,8 @@ bool phylink_expects_phy(struct phylink @@ -1724,7 +1724,8 @@ bool phylink_expects_phy(struct phylink
} }
EXPORT_SYMBOL_GPL(phylink_expects_phy); EXPORT_SYMBOL_GPL(phylink_expects_phy);
@ -107,9 +107,9 @@ still required by target/linux/ramips/files/drivers/net/ethernet/ralink/mdio.c
bool tx_pause, rx_pause; bool tx_pause, rx_pause;
--- a/include/linux/phy.h --- a/include/linux/phy.h
+++ b/include/linux/phy.h +++ b/include/linux/phy.h
@@ -739,7 +739,7 @@ struct phy_device { @@ -758,7 +758,7 @@ struct phy_device {
int pma_extable; unsigned int link_down_events;
- void (*phy_link_change)(struct phy_device *phydev, bool up); - void (*phy_link_change)(struct phy_device *phydev, bool up);
+ void (*phy_link_change)(struct phy_device *, bool up, bool do_carrier); + void (*phy_link_change)(struct phy_device *, bool up, bool do_carrier);

View File

@ -11,7 +11,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/net/phy/phy.c --- a/drivers/net/phy/phy.c
+++ b/drivers/net/phy/phy.c +++ b/drivers/net/phy/phy.c
@@ -738,7 +738,10 @@ static int phy_check_link_status(struct @@ -966,7 +966,10 @@ static int phy_check_link_status(struct
phy_link_up(phydev); phy_link_up(phydev);
} else if (!phydev->link && phydev->state != PHY_NOLINK) { } else if (!phydev->link && phydev->state != PHY_NOLINK) {
phydev->state = PHY_NOLINK; phydev->state = PHY_NOLINK;
@ -23,8 +23,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
} }
return 0; return 0;
@@ -1224,7 +1227,10 @@ void phy_state_machine(struct work_struc @@ -1485,7 +1488,10 @@ void phy_state_machine(struct work_struc
case PHY_HALTED: case PHY_ERROR:
if (phydev->link) { if (phydev->link) {
phydev->link = 0; phydev->link = 0;
- phy_link_down(phydev, true); - phy_link_down(phydev, true);
@ -37,11 +37,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
break; break;
--- a/include/linux/phy.h --- a/include/linux/phy.h
+++ b/include/linux/phy.h +++ b/include/linux/phy.h
@@ -647,6 +647,7 @@ struct phy_device { @@ -659,6 +659,7 @@ struct phy_device {
unsigned downshifted_rate:1; unsigned downshifted_rate:1;
unsigned is_on_sfp_module:1; unsigned is_on_sfp_module:1;
unsigned mac_managed_pm:1; unsigned mac_managed_pm:1;
+ unsigned no_auto_carrier_off:1; + unsigned no_auto_carrier_off:1;
unsigned wol_enabled:1;
unsigned autoneg:1; unsigned autoneg:1;
/* The most recently read link state */

View File

@ -47,7 +47,7 @@ Cc: linux-gpio@vger.kernel.org
+#endif /* __ASM_MACH_RALINK_GPIO_H */ +#endif /* __ASM_MACH_RALINK_GPIO_H */
--- a/drivers/gpio/Kconfig --- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig +++ b/drivers/gpio/Kconfig
@@ -585,6 +585,12 @@ config GPIO_SNPS_CREG @@ -594,6 +594,12 @@ config GPIO_SNPS_CREG
where only several fields in register belong to GPIO lines and where only several fields in register belong to GPIO lines and
each GPIO line owns a field with different length and on/off value. each GPIO line owns a field with different length and on/off value.
@ -62,7 +62,7 @@ Cc: linux-gpio@vger.kernel.org
depends on PLAT_SPEAR depends on PLAT_SPEAR
--- a/drivers/gpio/Makefile --- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile +++ b/drivers/gpio/Makefile
@@ -122,6 +122,7 @@ obj-$(CONFIG_GPIO_PISOSR) += gpio-pisos @@ -130,6 +130,7 @@ obj-$(CONFIG_GPIO_PISOSR) += gpio-pisos
obj-$(CONFIG_GPIO_PL061) += gpio-pl061.o obj-$(CONFIG_GPIO_PL061) += gpio-pl061.o
obj-$(CONFIG_GPIO_PMIC_EIC_SPRD) += gpio-pmic-eic-sprd.o obj-$(CONFIG_GPIO_PMIC_EIC_SPRD) += gpio-pmic-eic-sprd.o
obj-$(CONFIG_GPIO_PXA) += gpio-pxa.o obj-$(CONFIG_GPIO_PXA) += gpio-pxa.o
@ -84,7 +84,7 @@ Cc: linux-gpio@vger.kernel.org
+ +
+#include <linux/module.h> +#include <linux/module.h>
+#include <linux/io.h> +#include <linux/io.h>
+#include <linux/gpio.h> +#include <linux/gpio/driver.h>
+#include <linux/spinlock.h> +#include <linux/spinlock.h>
+#include <linux/platform_device.h> +#include <linux/platform_device.h>
+#include <linux/of_irq.h> +#include <linux/of_irq.h>
@ -373,7 +373,7 @@ Cc: linux-gpio@vger.kernel.org
+ +
+ rg->chip.parent = &pdev->dev; + rg->chip.parent = &pdev->dev;
+ rg->chip.label = dev_name(&pdev->dev); + rg->chip.label = dev_name(&pdev->dev);
+ rg->chip.of_node = np; + rg->chip.fwnode = of_node_to_fwnode(np);
+ rg->chip.ngpio = be32_to_cpu(*ngpio); + rg->chip.ngpio = be32_to_cpu(*ngpio);
+ rg->chip.direction_input = ralink_gpio_direction_input; + rg->chip.direction_input = ralink_gpio_direction_input;
+ rg->chip.direction_output = ralink_gpio_direction_output; + rg->chip.direction_output = ralink_gpio_direction_output;

View File

@ -9,12 +9,12 @@ the group function flag when requesting a different function.
Signed-off-by: Shiji Yang <yangshiji66@outlook.com> Signed-off-by: Shiji Yang <yangshiji66@outlook.com>
--- ---
drivers/pinctrl/ralink/pinctrl-ralink.c | 21 +++++++++++++++++---- drivers/pinctrl/mediatek/pinctrl-mtmips.c | 21 +++++++++++++++++----
1 file changed, 17 insertions(+), 4 deletions(-) 1 file changed, 17 insertions(+), 4 deletions(-)
--- a/drivers/pinctrl/ralink/pinctrl-ralink.c --- a/drivers/pinctrl/mediatek/pinctrl-mtmips.c
+++ b/drivers/pinctrl/ralink/pinctrl-ralink.c +++ b/drivers/pinctrl/mediatek/pinctrl-mtmips.c
@@ -123,11 +123,24 @@ static int ralink_pmx_group_enable(struc @@ -123,11 +123,24 @@ static int mtmips_pmx_group_enable(struc
int i; int i;
int shift; int shift;

View File

@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/media/usb/uvc/uvc_driver.c --- a/drivers/media/usb/uvc/uvc_driver.c
+++ b/drivers/media/usb/uvc/uvc_driver.c +++ b/drivers/media/usb/uvc/uvc_driver.c
@@ -2981,6 +2981,18 @@ static const struct usb_device_id uvc_id @@ -3120,6 +3120,18 @@ static const struct usb_device_id uvc_id
.bInterfaceSubClass = 1, .bInterfaceSubClass = 1,
.bInterfaceProtocol = 0, .bInterfaceProtocol = 0,
.driver_info = UVC_INFO_META(V4L2_META_FMT_D4XX) }, .driver_info = UVC_INFO_META(V4L2_META_FMT_D4XX) },
@ -34,15 +34,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
{ USB_INTERFACE_INFO(USB_CLASS_VIDEO, 1, UVC_PC_PROTOCOL_15) }, { USB_INTERFACE_INFO(USB_CLASS_VIDEO, 1, UVC_PC_PROTOCOL_15) },
--- a/drivers/media/usb/uvc/uvc_status.c --- a/drivers/media/usb/uvc/uvc_status.c
+++ b/drivers/media/usb/uvc/uvc_status.c +++ b/drivers/media/usb/uvc/uvc_status.c
@@ -223,6 +223,7 @@ static void uvc_status_complete(struct u @@ -228,6 +228,7 @@ static void uvc_status_complete(struct u
if (uvc_event_control(urb, status, len)) if (uvc_event_control(urb, dev->status, len))
/* The URB will be resubmitted in work context. */ /* The URB will be resubmitted in work context. */
return; return;
+ dev->motion = 1; + dev->motion = 1;
break; break;
} }
@@ -271,6 +272,7 @@ int uvc_status_init(struct uvc_device *d @@ -273,6 +274,7 @@ int uvc_status_init(struct uvc_device *d
} }
pipe = usb_rcvintpipe(dev->udev, ep->desc.bEndpointAddress); pipe = usb_rcvintpipe(dev->udev, ep->desc.bEndpointAddress);
@ -64,7 +64,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include <media/v4l2-common.h> #include <media/v4l2-common.h>
@@ -1231,9 +1236,149 @@ static void uvc_video_decode_data(struct @@ -1235,9 +1240,149 @@ static void uvc_video_decode_data(struct
uvc_urb->async_operations++; uvc_urb->async_operations++;
} }
@ -214,7 +214,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/* Mark the buffer as done if the EOF marker is set. */ /* Mark the buffer as done if the EOF marker is set. */
if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) { if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
uvc_dbg(stream->dev, FRAME, "Frame complete (EOF found)\n"); uvc_dbg(stream->dev, FRAME, "Frame complete (EOF found)\n");
@@ -1815,6 +1960,8 @@ static int uvc_init_video_isoc(struct uv @@ -1819,6 +1964,8 @@ static int uvc_init_video_isoc(struct uv
if (npackets == 0) if (npackets == 0)
return -ENOMEM; return -ENOMEM;
@ -225,7 +225,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
for_each_uvc_urb(uvc_urb, stream) { for_each_uvc_urb(uvc_urb, stream) {
--- a/drivers/media/usb/uvc/uvcvideo.h --- a/drivers/media/usb/uvc/uvcvideo.h
+++ b/drivers/media/usb/uvc/uvcvideo.h +++ b/drivers/media/usb/uvc/uvcvideo.h
@@ -75,6 +75,8 @@ @@ -73,6 +73,8 @@
#define UVC_QUIRK_FORCE_Y8 0x00000800 #define UVC_QUIRK_FORCE_Y8 0x00000800
#define UVC_QUIRK_FORCE_BPP 0x00001000 #define UVC_QUIRK_FORCE_BPP 0x00001000
#define UVC_QUIRK_WAKE_AUTOSUSPEND 0x00002000 #define UVC_QUIRK_WAKE_AUTOSUSPEND 0x00002000
@ -234,8 +234,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/* Format flags */ /* Format flags */
#define UVC_FMT_FLAG_COMPRESSED 0x00000001 #define UVC_FMT_FLAG_COMPRESSED 0x00000001
@@ -562,6 +564,7 @@ struct uvc_device { @@ -582,6 +584,7 @@ struct uvc_device {
u8 *status;
struct input_dev *input; struct input_dev *input;
char input_phys[64]; char input_phys[64];
+ int motion; + int motion;

View File

@ -16,7 +16,7 @@ Acked-by: John Crispin <blogic@openwrt.org>
--- a/drivers/spi/Kconfig --- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig +++ b/drivers/spi/Kconfig
@@ -823,6 +823,12 @@ config SPI_QCOM_GENI @@ -895,6 +895,12 @@ config SPI_QCOM_GENI
This driver can also be built as a module. If so, the module This driver can also be built as a module. If so, the module
will be called spi-geni-qcom. will be called spi-geni-qcom.
@ -26,19 +26,19 @@ Acked-by: John Crispin <blogic@openwrt.org>
+ help + help
+ This selects a driver for the Ralink RT288x/RT305x SPI Controller. + This selects a driver for the Ralink RT288x/RT305x SPI Controller.
+ +
config SPI_S3C24XX config SPI_S3C64XX
tristate "Samsung S3C24XX series SPI" tristate "Samsung S3C64XX/Exynos SoC series type SPI"
depends on ARCH_S3C24XX depends on (PLAT_SAMSUNG || ARCH_S5PV210 || ARCH_EXYNOS || COMPILE_TEST)
--- a/drivers/spi/Makefile --- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile +++ b/drivers/spi/Makefile
@@ -110,6 +110,7 @@ obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o @@ -117,6 +117,7 @@ obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
obj-$(CONFIG_MACH_REALTEK_RTL) += spi-realtek-rtl.o obj-$(CONFIG_MACH_REALTEK_RTL) += spi-realtek-rtl.o
obj-$(CONFIG_SPI_RPCIF) += spi-rpc-if.o obj-$(CONFIG_SPI_RPCIF) += spi-rpc-if.o
obj-$(CONFIG_SPI_RSPI) += spi-rspi.o obj-$(CONFIG_SPI_RSPI) += spi-rspi.o
+obj-$(CONFIG_SPI_RT2880) += spi-rt2880.o +obj-$(CONFIG_SPI_RT2880) += spi-rt2880.o
obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o obj-$(CONFIG_SPI_RZV2M_CSI) += spi-rzv2m-csi.o
spi-s3c24xx-hw-y := spi-s3c24xx.o
obj-$(CONFIG_SPI_S3C64XX) += spi-s3c64xx.o obj-$(CONFIG_SPI_S3C64XX) += spi-s3c64xx.o
obj-$(CONFIG_SPI_SC18IS602) += spi-sc18is602.o
--- /dev/null --- /dev/null
+++ b/drivers/spi/spi-rt2880.c +++ b/drivers/spi/spi-rt2880.c
@@ -0,0 +1,535 @@ @@ -0,0 +1,535 @@

View File

@ -45,7 +45,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+}; +};
--- a/drivers/i2c/busses/Kconfig --- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig +++ b/drivers/i2c/busses/Kconfig
@@ -998,6 +998,11 @@ config I2C_RK3X @@ -1021,6 +1021,11 @@ config I2C_RK3X
This driver can also be built as a module. If so, the module will This driver can also be built as a module. If so, the module will
be called i2c-rk3x. be called i2c-rk3x.
@ -59,7 +59,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on ARCH_RENESAS || COMPILE_TEST depends on ARCH_RENESAS || COMPILE_TEST
--- a/drivers/i2c/busses/Makefile --- a/drivers/i2c/busses/Makefile
+++ b/drivers/i2c/busses/Makefile +++ b/drivers/i2c/busses/Makefile
@@ -95,6 +95,7 @@ obj-$(CONFIG_I2C_PCA_PLATFORM) += i2c-pc @@ -96,6 +96,7 @@ obj-$(CONFIG_I2C_PCA_PLATFORM) += i2c-pc
obj-$(CONFIG_I2C_PNX) += i2c-pnx.o obj-$(CONFIG_I2C_PNX) += i2c-pnx.o
obj-$(CONFIG_I2C_PXA) += i2c-pxa.o obj-$(CONFIG_I2C_PXA) += i2c-pxa.o
obj-$(CONFIG_I2C_PXA_PCI) += i2c-pxa-pci.o obj-$(CONFIG_I2C_PXA_PCI) += i2c-pxa-pci.o

View File

@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mmc/host/Kconfig --- a/drivers/mmc/host/Kconfig
+++ b/drivers/mmc/host/Kconfig +++ b/drivers/mmc/host/Kconfig
@@ -1102,6 +1102,8 @@ config MMC_OWL @@ -1059,6 +1059,8 @@ config MMC_OWL
config MMC_SDHCI_EXTERNAL_DMA config MMC_SDHCI_EXTERNAL_DMA
bool bool

View File

@ -20,7 +20,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/sound/soc/Kconfig --- a/sound/soc/Kconfig
+++ b/sound/soc/Kconfig +++ b/sound/soc/Kconfig
@@ -86,6 +86,7 @@ source "sound/soc/mxs/Kconfig" @@ -99,6 +99,7 @@ source "sound/soc/mxs/Kconfig"
source "sound/soc/pxa/Kconfig" source "sound/soc/pxa/Kconfig"
source "sound/soc/qcom/Kconfig" source "sound/soc/qcom/Kconfig"
source "sound/soc/rockchip/Kconfig" source "sound/soc/rockchip/Kconfig"
@ -30,7 +30,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
source "sound/soc/sof/Kconfig" source "sound/soc/sof/Kconfig"
--- a/sound/soc/Makefile --- a/sound/soc/Makefile
+++ b/sound/soc/Makefile +++ b/sound/soc/Makefile
@@ -54,6 +54,7 @@ obj-$(CONFIG_SND_SOC) += kirkwood/ @@ -56,6 +56,7 @@ obj-$(CONFIG_SND_SOC) += kirkwood/
obj-$(CONFIG_SND_SOC) += pxa/ obj-$(CONFIG_SND_SOC) += pxa/
obj-$(CONFIG_SND_SOC) += qcom/ obj-$(CONFIG_SND_SOC) += qcom/
obj-$(CONFIG_SND_SOC) += rockchip/ obj-$(CONFIG_SND_SOC) += rockchip/

View File

@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/tty/serial/serial_core.c --- a/drivers/tty/serial/serial_core.c
+++ b/drivers/tty/serial/serial_core.c +++ b/drivers/tty/serial/serial_core.c
@@ -445,6 +445,9 @@ uart_get_baud_rate(struct uart_port *por @@ -467,6 +467,9 @@ uart_get_baud_rate(struct uart_port *por
break; break;
} }

View File

@ -13,9 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/pwm/Kconfig --- a/drivers/pwm/Kconfig
+++ b/drivers/pwm/Kconfig +++ b/drivers/pwm/Kconfig
@@ -393,6 +393,15 @@ config PWM_MEDIATEK @@ -415,6 +415,15 @@ config PWM_MICROCHIP_CORE
To compile this driver as a module, choose M here: the module To compile this driver as a module, choose M here: the module
will be called pwm-mediatek. will be called pwm-microchip-core.
+config PWM_MEDIATEK_RAMIPS +config PWM_MEDIATEK_RAMIPS
+ tristate "Mediatek PWM support" + tristate "Mediatek PWM support"
@ -31,14 +31,14 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on ARCH_MXS || COMPILE_TEST depends on ARCH_MXS || COMPILE_TEST
--- a/drivers/pwm/Makefile --- a/drivers/pwm/Makefile
+++ b/drivers/pwm/Makefile +++ b/drivers/pwm/Makefile
@@ -34,6 +34,7 @@ obj-$(CONFIG_PWM_LPSS_PCI) += pwm-lpss-p @@ -35,6 +35,7 @@ obj-$(CONFIG_PWM_LPSS_PCI) += pwm-lpss-p
obj-$(CONFIG_PWM_LPSS_PLATFORM) += pwm-lpss-platform.o obj-$(CONFIG_PWM_LPSS_PLATFORM) += pwm-lpss-platform.o
obj-$(CONFIG_PWM_MESON) += pwm-meson.o obj-$(CONFIG_PWM_MESON) += pwm-meson.o
obj-$(CONFIG_PWM_MEDIATEK) += pwm-mediatek.o obj-$(CONFIG_PWM_MEDIATEK) += pwm-mediatek.o
+obj-$(CONFIG_PWM_MEDIATEK_RAMIPS) += pwm-mediatek-ramips.o +obj-$(CONFIG_PWM_MEDIATEK_RAMIPS) += pwm-mediatek-ramips.o
obj-$(CONFIG_PWM_MICROCHIP_CORE) += pwm-microchip-core.o
obj-$(CONFIG_PWM_MTK_DISP) += pwm-mtk-disp.o obj-$(CONFIG_PWM_MTK_DISP) += pwm-mtk-disp.o
obj-$(CONFIG_PWM_MXS) += pwm-mxs.o obj-$(CONFIG_PWM_MXS) += pwm-mxs.o
obj-$(CONFIG_PWM_NTXEC) += pwm-ntxec.o
--- /dev/null --- /dev/null
+++ b/drivers/pwm/pwm-mediatek-ramips.c +++ b/drivers/pwm/pwm-mediatek-ramips.c
@@ -0,0 +1,197 @@ @@ -0,0 +1,197 @@

View File

@ -1,6 +1,6 @@
--- a/drivers/usb/dwc2/platform.c --- a/drivers/usb/dwc2/platform.c
+++ b/drivers/usb/dwc2/platform.c +++ b/drivers/usb/dwc2/platform.c
@@ -462,6 +462,12 @@ static int dwc2_driver_probe(struct plat @@ -493,6 +493,12 @@ static int dwc2_driver_probe(struct plat
if (retval) if (retval)
return retval; return retval;

View File

@ -1,6 +1,6 @@
--- a/drivers/misc/Makefile --- a/drivers/misc/Makefile
+++ b/drivers/misc/Makefile +++ b/drivers/misc/Makefile
@@ -50,6 +50,7 @@ obj-$(CONFIG_ECHO) += echo/ @@ -52,6 +52,7 @@ obj-$(CONFIG_ECHO) += echo/
obj-$(CONFIG_CXL_BASE) += cxl/ obj-$(CONFIG_CXL_BASE) += cxl/
obj-$(CONFIG_DW_XDATA_PCIE) += dw-xdata-pcie.o obj-$(CONFIG_DW_XDATA_PCIE) += dw-xdata-pcie.o
obj-$(CONFIG_PCI_ENDPOINT_TEST) += pci_endpoint_test.o obj-$(CONFIG_PCI_ENDPOINT_TEST) += pci_endpoint_test.o

View File

@ -3260,17 +3260,17 @@
+#endif +#endif
--- a/drivers/crypto/Kconfig --- a/drivers/crypto/Kconfig
+++ b/drivers/crypto/Kconfig +++ b/drivers/crypto/Kconfig
@@ -824,4 +824,6 @@ config CRYPTO_DEV_SA2UL @@ -797,4 +797,6 @@ config CRYPTO_DEV_SA2UL
source "drivers/crypto/keembay/Kconfig"
source "drivers/crypto/aspeed/Kconfig" source "drivers/crypto/aspeed/Kconfig"
source "drivers/crypto/starfive/Kconfig"
+source "drivers/crypto/mtk-eip93/Kconfig" +source "drivers/crypto/mtk-eip93/Kconfig"
+ +
endif # CRYPTO_HW endif # CRYPTO_HW
--- a/drivers/crypto/Makefile --- a/drivers/crypto/Makefile
+++ b/drivers/crypto/Makefile +++ b/drivers/crypto/Makefile
@@ -53,3 +53,4 @@ obj-y += xilinx/ @@ -51,3 +51,4 @@ obj-y += hisilicon/
obj-y += hisilicon/
obj-$(CONFIG_CRYPTO_DEV_AMLOGIC_GXL) += amlogic/ obj-$(CONFIG_CRYPTO_DEV_AMLOGIC_GXL) += amlogic/
obj-y += keembay/ obj-y += intel/
obj-y += starfive/
+obj-$(CONFIG_CRYPTO_DEV_EIP93) += mtk-eip93/ +obj-$(CONFIG_CRYPTO_DEV_EIP93) += mtk-eip93/