iproute2: update to 6.0.0

Release Notes:
https://lore.kernel.org/netdev/20221004082610.56b04719@hermes.local/t/

Remove upstreamed patch:
- 010-ipstats-Add-param.h-for-musl.patch

Refreshed:
- 140-keep_libmnl_optional.patch
- 145-keep_libelf_optional.patch
- 150-keep_libcap_optional.patch
- 155-keep_tirpc_optional.patch
- 170-ip_tiny.patch
- 190-fix-nls-rpath-link.patch
- 200-drop_libbsd_dependency.patch
- 300-selinux-configurable.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
This commit is contained in:
Nick Hainke 2022-10-05 12:37:47 +02:00 committed by Hauke Mehrtens
parent 5479281c72
commit 0dfe1d2175
10 changed files with 11 additions and 34 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=5.19.0
PKG_VERSION:=6.0.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
PKG_HASH:=26b7a34d6a7fd2f7a42e2b39c5a90cb61bac522d1096067ffeb195e5693d7791
PKG_HASH:=523139e9e72aec996374fa2de74be4c53d2dd05589488934d21ff97bae19580a
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0

View File

@ -1,23 +0,0 @@
From cf6b60c504d4be5e1df2b2745e55d677967831d0 Mon Sep 17 00:00:00 2001
From: Changhyeok Bae <changhyeok.bae@gmail.com>
Date: Tue, 9 Aug 2022 04:01:05 +0000
Subject: [PATCH 1/5] ipstats: Add param.h for musl
Fix build error for musl
| /usr/src/debug/iproute2/5.19.0-r0/iproute2-5.19.0/ip/ipstats.c:231: undefined reference to `MIN'
Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
---
ip/ipstats.c | 1 +
1 file changed, 1 insertion(+)
--- a/ip/ipstats.c
+++ b/ip/ipstats.c
@@ -1,6 +1,7 @@
// SPDX-License-Identifier: GPL-2.0+
#include <assert.h>
#include <errno.h>
+#include <sys/param.h>
#include "list.h"
#include "utils.h"

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -411,7 +411,7 @@ check_tirpc()
@@ -412,7 +412,7 @@ check_tirpc()
check_mnl()
{

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -266,7 +266,7 @@ EOF
@@ -267,7 +267,7 @@ EOF
check_elf()
{

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -469,7 +469,7 @@ EOF
@@ -470,7 +470,7 @@ EOF
check_cap()
{

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -398,7 +398,7 @@ check_selinux()
@@ -399,7 +399,7 @@ check_selinux()
check_tirpc()
{

View File

@ -105,4 +105,4 @@
+
UTILOBJ = utils.o utils_math.o rt_names.o ll_map.o ll_types.o ll_proto.o ll_addr.o \
inet_proto.o namespace.o json_writer.o json_print.o json_print_math.o \
names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o
names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o ppp_proto.o

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -290,7 +290,7 @@ int main(int argc, char **argv) {
@@ -291,7 +291,7 @@ int main(int argc, char **argv) {
}
EOF
@ -9,7 +9,7 @@
local ret=$?
rm -f $TMPDIR/libbpf_test.c $TMPDIR/libbpf_test
@@ -308,7 +308,7 @@ int main(int argc, char **argv) {
@@ -309,7 +309,7 @@ int main(int argc, char **argv) {
}
EOF

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -455,14 +455,8 @@ EOF
@@ -456,14 +456,8 @@ EOF
if $CC -I$INCLUDE -o $TMPDIR/strtest $TMPDIR/strtest.c >/dev/null 2>&1; then
echo "no"
else

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -385,7 +385,7 @@ check_libbpf()
@@ -386,7 +386,7 @@ check_libbpf()
check_selinux()
# SELinux is a compile time option in the ss utility
{