mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-12 21:55:38 +00:00
toolchain/gcc: update 6.x to 6.3.0
This is a bugfix release Build and run tested on mvebu/Linksys WRT1900AC v1 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
This commit is contained in:
parent
16725e2db0
commit
0a5ccfbadd
@ -5,7 +5,7 @@ config GCC_VERSION_4_8_ARC
|
|||||||
config GCC_VERSION
|
config GCC_VERSION
|
||||||
string
|
string
|
||||||
default "arc-2016.03" if GCC_VERSION_4_8_ARC
|
default "arc-2016.03" if GCC_VERSION_4_8_ARC
|
||||||
default "6.2.0" if GCC_USE_VERSION_6
|
default "6.3.0" if GCC_USE_VERSION_6
|
||||||
default "5.4.0"
|
default "5.4.0"
|
||||||
|
|
||||||
config GCC_VERSION_4_8
|
config GCC_VERSION_4_8
|
||||||
|
@ -32,8 +32,8 @@ ifeq ($(PKG_VERSION),5.4.0)
|
|||||||
PKG_HASH:=608df76dec2d34de6558249d8af4cbee21eceddbcb580d666f7a5a583ca3303a
|
PKG_HASH:=608df76dec2d34de6558249d8af4cbee21eceddbcb580d666f7a5a583ca3303a
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifeq ($(PKG_VERSION),6.2.0)
|
ifeq ($(PKG_VERSION),6.3.0)
|
||||||
PKG_HASH:=9944589fc722d3e66308c0ce5257788ebd7872982a718aa2516123940671b7c5
|
PKG_HASH:=f06ae7f3f790fbf0f018f6d40e844451e6bc3b7bc96e128e63b09825c1f8b29f
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
|
ifneq ($(CONFIG_GCC_VERSION_4_8_ARC),)
|
||||||
|
@ -14,11 +14,9 @@ git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@239859 138bc75d-0d04-0410-961f-8
|
|||||||
gcc/config.gcc | 4 ++--
|
gcc/config.gcc | 4 ++--
|
||||||
2 files changed, 6 insertions(+), 2 deletions(-)
|
2 files changed, 6 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/gcc/config.gcc b/gcc/config.gcc
|
|
||||||
index 8827dc8..e544d76 100644
|
|
||||||
--- a/gcc/config.gcc
|
--- a/gcc/config.gcc
|
||||||
+++ b/gcc/config.gcc
|
+++ b/gcc/config.gcc
|
||||||
@@ -1465,7 +1465,7 @@ i[34567]86-*-linux* | i[34567]86-*-kfreebsd*-gnu | i[34567]86-*-gnu* | i[34567]8
|
@@ -1495,7 +1495,7 @@ i[34567]86-*-linux* | i[34567]86-*-kfree
|
||||||
extra_options="${extra_options} linux-android.opt"
|
extra_options="${extra_options} linux-android.opt"
|
||||||
# Assume modern glibc if not targeting Android nor uclibc.
|
# Assume modern glibc if not targeting Android nor uclibc.
|
||||||
case ${target} in
|
case ${target} in
|
||||||
@ -27,7 +25,7 @@ index 8827dc8..e544d76 100644
|
|||||||
;;
|
;;
|
||||||
*)
|
*)
|
||||||
default_gnu_indirect_function=yes
|
default_gnu_indirect_function=yes
|
||||||
@@ -1531,7 +1531,7 @@ x86_64-*-linux* | x86_64-*-kfreebsd*-gnu)
|
@@ -1564,7 +1564,7 @@ x86_64-*-linux* | x86_64-*-kfreebsd*-gnu
|
||||||
extra_options="${extra_options} linux-android.opt"
|
extra_options="${extra_options} linux-android.opt"
|
||||||
# Assume modern glibc if not targeting Android nor uclibc.
|
# Assume modern glibc if not targeting Android nor uclibc.
|
||||||
case ${target} in
|
case ${target} in
|
@ -1,6 +1,6 @@
|
|||||||
--- a/gcc/config/rs6000/rs6000.c
|
--- a/gcc/config/rs6000/rs6000.c
|
||||||
+++ b/gcc/config/rs6000/rs6000.c
|
+++ b/gcc/config/rs6000/rs6000.c
|
||||||
@@ -24141,7 +24141,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
@@ -24171,7 +24171,7 @@ rs6000_savres_strategy (rs6000_stack_t *
|
||||||
/* Define cutoff for using out-of-line functions to save registers. */
|
/* Define cutoff for using out-of-line functions to save registers. */
|
||||||
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
|
||||||
{
|
{
|
@ -1,6 +1,6 @@
|
|||||||
--- a/libstdc++-v3/include/Makefile.in
|
--- a/libstdc++-v3/include/Makefile.in
|
||||||
+++ b/libstdc++-v3/include/Makefile.in
|
+++ b/libstdc++-v3/include/Makefile.in
|
||||||
@@ -1458,7 +1458,7 @@ stamp-bits: ${bits_headers}
|
@@ -1459,7 +1459,7 @@ stamp-bits: ${bits_headers}
|
||||||
@$(STAMP) stamp-bits
|
@$(STAMP) stamp-bits
|
||||||
|
|
||||||
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
stamp-bits-sup: stamp-bits ${bits_sup_headers}
|
Loading…
x
Reference in New Issue
Block a user