diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index d5feae3a079..5d402f02982 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.5)
-  LINUX_KERNEL_MD5SUM:=ae355001775bc841132fe0fea2f354d4
+ifeq ($(LINUX_VERSION),3.7.6)
+  LINUX_KERNEL_MD5SUM:=4c4d80619c713f83015fc6b1c6280891
 endif
 
 # disable the md5sum check for unknown kernel versions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index fe919dad988..5f31bc59438 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 315db0ec91d..4a9a15d3266 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
index 630d8d20e74..0a285f935d2 100644
--- a/target/linux/cns21xx/Makefile
+++ b/target/linux/cns21xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/generic/patches-3.7/250-netfilter_depends.patch b/target/linux/generic/patches-3.7/250-netfilter_depends.patch
index 3c9013400a3..218df4cfb1a 100644
--- a/target/linux/generic/patches-3.7/250-netfilter_depends.patch
+++ b/target/linux/generic/patches-3.7/250-netfilter_depends.patch
@@ -8,7 +8,7 @@
  	depends on NETFILTER_ADVANCED
  	help
  	  H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -750,7 +749,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -757,7 +756,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
  	tristate '"TCPMSS" target support'
diff --git a/target/linux/generic/patches-3.7/600-netfilter_layer7_2.22.patch b/target/linux/generic/patches-3.7/600-netfilter_layer7_2.22.patch
index 0c8c5e890b2..55daeab7aee 100644
--- a/target/linux/generic/patches-3.7/600-netfilter_layer7_2.22.patch
+++ b/target/linux/generic/patches-3.7/600-netfilter_layer7_2.22.patch
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -1176,6 +1176,27 @@ config NETFILTER_XT_MATCH_STATE
+@@ -1183,6 +1183,27 @@ config NETFILTER_XT_MATCH_STATE
  
  	  To compile it as a module, choose M here.  If unsure, say N.
  
diff --git a/target/linux/generic/patches-3.7/603-netfilter_layer7_2.6.36_fix.patch b/target/linux/generic/patches-3.7/603-netfilter_layer7_2.6.36_fix.patch
index 23a1b1b26d4..e3f203289ee 100644
--- a/target/linux/generic/patches-3.7/603-netfilter_layer7_2.6.36_fix.patch
+++ b/target/linux/generic/patches-3.7/603-netfilter_layer7_2.6.36_fix.patch
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -980,6 +980,27 @@ config NETFILTER_XT_MATCH_IPVS
+@@ -987,6 +987,27 @@ config NETFILTER_XT_MATCH_IPVS
  
  	  If unsure, say N.
  
@@ -28,7 +28,7 @@
  config NETFILTER_XT_MATCH_LENGTH
  	tristate '"length" match support'
  	depends on NETFILTER_ADVANCED
-@@ -1176,26 +1197,11 @@ config NETFILTER_XT_MATCH_STATE
+@@ -1183,26 +1204,11 @@ config NETFILTER_XT_MATCH_STATE
  
  	  To compile it as a module, choose M here.  If unsure, say N.
  
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index febdeccfb4a..a7241f0f19a 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index fbf6f819f79..7d9d08e0ffb 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 DEVICE_TYPE:=developerboard
 
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
index dcd1a8c8268..552d972de5c 100644
--- a/target/linux/mpc83xx/Makefile
+++ b/target/linux/mpc83xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index b5210774a5d..3950c6ddcc1 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 4a57f217ae0..871c5b01b58 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 68e5a57b3c0..a5879dd0ebd 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 9a5f8115ea1..5d0a6437036 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
diff --git a/target/linux/rb532/Makefile b/target/linux/rb532/Makefile
index 69f01b7476c..7044f109785 100644
--- a/target/linux/rb532/Makefile
+++ b/target/linux/rb532/Makefile
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index e10e1697e91..f215751d69d 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
 			kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
 			kmod-ledtrig-netdev \
 			kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
diff --git a/target/linux/x86/geos/target.mk b/target/linux/x86/geos/target.mk
index c82b1895c0a..90ed8f3b4a6 100644
--- a/target/linux/x86/geos/target.mk
+++ b/target/linux/x86/geos/target.mk
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.5
+LINUX_VERSION:=3.7.6
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \