kernel: bump 5.10 to 5.10.185

Removed because upstreamed:
uml/patches-5.10/001-um-Fix-build-w-o-CONFIG_PM_SLEEP.patch

All other patches automatically rebased.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
Hauke Mehrtens 2023-07-01 14:31:42 +02:00
parent 2034387af4
commit 0344144e77
20 changed files with 27 additions and 59 deletions

View File

@ -1,2 +1,2 @@
LINUX_VERSION-5.10 = .184 LINUX_VERSION-5.10 = .185
LINUX_KERNEL_HASH-5.10.184 = 77a9bebc1d1fa057212a3ac62c2a0784aafcdef149032df8898ebc9ed3c62908 LINUX_KERNEL_HASH-5.10.185 = 280662ec8dc8738cf947ad66e748141abd58cbe3b5ed66b7f2b153222b7c7090

View File

@ -754,7 +754,7 @@
ptr = ip6hoff + sizeof(struct ipv6hdr); ptr = ip6hoff + sizeof(struct ipv6hdr);
--- a/include/net/neighbour.h --- a/include/net/neighbour.h
+++ b/include/net/neighbour.h +++ b/include/net/neighbour.h
@@ -275,8 +275,10 @@ static inline bool neigh_key_eq128(const @@ -270,8 +270,10 @@ static inline bool neigh_key_eq128(const
const u32 *n32 = (const u32 *)n->primary_key; const u32 *n32 = (const u32 *)n->primary_key;
const u32 *p32 = pkey; const u32 *p32 = pkey;

View File

@ -221,7 +221,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
static inline int mmc_blk_part_switch(struct mmc_card *card, static inline int mmc_blk_part_switch(struct mmc_card *card,
unsigned int part_type); unsigned int part_type);
static void mmc_blk_rw_rq_prep(struct mmc_queue_req *mqrq, static void mmc_blk_rw_rq_prep(struct mmc_queue_req *mqrq,
@@ -2901,6 +2908,7 @@ static int mmc_blk_probe(struct mmc_card @@ -2906,6 +2913,7 @@ static int mmc_blk_probe(struct mmc_card
{ {
struct mmc_blk_data *md, *part_md; struct mmc_blk_data *md, *part_md;
char cap_str[10]; char cap_str[10];
@ -229,7 +229,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
/* /*
* Check that the card supports the command class(es) we need. * Check that the card supports the command class(es) we need.
@@ -2908,7 +2916,16 @@ static int mmc_blk_probe(struct mmc_card @@ -2913,7 +2921,16 @@ static int mmc_blk_probe(struct mmc_card
if (!(card->csd.cmdclass & CCC_BLOCK_READ)) if (!(card->csd.cmdclass & CCC_BLOCK_READ))
return -ENODEV; return -ENODEV;
@ -247,7 +247,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
card->complete_wq = alloc_workqueue("mmc_complete", card->complete_wq = alloc_workqueue("mmc_complete",
WQ_MEM_RECLAIM | WQ_HIGHPRI, 0); WQ_MEM_RECLAIM | WQ_HIGHPRI, 0);
@@ -2923,9 +2940,14 @@ static int mmc_blk_probe(struct mmc_card @@ -2928,9 +2945,14 @@ static int mmc_blk_probe(struct mmc_card
string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2, string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2,
cap_str, sizeof(cap_str)); cap_str, sizeof(cap_str));

View File

@ -25,7 +25,7 @@ Signed-off-by: Naushir Patuck <naush@raspberrypi.com>
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -16348,6 +16348,14 @@ S: Maintained @@ -16341,6 +16341,14 @@ S: Maintained
T: git git://linuxtv.org/media_tree.git T: git git://linuxtv.org/media_tree.git
F: drivers/media/i2c/imx355.c F: drivers/media/i2c/imx355.c

View File

@ -40,7 +40,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
for_each_subsys(ss, ssid) { for_each_subsys(ss, ssid) {
if (ss->early_init) { if (ss->early_init) {
struct cgroup_subsys_state *css = struct cgroup_subsys_state *css =
@@ -6361,6 +6370,10 @@ static int __init cgroup_disable(char *s @@ -6360,6 +6369,10 @@ static int __init cgroup_disable(char *s
strcmp(token, ss->legacy_name)) strcmp(token, ss->legacy_name))
continue; continue;
@ -51,7 +51,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
static_branch_disable(cgroup_subsys_enabled_key[i]); static_branch_disable(cgroup_subsys_enabled_key[i]);
pr_info("Disabling %s control group subsystem\n", pr_info("Disabling %s control group subsystem\n",
ss->name); ss->name);
@@ -6370,6 +6383,31 @@ static int __init cgroup_disable(char *s @@ -6369,6 +6382,31 @@ static int __init cgroup_disable(char *s
} }
__setup("cgroup_disable=", cgroup_disable); __setup("cgroup_disable=", cgroup_disable);

View File

@ -132,7 +132,7 @@ Signed-off-by: David Plowman <david.plowman@raspberrypi.com>
+... +...
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -16362,6 +16362,7 @@ M: Raspberry Pi Kernel Maintenance <kern @@ -16355,6 +16355,7 @@ M: Raspberry Pi Kernel Maintenance <kern
L: linux-media@vger.kernel.org L: linux-media@vger.kernel.org
S: Maintained S: Maintained
T: git git://linuxtv.org/media_tree.git T: git git://linuxtv.org/media_tree.git

View File

@ -161,7 +161,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -5526,6 +5526,14 @@ S: Maintained @@ -5519,6 +5519,14 @@ S: Maintained
F: Documentation/devicetree/bindings/display/panel/feiyang,fy07024di26a30d.yaml F: Documentation/devicetree/bindings/display/panel/feiyang,fy07024di26a30d.yaml
F: drivers/gpu/drm/panel/panel-feiyang-fy07024di26a30d.c F: drivers/gpu/drm/panel/panel-feiyang-fy07024di26a30d.c

View File

@ -76,7 +76,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
/** /**
* napi_synchronize - wait until NAPI is not running * napi_synchronize - wait until NAPI is not running
@@ -1868,6 +1858,8 @@ enum netdev_ml_priv_type { @@ -1867,6 +1857,8 @@ enum netdev_ml_priv_type {
* *
* @wol_enabled: Wake-on-LAN is enabled * @wol_enabled: Wake-on-LAN is enabled
* *
@ -85,7 +85,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
* @net_notifier_list: List of per-net netdev notifier block * @net_notifier_list: List of per-net netdev notifier block
* that follow this device when it is moved * that follow this device when it is moved
* to another network namespace. * to another network namespace.
@@ -2187,6 +2179,7 @@ struct net_device { @@ -2183,6 +2175,7 @@ struct net_device {
struct lock_class_key *qdisc_running_key; struct lock_class_key *qdisc_running_key;
bool proto_down; bool proto_down;
unsigned wol_enabled:1; unsigned wol_enabled:1;

View File

@ -104,7 +104,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
}; };
/** /**
@@ -2854,6 +2879,8 @@ void dev_remove_offload(struct packet_of @@ -2850,6 +2875,8 @@ void dev_remove_offload(struct packet_of
int dev_get_iflink(const struct net_device *dev); int dev_get_iflink(const struct net_device *dev);
int dev_fill_metadata_dst(struct net_device *dev, struct sk_buff *skb); int dev_fill_metadata_dst(struct net_device *dev, struct sk_buff *skb);

View File

@ -26,7 +26,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
* @name: name of the struct -- the string is not copied internally * @name: name of the struct -- the string is not copied internally
--- a/net/Makefile --- a/net/Makefile
+++ b/net/Makefile +++ b/net/Makefile
@@ -53,7 +53,7 @@ obj-$(CONFIG_TIPC) += tipc/ @@ -52,7 +52,7 @@ obj-$(CONFIG_TIPC) += tipc/
obj-$(CONFIG_NETLABEL) += netlabel/ obj-$(CONFIG_NETLABEL) += netlabel/
obj-$(CONFIG_IUCV) += iucv/ obj-$(CONFIG_IUCV) += iucv/
obj-$(CONFIG_SMC) += smc/ obj-$(CONFIG_SMC) += smc/

View File

@ -35,7 +35,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/* Specifies the type of the struct net_device::ml_priv pointer */ /* Specifies the type of the struct net_device::ml_priv pointer */
enum netdev_ml_priv_type { enum netdev_ml_priv_type {
@@ -2023,6 +2025,11 @@ struct net_device { @@ -2022,6 +2024,11 @@ struct net_device {
const struct tlsdev_ops *tlsdev_ops; const struct tlsdev_ops *tlsdev_ops;
#endif #endif
@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
const struct header_ops *header_ops; const struct header_ops *header_ops;
unsigned int flags; unsigned int flags;
@@ -2113,6 +2120,10 @@ struct net_device { @@ -2109,6 +2116,10 @@ struct net_device {
struct mpls_dev __rcu *mpls_ptr; struct mpls_dev __rcu *mpls_ptr;
#endif #endif

View File

@ -19,7 +19,7 @@
#define QUECTEL_VENDOR_ID 0x2c7c #define QUECTEL_VENDOR_ID 0x2c7c
/* These Quectel products use Quectel's vendor ID */ /* These Quectel products use Quectel's vendor ID */
@@ -1169,6 +1171,11 @@ static const struct usb_device_id option @@ -1173,6 +1175,11 @@ static const struct usb_device_id option
.driver_info = ZLP }, .driver_info = ZLP },
{ USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96), { USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
.driver_info = RSVD(4) }, .driver_info = RSVD(4) },

View File

@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/include/linux/netdevice.h --- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h +++ b/include/linux/netdevice.h
@@ -2062,6 +2062,8 @@ struct net_device { @@ -2061,6 +2061,8 @@ struct net_device {
struct netdev_hw_addr_list mc; struct netdev_hw_addr_list mc;
struct netdev_hw_addr_list dev_addrs; struct netdev_hw_addr_list dev_addrs;

View File

@ -49,7 +49,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/drivers/net/usb/qmi_wwan.c --- a/drivers/net/usb/qmi_wwan.c
+++ b/drivers/net/usb/qmi_wwan.c +++ b/drivers/net/usb/qmi_wwan.c
@@ -1253,6 +1253,7 @@ static const struct usb_device_id produc @@ -1255,6 +1255,7 @@ static const struct usb_device_id produc
{QMI_FIXED_INTF(0x19d2, 0x1426, 2)}, /* ZTE MF91 */ {QMI_FIXED_INTF(0x19d2, 0x1426, 2)}, /* ZTE MF91 */
{QMI_FIXED_INTF(0x19d2, 0x1428, 2)}, /* Telewell TW-LTE 4G v2 */ {QMI_FIXED_INTF(0x19d2, 0x1428, 2)}, /* Telewell TW-LTE 4G v2 */
{QMI_FIXED_INTF(0x19d2, 0x1432, 3)}, /* ZTE ME3620 */ {QMI_FIXED_INTF(0x19d2, 0x1432, 3)}, /* ZTE ME3620 */

View File

@ -1090,7 +1090,7 @@ Date: Wed Sep 30 17:20:19 2020 +0530
+}; +};
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -7068,6 +7068,14 @@ F: drivers/ptp/ptp_qoriq.c @@ -7061,6 +7061,14 @@ F: drivers/ptp/ptp_qoriq.c
F: drivers/ptp/ptp_qoriq_debugfs.c F: drivers/ptp/ptp_qoriq_debugfs.c
F: include/linux/fsl/ptp_qoriq.h F: include/linux/fsl/ptp_qoriq.h

View File

@ -16,7 +16,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -8538,6 +8538,22 @@ F: include/net/nl802154.h @@ -8531,6 +8531,22 @@ F: include/net/nl802154.h
F: net/ieee802154/ F: net/ieee802154/
F: net/mac802154/ F: net/mac802154/

View File

@ -17,7 +17,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
--- a/arch/mips/kernel/setup.c --- a/arch/mips/kernel/setup.c
+++ b/arch/mips/kernel/setup.c +++ b/arch/mips/kernel/setup.c
@@ -542,8 +542,28 @@ static int __init bootcmdline_scan_chose @@ -543,8 +543,28 @@ static int __init bootcmdline_scan_chose
#endif /* CONFIG_OF_EARLY_FLATTREE */ #endif /* CONFIG_OF_EARLY_FLATTREE */
@ -46,7 +46,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
bool dt_bootargs = false; bool dt_bootargs = false;
/* /*
@@ -557,6 +577,14 @@ static void __init bootcmdline_init(void @@ -558,6 +578,14 @@ static void __init bootcmdline_init(void
} }
/* /*

View File

@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/arch/mips/kernel/setup.c --- a/arch/mips/kernel/setup.c
+++ b/arch/mips/kernel/setup.c +++ b/arch/mips/kernel/setup.c
@@ -694,8 +694,6 @@ static void __init arch_mem_init(char ** @@ -695,8 +695,6 @@ static void __init arch_mem_init(char **
if (crashk_res.start != crashk_res.end) if (crashk_res.start != crashk_res.end)
memblock_reserve(crashk_res.start, resource_size(&crashk_res)); memblock_reserve(crashk_res.start, resource_size(&crashk_res));
#endif #endif
@ -19,7 +19,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
/* /*
* In order to reduce the possibility of kernel panic when failed to * In order to reduce the possibility of kernel panic when failed to
* get IO TLB memory under CONFIG_SWIOTLB, it is better to allocate * get IO TLB memory under CONFIG_SWIOTLB, it is better to allocate
@@ -815,6 +813,7 @@ void __init setup_arch(char **cmdline_p) @@ -816,6 +814,7 @@ void __init setup_arch(char **cmdline_p)
cpu_cache_init(); cpu_cache_init();
paging_init(); paging_init();

View File

@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -14816,6 +14816,13 @@ S: Maintained @@ -14809,6 +14809,13 @@ S: Maintained
F: include/sound/rt*.h F: include/sound/rt*.h
F: sound/soc/codecs/rt* F: sound/soc/codecs/rt*

View File

@ -1,32 +0,0 @@
From 1fb1abc83636f5329c26cd29f0f19f3faeb697a5 Mon Sep 17 00:00:00 2001
From: Johannes Berg <johannes.berg@intel.com>
Date: Mon, 14 Dec 2020 20:51:02 +0100
Subject: [PATCH] um: Fix build w/o CONFIG_PM_SLEEP
uml_pm_wake() is unconditionally called from the SIGUSR1 wakeup
handler since that's in the userspace portion of UML, and thus
a bit tricky to ifdef out. Since pm_system_wakeup() can always
be called (but may be an empty inline), also simply always have
uml_pm_wake() to fix the build.
Reported-by: Randy Dunlap <rdunlap@infradead.org>
Acked-by: Randy Dunlap <rdunlap@infradead.org> # build-tested
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
Signed-off-by: Richard Weinberger <richard@nod.at>
---
--- a/arch/um/kernel/um_arch.c
+++ b/arch/um/kernel/um_arch.c
@@ -387,12 +387,12 @@ void text_poke_sync(void)
{
}
-#ifdef CONFIG_PM_SLEEP
void uml_pm_wake(void)
{
pm_system_wakeup();
}
+#ifdef CONFIG_PM_SLEEP
static int init_pm_wake_signal(void)
{
/*