mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-01 16:58:22 +00:00
gdb: Update to version 10.1
gdb 10.1 adds many new features for example gdbserver support for - ARC GNU/Linux - RISC-V GNU/Linux Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: maurerr <mariusd84@gmail.com>
This commit is contained in:
parent
077b344cec
commit
030d641d1d
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gdb
|
||||
PKG_VERSION:=8.3.1
|
||||
PKG_VERSION:=10.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/gdb
|
||||
PKG_HASH:=1e55b4d7cdca7b34be12f4ceae651623aa73b2fd640152313f9f66a7149757c4
|
||||
PKG_HASH:=f82f1eceeec14a3afa2de8d9b0d3c91d5a3820e23e0a01bbb70ef9f0276b62c0
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
@ -72,7 +72,7 @@ define Build/Install
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||
install-gdb
|
||||
install-gdb install-gdbserver
|
||||
endef
|
||||
|
||||
define Package/gdb/install
|
||||
|
@ -1,7 +1,7 @@
|
||||
See http://sourceware.org/bugzilla/show_bug.cgi?id=14523
|
||||
|
||||
--- a/gdb/common/signals.c
|
||||
+++ b/gdb/common/signals.c
|
||||
--- a/gdbsupport/signals.cc
|
||||
+++ b/gdbsupport/signals.cc
|
||||
@@ -348,6 +348,11 @@ gdb_signal_from_host (int hostsig)
|
||||
else if (64 <= hostsig && hostsig <= 127)
|
||||
return (enum gdb_signal)
|
||||
|
@ -8,9 +8,9 @@
|
||||
#include "defs.h"
|
||||
#include "inferior.h"
|
||||
#include "infrun.h"
|
||||
@@ -72,6 +73,10 @@
|
||||
#define SPUFS_MAGIC 0x23c9b64e
|
||||
#endif
|
||||
@@ -70,6 +71,10 @@
|
||||
#include "gdbsupport/gdb-sigmask.h"
|
||||
#include "debug.h"
|
||||
|
||||
+#ifndef __SIGRTMIN
|
||||
+#define __SIGRTMIN SIGRTMIN
|
||||
@ -39,8 +39,8 @@
|
||||
#include <asm/cputable.h>
|
||||
|
||||
/* This sometimes isn't defined. */
|
||||
--- a/gdb/gdbserver/linux-ppc-low.c
|
||||
+++ b/gdb/gdbserver/linux-ppc-low.c
|
||||
--- a/gdbserver/linux-ppc-low.cc
|
||||
+++ b/gdbserver/linux-ppc-low.cc
|
||||
@@ -23,7 +23,9 @@
|
||||
#include "elf/common.h"
|
||||
#include <sys/uio.h>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1283,13 +1283,13 @@ if test -z "$LD"; then
|
||||
@@ -1302,13 +1302,13 @@ if test -z "$LD"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
@ -17,7 +17,7 @@
|
||||
AC_LANG_PUSH(C++)
|
||||
AC_LINK_IFELSE([AC_LANG_SOURCE([
|
||||
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
|
||||
@@ -1629,7 +1629,7 @@ AC_ARG_WITH(stage1-ldflags,
|
||||
@@ -1648,7 +1648,7 @@ AC_ARG_WITH(stage1-ldflags,
|
||||
# trust that they are doing what they want.
|
||||
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
|
||||
-a "$have_static_libs" = yes; then
|
||||
@ -26,7 +26,7 @@
|
||||
fi])
|
||||
AC_SUBST(stage1_ldflags)
|
||||
|
||||
@@ -1658,7 +1658,7 @@ AC_ARG_WITH(boot-ldflags,
|
||||
@@ -1677,7 +1677,7 @@ AC_ARG_WITH(boot-ldflags,
|
||||
# statically. But if the user explicitly specified the libraries to
|
||||
# use, trust that they are doing what they want.
|
||||
if test "$poststage1_libs" = ""; then
|
||||
@ -37,7 +37,7 @@
|
||||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -5053,14 +5053,14 @@ if test -z "$LD"; then
|
||||
@@ -5075,14 +5075,14 @@ if test -z "$LD"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
@ -56,7 +56,7 @@
|
||||
ac_ext=cpp
|
||||
ac_cpp='$CXXCPP $CPPFLAGS'
|
||||
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
@@ -5861,7 +5861,7 @@ else
|
||||
@@ -5883,7 +5883,7 @@ else
|
||||
# trust that they are doing what they want.
|
||||
if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
|
||||
-a "$have_static_libs" = yes; then
|
||||
@ -65,7 +65,7 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -5897,7 +5897,7 @@ else
|
||||
@@ -5919,7 +5919,7 @@ else
|
||||
# statically. But if the user explicitly specified the libraries to
|
||||
# use, trust that they are doing what they want.
|
||||
if test "$poststage1_libs" = ""; then
|
||||
|
@ -25,14 +25,14 @@ gdb/ChangeLog:
|
||||
gdb/common/signals-state-save-restore.c | 2 +-
|
||||
2 files changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/gdb/common/signals-state-save-restore.c
|
||||
+++ b/gdb/common/signals-state-save-restore.c
|
||||
@@ -41,7 +41,7 @@ save_original_signals_state (bool quiet)
|
||||
--- a/gdbsupport/signals-state-save-restore.cc
|
||||
+++ b/gdbsupport/signals-state-save-restore.cc
|
||||
@@ -38,7 +38,7 @@ save_original_signals_state (bool quiet)
|
||||
int i;
|
||||
int res;
|
||||
|
||||
- res = sigprocmask (0, NULL, &original_signal_mask);
|
||||
+ res = sigprocmask (SIG_BLOCK, NULL, &original_signal_mask);
|
||||
- res = gdb_sigmask (0, NULL, &original_signal_mask);
|
||||
+ res = gdb_sigmask (SIG_BLOCK, NULL, &original_signal_mask);
|
||||
if (res == -1)
|
||||
perror_with_name (("sigprocmask"));
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/gdb/dwarf-index-write.c
|
||||
+++ b/gdb/dwarf-index-write.c
|
||||
@@ -701,7 +701,7 @@ public:
|
||||
--- a/gdb/dwarf2/index-write.c
|
||||
+++ b/gdb/dwarf2/index-write.c
|
||||
@@ -777,7 +777,7 @@ public:
|
||||
gdb_assert (m_abbrev_table.empty ());
|
||||
const size_t name_count = m_name_to_value_set.size ();
|
||||
m_bucket_table.resize
|
||||
|
Loading…
x
Reference in New Issue
Block a user