mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-19 11:16:32 +00:00
mediatek: add missing 5.10 patches
These patches are required for the Ubiquiti UniFi 6 LR to work. They were already present for kernel 5.4 but got lost when adding 5.10 support. Signed-off-by: David Bauer <mail@david-bauer.net>
This commit is contained in:
parent
dfa0a38d1f
commit
024c81adb8
@ -0,0 +1,28 @@
|
|||||||
|
From: David Bauer <mail@david-bauer.net>
|
||||||
|
To: linux-mtd@lists.infradead.org
|
||||||
|
Subject: [PATCH] mtd: spi-nor: add support for Winbond W25Q512JV
|
||||||
|
Date: Sat, 13 Feb 2021 16:10:47 +0100
|
||||||
|
|
||||||
|
The Winbond W25Q512JV is a 512mb SPI-NOR chip. It supports 4K
|
||||||
|
sectors as well as block protection and Dual-/Quad-read.
|
||||||
|
|
||||||
|
Tested on: Ubiquiti UniFi 6 LR
|
||||||
|
|
||||||
|
Signed-off-by: David Bauer <mail@david-bauer.net>
|
||||||
|
---
|
||||||
|
drivers/mtd/spi-nor/winbond.c | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
--- a/drivers/mtd/spi-nor/winbond.c
|
||||||
|
+++ b/drivers/mtd/spi-nor/winbond.c
|
||||||
|
@@ -95,6 +95,10 @@ static const struct flash_info winbond_p
|
||||||
|
SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
|
||||||
|
{ "w25q256jw", INFO(0xef6019, 0, 64 * 1024, 512,
|
||||||
|
SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
|
||||||
|
+ { "w25q512jv", INFO(0xef4020, 0, 64 * 1024, 1024,
|
||||||
|
+ SECT_4K | SPI_NOR_QUAD_READ | SPI_NOR_DUAL_READ |
|
||||||
|
+ SPI_NOR_HAS_TB | SPI_NOR_TB_SR_BIT6 |
|
||||||
|
+ SPI_NOR_HAS_LOCK | SPI_NOR_4BIT_BP) },
|
||||||
|
{ "w25m512jv", INFO(0xef7119, 0, 64 * 1024, 1024,
|
||||||
|
SECT_4K | SPI_NOR_QUAD_READ | SPI_NOR_DUAL_READ) },
|
||||||
|
};
|
@ -0,0 +1,29 @@
|
|||||||
|
--- a/drivers/leds/Kconfig
|
||||||
|
+++ b/drivers/leds/Kconfig
|
||||||
|
@@ -928,6 +928,16 @@ config LEDS_ACER_A500
|
||||||
|
This option enables support for the Power Button LED of
|
||||||
|
Acer Iconia Tab A500.
|
||||||
|
|
||||||
|
+config LEDS_UBNT_LEDBAR
|
||||||
|
+ tristate "LED support for Ubiquiti UniFi 6 LR"
|
||||||
|
+ depends on LEDS_CLASS && I2C && OF
|
||||||
|
+ help
|
||||||
|
+ This option enables support for the Ubiquiti LEDBAR
|
||||||
|
+ LED driver.
|
||||||
|
+
|
||||||
|
+ To compile this driver as a module, choose M here: the module
|
||||||
|
+ will be called leds-ubnt-ledbar.
|
||||||
|
+
|
||||||
|
comment "LED Triggers"
|
||||||
|
source "drivers/leds/trigger/Kconfig"
|
||||||
|
|
||||||
|
--- a/drivers/leds/Makefile
|
||||||
|
+++ b/drivers/leds/Makefile
|
||||||
|
@@ -93,6 +93,7 @@ obj-$(CONFIG_LEDS_TURRIS_OMNIA) += leds
|
||||||
|
obj-$(CONFIG_LEDS_WM831X_STATUS) += leds-wm831x-status.o
|
||||||
|
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
|
||||||
|
obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
|
||||||
|
+obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
|
||||||
|
|
||||||
|
# LED SPI Drivers
|
||||||
|
obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o
|
Loading…
Reference in New Issue
Block a user