mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-31 16:35:44 +00:00
omcproxy: switch to OpenWrt github repo
Switch to OpenWrt github repo in PKG_SOURCE_URL so we can remove the out of tree patch Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
3c04d10483
commit
0074a5e67e
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=omcproxy
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE_URL:=https://github.com/sbyx/omcproxy.git
|
||||
PKG_SOURCE_URL:=https://github.com/openwrt/omcproxy.git
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_DATE:=2017-02-14
|
||||
PKG_SOURCE_VERSION:=1fe6f48f8a5067685cbcf6427baf1b3e8b889da1
|
||||
PKG_MIRROR_HASH:=b5a5e09149bd08a945ada8a29a30c3e42834524747d7fd0911717f5a0ec59c72
|
||||
PKG_SOURCE_DATE:=2018-12-14
|
||||
PKG_SOURCE_VERSION:=722151f04348cf1b759613c087bced52fb45790a
|
||||
PKG_MIRROR_HASH:=4d218923c149e2dc9010b8932ea92ab7e06f30df06814ffedaba7e081f2d4640
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 721064f2eb1dabe5bda63dcaff249b73ab891e6c Mon Sep 17 00:00:00 2001
|
||||
From: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
||||
Date: Fri, 14 Dec 2018 15:13:41 -0200
|
||||
Subject: [PATCH] mrib.c: don't use cpu_to_be32 outside of function
|
||||
|
||||
cpu_to_be32 is not a constant, so it can't be used outside of a
|
||||
function.
|
||||
|
||||
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
||||
|
||||
--- a/src/mrib.c
|
||||
+++ b/src/mrib.c
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
+#include <endian.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <unistd.h>
|
||||
@@ -54,7 +55,13 @@ struct mrib_iface {
|
||||
struct uloop_timeout timer;
|
||||
};
|
||||
|
||||
-static uint32_t ipv4_rtr_alert = cpu_to_be32(0x94040000);
|
||||
+/* we can't use cpu_to_be32 outside a function */
|
||||
+#if __BYTE_ORDER == __BIG_ENDIAN
|
||||
+static uint32_t ipv4_rtr_alert = 0x94040000;
|
||||
+#else
|
||||
+static uint32_t ipv4_rtr_alert = 0x00000494;
|
||||
+#endif
|
||||
+
|
||||
static struct {
|
||||
struct ip6_hbh hdr;
|
||||
struct ip6_opt_router rt;
|
Loading…
x
Reference in New Issue
Block a user