mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-19 04:47:52 +00:00
98bc4decde
Signed-off-by: Alexey Neyman <stilor@att.net>
631 lines
20 KiB
Diff
631 lines
20 KiB
Diff
This patch fixes another configure test issue when bootstrapping.
|
|
sysdeps/i386/configure.in uses the obsolete AC_HEADER_CHECK macro to
|
|
test for cpuid.h, and that macro tries to include various other
|
|
standard headers (which come from the library, unlike cpuid.h which
|
|
comes from the compiler, so aren't available when bootstrapping) in
|
|
the test code it compiles. This patch changes the code to use
|
|
AC_CHECK_HEADER, with the fourth argument used to prevent any default
|
|
includes being used in the test.
|
|
|
|
Tested x86_64 (native).
|
|
|
|
2012-03-07 Joseph Myers <joseph@codesourcery.com>
|
|
|
|
* sysdeps/i386/configure.in (cpuid.h): Use AC_CHECK_HEADER with no
|
|
default includes instead of AC_HEADER_CHECK.
|
|
* sysdeps/i386/configure: Regenerated.
|
|
|
|
Origin: http://sourceware.org/ml/libc-alpha/2012-03/msg00177.html
|
|
|
|
---
|
|
sysdeps/i386/configure | 502 +---------------------------------------------
|
|
sysdeps/i386/configure.in | 5
|
|
2 files changed, 17 insertions(+), 490 deletions(-)
|
|
|
|
--- a/sysdeps/i386/configure
|
|
+++ b/sysdeps/i386/configure
|
|
@@ -16,23 +16,6 @@
|
|
as_fn_set_status $1
|
|
exit $1
|
|
} # as_fn_exit
|
|
-# as_fn_arith ARG...
|
|
-# ------------------
|
|
-# Perform arithmetic evaluation on the ARGs, and store the result in the
|
|
-# global $as_val. Take advantage of shells that can avoid forks. The arguments
|
|
-# must be portable across $(()) and expr.
|
|
-if (eval "test \$(( 1 + 1 )) = 2") 2>/dev/null; then :
|
|
- eval 'as_fn_arith ()
|
|
- {
|
|
- as_val=$(( $* ))
|
|
- }'
|
|
-else
|
|
- as_fn_arith ()
|
|
- {
|
|
- as_val=`expr "$@" || test $? -eq 1`
|
|
- }
|
|
-fi # as_fn_arith
|
|
-
|
|
if expr a : '\(a\)' >/dev/null 2>&1 &&
|
|
test "X`expr 00001 : '.*\(...\)'`" = X001; then
|
|
as_expr=expr
|
|
@@ -89,6 +72,10 @@
|
|
chmod +x "$as_me.lineno" ||
|
|
{ $as_echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2; as_fn_exit 1; }
|
|
|
|
+ # If we had to re-execute with $CONFIG_SHELL, we're ensured to have
|
|
+ # already done that, so ensure we don't try to do so again and fall
|
|
+ # in an infinite loop. This has already happened in practice.
|
|
+ _as_can_reexec=no; export _as_can_reexec
|
|
# Don't try to exec as it changes $[0], causing all sort of problems
|
|
# (the dirname of $[0] is not the place where we might find the
|
|
# original and so on. Autoconf is especially sensitive to this).
|
|
@@ -97,42 +84,6 @@
|
|
exit
|
|
}
|
|
|
|
-# Factoring default headers for most tests.
|
|
-ac_includes_default="\
|
|
-#include <stdio.h>
|
|
-#ifdef HAVE_SYS_TYPES_H
|
|
-# include <sys/types.h>
|
|
-#endif
|
|
-#ifdef HAVE_SYS_STAT_H
|
|
-# include <sys/stat.h>
|
|
-#endif
|
|
-#ifdef STDC_HEADERS
|
|
-# include <stdlib.h>
|
|
-# include <stddef.h>
|
|
-#else
|
|
-# ifdef HAVE_STDLIB_H
|
|
-# include <stdlib.h>
|
|
-# endif
|
|
-#endif
|
|
-#ifdef HAVE_STRING_H
|
|
-# if !defined STDC_HEADERS && defined HAVE_MEMORY_H
|
|
-# include <memory.h>
|
|
-# endif
|
|
-# include <string.h>
|
|
-#endif
|
|
-#ifdef HAVE_STRINGS_H
|
|
-# include <strings.h>
|
|
-#endif
|
|
-#ifdef HAVE_INTTYPES_H
|
|
-# include <inttypes.h>
|
|
-#endif
|
|
-#ifdef HAVE_STDINT_H
|
|
-# include <stdint.h>
|
|
-#endif
|
|
-#ifdef HAVE_UNISTD_H
|
|
-# include <unistd.h>
|
|
-#endif"
|
|
-
|
|
|
|
# ac_fn_c_try_compile LINENO
|
|
# --------------------------
|
|
@@ -167,177 +118,11 @@
|
|
|
|
ac_retval=1
|
|
fi
|
|
- eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
|
+ eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
|
|
as_fn_set_status $ac_retval
|
|
|
|
} # ac_fn_c_try_compile
|
|
|
|
-# ac_fn_c_try_cpp LINENO
|
|
-# ----------------------
|
|
-# Try to preprocess conftest.$ac_ext, and return whether this succeeded.
|
|
-ac_fn_c_try_cpp ()
|
|
-{
|
|
- as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
|
|
- if { { ac_try="$ac_cpp conftest.$ac_ext"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
|
|
-$as_echo "$ac_try_echo"; } >&5
|
|
- (eval "$ac_cpp conftest.$ac_ext") 2>conftest.err
|
|
- ac_status=$?
|
|
- if test -s conftest.err; then
|
|
- grep -v '^ *+' conftest.err >conftest.er1
|
|
- cat conftest.er1 >&5
|
|
- mv -f conftest.er1 conftest.err
|
|
- fi
|
|
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
- test $ac_status = 0; } >/dev/null && {
|
|
- test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- }; then :
|
|
- ac_retval=0
|
|
-else
|
|
- $as_echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- ac_retval=1
|
|
-fi
|
|
- eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
|
- as_fn_set_status $ac_retval
|
|
-
|
|
-} # ac_fn_c_try_cpp
|
|
-
|
|
-# ac_fn_c_check_header_mongrel LINENO HEADER VAR INCLUDES
|
|
-# -------------------------------------------------------
|
|
-# Tests whether HEADER exists, giving a warning if it cannot be compiled using
|
|
-# the include files in INCLUDES and setting the cache variable VAR
|
|
-# accordingly.
|
|
-ac_fn_c_check_header_mongrel ()
|
|
-{
|
|
- as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
|
|
- if eval "test \"\${$3+set}\"" = set; then :
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $2" >&5
|
|
-$as_echo_n "checking for $2... " >&6; }
|
|
-if eval "test \"\${$3+set}\"" = set; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-fi
|
|
-eval ac_res=\$$3
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
|
|
-$as_echo "$ac_res" >&6; }
|
|
-else
|
|
- # Is the header compilable?
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking $2 usability" >&5
|
|
-$as_echo_n "checking $2 usability... " >&6; }
|
|
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-$4
|
|
-#include <$2>
|
|
-_ACEOF
|
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
|
- ac_header_compiler=yes
|
|
-else
|
|
- ac_header_compiler=no
|
|
-fi
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_header_compiler" >&5
|
|
-$as_echo "$ac_header_compiler" >&6; }
|
|
-
|
|
-# Is the header present?
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking $2 presence" >&5
|
|
-$as_echo_n "checking $2 presence... " >&6; }
|
|
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-#include <$2>
|
|
-_ACEOF
|
|
-if ac_fn_c_try_cpp "$LINENO"; then :
|
|
- ac_header_preproc=yes
|
|
-else
|
|
- ac_header_preproc=no
|
|
-fi
|
|
-rm -f conftest.err conftest.$ac_ext
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_header_preproc" >&5
|
|
-$as_echo "$ac_header_preproc" >&6; }
|
|
-
|
|
-# So? What about this header?
|
|
-case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in #((
|
|
- yes:no: )
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: accepted by the compiler, rejected by the preprocessor!" >&5
|
|
-$as_echo "$as_me: WARNING: $2: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: proceeding with the compiler's result" >&5
|
|
-$as_echo "$as_me: WARNING: $2: proceeding with the compiler's result" >&2;}
|
|
- ;;
|
|
- no:yes:* )
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: present but cannot be compiled" >&5
|
|
-$as_echo "$as_me: WARNING: $2: present but cannot be compiled" >&2;}
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: check for missing prerequisite headers?" >&5
|
|
-$as_echo "$as_me: WARNING: $2: check for missing prerequisite headers?" >&2;}
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: see the Autoconf documentation" >&5
|
|
-$as_echo "$as_me: WARNING: $2: see the Autoconf documentation" >&2;}
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: section \"Present But Cannot Be Compiled\"" >&5
|
|
-$as_echo "$as_me: WARNING: $2: section \"Present But Cannot Be Compiled\"" >&2;}
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: $2: proceeding with the compiler's result" >&5
|
|
-$as_echo "$as_me: WARNING: $2: proceeding with the compiler's result" >&2;}
|
|
- ;;
|
|
-esac
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $2" >&5
|
|
-$as_echo_n "checking for $2... " >&6; }
|
|
-if eval "test \"\${$3+set}\"" = set; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- eval "$3=\$ac_header_compiler"
|
|
-fi
|
|
-eval ac_res=\$$3
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
|
|
-$as_echo "$ac_res" >&6; }
|
|
-fi
|
|
- eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
|
-
|
|
-} # ac_fn_c_check_header_mongrel
|
|
-
|
|
-# ac_fn_c_try_run LINENO
|
|
-# ----------------------
|
|
-# Try to link conftest.$ac_ext, and return whether this succeeded. Assumes
|
|
-# that executables *can* be run.
|
|
-ac_fn_c_try_run ()
|
|
-{
|
|
- as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
|
|
- if { { ac_try="$ac_link"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
|
|
-$as_echo "$ac_try_echo"; } >&5
|
|
- (eval "$ac_link") 2>&5
|
|
- ac_status=$?
|
|
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
- test $ac_status = 0; } && { ac_try='./conftest$ac_exeext'
|
|
- { { case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval ac_try_echo="\"\$as_me:${as_lineno-$LINENO}: $ac_try_echo\""
|
|
-$as_echo "$ac_try_echo"; } >&5
|
|
- (eval "$ac_try") 2>&5
|
|
- ac_status=$?
|
|
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
- test $ac_status = 0; }; }; then :
|
|
- ac_retval=0
|
|
-else
|
|
- $as_echo "$as_me: program exited with status $ac_status" >&5
|
|
- $as_echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- ac_retval=$ac_status
|
|
-fi
|
|
- rm -rf conftest.dSYM conftest_ipa8_conftest.oo
|
|
- eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
|
- as_fn_set_status $ac_retval
|
|
-
|
|
-} # ac_fn_c_try_run
|
|
-
|
|
# ac_fn_c_check_header_compile LINENO HEADER VAR INCLUDES
|
|
# -------------------------------------------------------
|
|
# Tests whether HEADER exists and can be compiled using the include files in
|
|
@@ -347,7 +132,7 @@
|
|
as_lineno=${as_lineno-"$1"} as_lineno_stack=as_lineno_stack=$as_lineno_stack
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $2" >&5
|
|
$as_echo_n "checking for $2... " >&6; }
|
|
-if eval "test \"\${$3+set}\"" = set; then :
|
|
+if eval \${$3+:} false; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
@@ -365,275 +150,16 @@
|
|
eval ac_res=\$$3
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
|
|
$as_echo "$ac_res" >&6; }
|
|
- eval $as_lineno_stack; test "x$as_lineno_stack" = x && { as_lineno=; unset as_lineno;}
|
|
+ eval $as_lineno_stack; ${as_lineno_stack:+:} unset as_lineno
|
|
|
|
} # ac_fn_c_check_header_compile
|
|
# This file is generated from configure.in by Autoconf. DO NOT EDIT!
|
|
# Local configure fragment for sysdeps/i386.
|
|
|
|
|
|
-
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for grep that handles long lines and -e" >&5
|
|
-$as_echo_n "checking for grep that handles long lines and -e... " >&6; }
|
|
-if test "${ac_cv_path_GREP+set}" = set; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- if test -z "$GREP"; then
|
|
- ac_path_GREP_found=false
|
|
- # Loop through the user's path and test for each of PROGNAME-LIST
|
|
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
|
-for as_dir in $PATH$PATH_SEPARATOR/usr/xpg4/bin
|
|
-do
|
|
- IFS=$as_save_IFS
|
|
- test -z "$as_dir" && as_dir=.
|
|
- for ac_prog in grep ggrep; do
|
|
- for ac_exec_ext in '' $ac_executable_extensions; do
|
|
- ac_path_GREP="$as_dir/$ac_prog$ac_exec_ext"
|
|
- { test -f "$ac_path_GREP" && $as_test_x "$ac_path_GREP"; } || continue
|
|
-# Check for GNU ac_path_GREP and select it if it is found.
|
|
- # Check for GNU $ac_path_GREP
|
|
-case `"$ac_path_GREP" --version 2>&1` in
|
|
-*GNU*)
|
|
- ac_cv_path_GREP="$ac_path_GREP" ac_path_GREP_found=:;;
|
|
-*)
|
|
- ac_count=0
|
|
- $as_echo_n 0123456789 >"conftest.in"
|
|
- while :
|
|
- do
|
|
- cat "conftest.in" "conftest.in" >"conftest.tmp"
|
|
- mv "conftest.tmp" "conftest.in"
|
|
- cp "conftest.in" "conftest.nl"
|
|
- $as_echo 'GREP' >> "conftest.nl"
|
|
- "$ac_path_GREP" -e 'GREP$' -e '-(cannot match)-' < "conftest.nl" >"conftest.out" 2>/dev/null || break
|
|
- diff "conftest.out" "conftest.nl" >/dev/null 2>&1 || break
|
|
- as_fn_arith $ac_count + 1 && ac_count=$as_val
|
|
- if test $ac_count -gt ${ac_path_GREP_max-0}; then
|
|
- # Best one so far, save it but keep looking for a better one
|
|
- ac_cv_path_GREP="$ac_path_GREP"
|
|
- ac_path_GREP_max=$ac_count
|
|
- fi
|
|
- # 10*(2^10) chars as input seems more than enough
|
|
- test $ac_count -gt 10 && break
|
|
- done
|
|
- rm -f conftest.in conftest.tmp conftest.nl conftest.out;;
|
|
-esac
|
|
-
|
|
- $ac_path_GREP_found && break 3
|
|
- done
|
|
- done
|
|
- done
|
|
-IFS=$as_save_IFS
|
|
- if test -z "$ac_cv_path_GREP"; then
|
|
- as_fn_error $? "no acceptable grep could be found in $PATH$PATH_SEPARATOR/usr/xpg4/bin" "$LINENO" 5
|
|
- fi
|
|
-else
|
|
- ac_cv_path_GREP=$GREP
|
|
-fi
|
|
-
|
|
-fi
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_path_GREP" >&5
|
|
-$as_echo "$ac_cv_path_GREP" >&6; }
|
|
- GREP="$ac_cv_path_GREP"
|
|
-
|
|
-
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for egrep" >&5
|
|
-$as_echo_n "checking for egrep... " >&6; }
|
|
-if test "${ac_cv_path_EGREP+set}" = set; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- if echo a | $GREP -E '(a|b)' >/dev/null 2>&1
|
|
- then ac_cv_path_EGREP="$GREP -E"
|
|
- else
|
|
- if test -z "$EGREP"; then
|
|
- ac_path_EGREP_found=false
|
|
- # Loop through the user's path and test for each of PROGNAME-LIST
|
|
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
|
|
-for as_dir in $PATH$PATH_SEPARATOR/usr/xpg4/bin
|
|
-do
|
|
- IFS=$as_save_IFS
|
|
- test -z "$as_dir" && as_dir=.
|
|
- for ac_prog in egrep; do
|
|
- for ac_exec_ext in '' $ac_executable_extensions; do
|
|
- ac_path_EGREP="$as_dir/$ac_prog$ac_exec_ext"
|
|
- { test -f "$ac_path_EGREP" && $as_test_x "$ac_path_EGREP"; } || continue
|
|
-# Check for GNU ac_path_EGREP and select it if it is found.
|
|
- # Check for GNU $ac_path_EGREP
|
|
-case `"$ac_path_EGREP" --version 2>&1` in
|
|
-*GNU*)
|
|
- ac_cv_path_EGREP="$ac_path_EGREP" ac_path_EGREP_found=:;;
|
|
-*)
|
|
- ac_count=0
|
|
- $as_echo_n 0123456789 >"conftest.in"
|
|
- while :
|
|
- do
|
|
- cat "conftest.in" "conftest.in" >"conftest.tmp"
|
|
- mv "conftest.tmp" "conftest.in"
|
|
- cp "conftest.in" "conftest.nl"
|
|
- $as_echo 'EGREP' >> "conftest.nl"
|
|
- "$ac_path_EGREP" 'EGREP$' < "conftest.nl" >"conftest.out" 2>/dev/null || break
|
|
- diff "conftest.out" "conftest.nl" >/dev/null 2>&1 || break
|
|
- as_fn_arith $ac_count + 1 && ac_count=$as_val
|
|
- if test $ac_count -gt ${ac_path_EGREP_max-0}; then
|
|
- # Best one so far, save it but keep looking for a better one
|
|
- ac_cv_path_EGREP="$ac_path_EGREP"
|
|
- ac_path_EGREP_max=$ac_count
|
|
- fi
|
|
- # 10*(2^10) chars as input seems more than enough
|
|
- test $ac_count -gt 10 && break
|
|
- done
|
|
- rm -f conftest.in conftest.tmp conftest.nl conftest.out;;
|
|
-esac
|
|
-
|
|
- $ac_path_EGREP_found && break 3
|
|
- done
|
|
- done
|
|
- done
|
|
-IFS=$as_save_IFS
|
|
- if test -z "$ac_cv_path_EGREP"; then
|
|
- as_fn_error $? "no acceptable egrep could be found in $PATH$PATH_SEPARATOR/usr/xpg4/bin" "$LINENO" 5
|
|
- fi
|
|
-else
|
|
- ac_cv_path_EGREP=$EGREP
|
|
-fi
|
|
-
|
|
- fi
|
|
-fi
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_path_EGREP" >&5
|
|
-$as_echo "$ac_cv_path_EGREP" >&6; }
|
|
- EGREP="$ac_cv_path_EGREP"
|
|
-
|
|
-
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ANSI C header files" >&5
|
|
-$as_echo_n "checking for ANSI C header files... " >&6; }
|
|
-if test "${ac_cv_header_stdc+set}" = set; then :
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-#include <stdlib.h>
|
|
-#include <stdarg.h>
|
|
-#include <string.h>
|
|
-#include <float.h>
|
|
-
|
|
-int
|
|
-main ()
|
|
-{
|
|
-
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
|
- ac_cv_header_stdc=yes
|
|
-else
|
|
- ac_cv_header_stdc=no
|
|
-fi
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
-
|
|
-if test $ac_cv_header_stdc = yes; then
|
|
- # SunOS 4.x string.h does not declare mem*, contrary to ANSI.
|
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-#include <string.h>
|
|
-
|
|
-_ACEOF
|
|
-if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
|
|
- $EGREP "memchr" >/dev/null 2>&1; then :
|
|
-
|
|
-else
|
|
- ac_cv_header_stdc=no
|
|
-fi
|
|
-rm -f conftest*
|
|
-
|
|
-fi
|
|
-
|
|
-if test $ac_cv_header_stdc = yes; then
|
|
- # ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI.
|
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-#include <stdlib.h>
|
|
-
|
|
-_ACEOF
|
|
-if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
|
|
- $EGREP "free" >/dev/null 2>&1; then :
|
|
-
|
|
-else
|
|
- ac_cv_header_stdc=no
|
|
-fi
|
|
-rm -f conftest*
|
|
-
|
|
-fi
|
|
-
|
|
-if test $ac_cv_header_stdc = yes; then
|
|
- # /bin/cc in Irix-4.0.5 gets non-ANSI ctype macros unless using -ansi.
|
|
- if test "$cross_compiling" = yes; then :
|
|
- :
|
|
-else
|
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
|
-/* end confdefs.h. */
|
|
-#include <ctype.h>
|
|
-#include <stdlib.h>
|
|
-#if ((' ' & 0x0FF) == 0x020)
|
|
-# define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
|
|
-# define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
|
|
-#else
|
|
-# define ISLOWER(c) \
|
|
- (('a' <= (c) && (c) <= 'i') \
|
|
- || ('j' <= (c) && (c) <= 'r') \
|
|
- || ('s' <= (c) && (c) <= 'z'))
|
|
-# define TOUPPER(c) (ISLOWER(c) ? ((c) | 0x40) : (c))
|
|
-#endif
|
|
-
|
|
-#define XOR(e, f) (((e) && !(f)) || (!(e) && (f)))
|
|
-int
|
|
-main ()
|
|
-{
|
|
- int i;
|
|
- for (i = 0; i < 256; i++)
|
|
- if (XOR (islower (i), ISLOWER (i))
|
|
- || toupper (i) != TOUPPER (i))
|
|
- return 2;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-if ac_fn_c_try_run "$LINENO"; then :
|
|
-
|
|
-else
|
|
- ac_cv_header_stdc=no
|
|
-fi
|
|
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
|
|
- conftest.$ac_objext conftest.beam conftest.$ac_ext
|
|
-fi
|
|
-
|
|
-fi
|
|
-fi
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_header_stdc" >&5
|
|
-$as_echo "$ac_cv_header_stdc" >&6; }
|
|
-if test $ac_cv_header_stdc = yes; then
|
|
-
|
|
-$as_echo "#define STDC_HEADERS 1" >>confdefs.h
|
|
-
|
|
-fi
|
|
-
|
|
-# On IRIX 5.3, sys/types and inttypes.h are conflicting.
|
|
-for ac_header in sys/types.h sys/stat.h stdlib.h string.h memory.h strings.h \
|
|
- inttypes.h stdint.h unistd.h
|
|
-do :
|
|
- as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
|
-ac_fn_c_check_header_compile "$LINENO" "$ac_header" "$as_ac_Header" "$ac_includes_default
|
|
+ac_fn_c_check_header_compile "$LINENO" "cpuid.h" "ac_cv_header_cpuid_h" "/* No default includes. */
|
|
"
|
|
-if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
|
|
- cat >>confdefs.h <<_ACEOF
|
|
-#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
|
|
-_ACEOF
|
|
-
|
|
-fi
|
|
-
|
|
-done
|
|
-
|
|
-
|
|
-ac_fn_c_check_header_mongrel "$LINENO" "cpuid.h" "ac_cv_header_cpuid_h" "$ac_includes_default"
|
|
-if test "x$ac_cv_header_cpuid_h" = x""yes; then :
|
|
+if test "x$ac_cv_header_cpuid_h" = xyes; then :
|
|
|
|
else
|
|
as_fn_error $? "gcc must provide the <cpuid.h> header" "$LINENO" 5
|
|
@@ -643,7 +169,7 @@
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if -g produces usable source locations for assembler-with-cpp" >&5
|
|
$as_echo_n "checking if -g produces usable source locations for assembler-with-cpp... " >&6; }
|
|
-if test "${libc_cv_cpp_asm_debuginfo+set}" = set; then :
|
|
+if ${libc_cv_cpp_asm_debuginfo+:} false; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
cat > conftest.S <<EOF
|
|
@@ -693,7 +219,7 @@
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for SSE4 support" >&5
|
|
$as_echo_n "checking for SSE4 support... " >&6; }
|
|
-if test "${libc_cv_cc_sse4+set}" = set; then :
|
|
+if ${libc_cv_cc_sse4+:} false; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
if { ac_try='${CC-cc} -msse4 -xc /dev/null -S -o /dev/null'
|
|
@@ -716,7 +242,7 @@
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for assembler -mtune=i686 support" >&5
|
|
$as_echo_n "checking for assembler -mtune=i686 support... " >&6; }
|
|
-if test "${libc_cv_as_i686+set}" = set; then :
|
|
+if ${libc_cv_as_i686+:} false; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
if { ac_try='${CC-cc} -Wa,-mtune=i686 -xc /dev/null -S -o /dev/null'
|
|
@@ -735,7 +261,7 @@
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for AVX support" >&5
|
|
$as_echo_n "checking for AVX support... " >&6; }
|
|
-if test "${libc_cv_cc_avx+set}" = set; then :
|
|
+if ${libc_cv_cc_avx+:} false; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
if { ac_try='${CC-cc} -mavx -xc /dev/null -S -o /dev/null'
|
|
@@ -758,7 +284,7 @@
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -mno-vzeroupper support" >&5
|
|
$as_echo_n "checking for -mno-vzeroupper support... " >&6; }
|
|
-if test "${libc_cv_cc_novzeroupper+set}" = set; then :
|
|
+if ${libc_cv_cc_novzeroupper+:} false; then :
|
|
$as_echo_n "(cached) " >&6
|
|
else
|
|
if { ac_try='${CC-cc} -mno-vzeroupper -xc /dev/null -S -o /dev/null'
|
|
--- a/sysdeps/i386/configure.in
|
|
+++ b/sysdeps/i386/configure.in
|
|
@@ -1,8 +1,9 @@
|
|
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
|
|
# Local configure fragment for sysdeps/i386.
|
|
|
|
-AC_HEADER_CHECK([cpuid.h], ,
|
|
- [AC_MSG_ERROR([gcc must provide the <cpuid.h> header])])
|
|
+AC_CHECK_HEADER([cpuid.h], ,
|
|
+ [AC_MSG_ERROR([gcc must provide the <cpuid.h> header])],
|
|
+ [/* No default includes. */])
|
|
|
|
AC_CACHE_CHECK(if -g produces usable source locations for assembler-with-cpp,
|
|
libc_cv_cpp_asm_debuginfo, [dnl
|