crosstool-ng/packages/make/4.2.1/0000-glob-v2.patch
Alexey Neyman 6ad79d8932 Add globbing patches to make from upstream
Fixes #1004.

Signed-off-by: Alexey Neyman <stilor@att.net>
2018-09-28 11:47:57 -07:00

40 lines
1.1 KiB
Diff

commit 48c8a116a914a325a0497721f5d8b58d5bba34d4
Author: Paul Smith <psmith@gnu.org>
Date: Sun Nov 19 15:09:16 2017 -0500
* configure.ac: Support GLIBC glob interface version 2
---
configure | 3 +--
configure.ac | 3 +--
2 files changed, 2 insertions(+), 4 deletions(-)
--- a/configure.ac
+++ b/configure.ac
@@ -399,10 +399,9 @@
#include <glob.h>
#include <fnmatch.h>
-#define GLOB_INTERFACE_VERSION 1
#if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
# include <gnu-versions.h>
-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
+# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
gnu glob
# endif
#endif],
--- a/configure
+++ b/configure
@@ -11481,10 +11481,9 @@
#include <glob.h>
#include <fnmatch.h>
-#define GLOB_INTERFACE_VERSION 1
#if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
# include <gnu-versions.h>
-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
+# if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
gnu glob
# endif
#endif