mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-19 21:07:54 +00:00
931b37a405
Forward ported patches from version 2.32, and refreshed them so they apply clean. Signed-off-by: Hans-Christian Noren Egtvedt <hegtvedt@cisco.com>
106 lines
2.5 KiB
Diff
106 lines
2.5 KiB
Diff
---
|
|
binutils/configure | 3 +++
|
|
binutils/configure.ac | 3 +++
|
|
gas/configure | 3 +++
|
|
gas/configure.ac | 3 +++
|
|
ld/configure | 3 +++
|
|
ld/configure.ac | 3 +++
|
|
6 files changed, 18 insertions(+)
|
|
|
|
--- a/binutils/configure
|
|
+++ b/binutils/configure
|
|
@@ -12449,6 +12449,7 @@ fi
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -12612,6 +12613,8 @@ esac
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
|
|
# If we haven't got the data from the intl directory,
|
|
--- a/binutils/configure.ac
|
|
+++ b/binutils/configure.ac
|
|
@@ -86,7 +86,10 @@ if test -z "$host" ; then
|
|
fi
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
|
|
ZW_GNU_GETTEXT_SISTER_DIR
|
|
--- a/gas/configure
|
|
+++ b/gas/configure
|
|
@@ -13469,6 +13469,7 @@ fi
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -13632,6 +13633,8 @@ esac
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
|
|
# If we haven't got the data from the intl directory,
|
|
--- a/gas/configure.ac
|
|
+++ b/gas/configure.ac
|
|
@@ -893,7 +893,10 @@ AC_DEFINE_UNQUOTED(TARGET_VENDOR, "${tar
|
|
AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}", [Target OS.])
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
|
|
ZW_GNU_GETTEXT_SISTER_DIR
|
|
--- a/ld/configure
|
|
+++ b/ld/configure
|
|
@@ -16537,6 +16537,7 @@ fi
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -16700,6 +16701,8 @@ esac
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
|
|
--- a/ld/configure.ac
|
|
+++ b/ld/configure.ac
|
|
@@ -243,7 +243,10 @@ AM_PO_SUBDIRS
|
|
AC_EXEEXT
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
AM_MAINTAINER_MODE
|
|
AM_CONDITIONAL(GENINSRC_NEVER, false)
|