crosstool-ng/packages/zlib/1.2.12/0000-mingw-static-only.patch
Chris Packham dd4d19fce2 zlib: Update to zlib-1.2.12
Bring in the following changes

- Fix a deflate bug when using the Z_FIXED strategy that can result in
  out-of-bound accesses.
- Fix a deflate bug when the window is full in deflate_stored().
- Speed up CRC-32 computations by a factor of 1.5 to 3.
- Use the hardware CRC-32 instruction on ARMv8 processors.
- Speed up crc32_combine() with powers of x tables.
- Add crc32_combine_gen() and crc32_combine_op() for fast combines.

Drop two patches that have been applied upstream and regenerate the
remaining two.

Fixes #1708

Signed-off-by: Chris Packham <judge.packham@gmail.com>
2022-04-22 10:15:41 +12:00

29 lines
930 B
Diff

---
win32/Makefile.gcc | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
--- a/win32/Makefile.gcc
+++ b/win32/Makefile.gcc
@@ -66,7 +66,11 @@
gzwrite.o infback.o inffast.o inflate.o inftrees.o trees.o uncompr.o zutil.o
OBJA =
-all: $(STATICLIB) $(SHAREDLIB) $(IMPLIB) example.exe minigzip.exe example_d.exe minigzip_d.exe
+all: $(STATICLIB) example.exe minigzip.exe
+
+ifeq ($(SHARED_MODE),1)
+all: $(SHAREDLIB) $(IMPLIB) example_d.exe minigzip_d.exe
+endif
test: example.exe minigzip.exe
./example
@@ -120,7 +124,7 @@
.PHONY: install uninstall clean
install: zlib.h zconf.h $(STATICLIB) $(IMPLIB)
- @if test -z "$(DESTDIR)$(INCLUDE_PATH)" -o -z "$(DESTDIR)$(LIBRARY_PATH)" -o -z "$(DESTDIR)$(BINARY_PATH)"; then \
+ @if test -z "$(INCLUDE_PATH)" -o -z "$(LIBRARY_PATH)" -o -z "$(BINARY_PATH)"; then \
echo INCLUDE_PATH, LIBRARY_PATH, and BINARY_PATH must be specified; \
exit 1; \
fi