crosstool-ng/packages/glibc/2.14.1/140-disable-ldconfig.patch
Alexey Neyman f8d4ce3d0e Implement a script for checking packages
Then use this script to check that all packages can be extracted and patched.

Signed-off-by: Alexey Neyman <stilor@att.net>
2017-08-23 16:05:40 -07:00

17 lines
677 B
Diff

do not bother running ldconfig on DESTDIR. it wants to write the temp cache
file outside of the chroot. doesnt matter anyways as we wont use the cache
results (portage will rebuild cache), so running ldconfig is simply a waste
of time.
diff -durN glibc-2.13.orig/Makefile glibc-2.13/Makefile
--- glibc-2.13.orig/Makefile 2009-04-23 20:23:03.000000000 +0200
+++ glibc-2.13/Makefile 2009-11-13 00:49:49.000000000 +0100
@@ -116,6 +116,7 @@
rm -f $(symbolic-link-list)
install:
+dont-bother-with-destdir:
-test ! -x $(common-objpfx)elf/ldconfig || LC_ALL=C LANGUAGE=C \
$(common-objpfx)elf/ldconfig $(addprefix -r ,$(install_root)) \
$(slibdir) $(libdir)