mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-19 12:57:53 +00:00
07594d1e8b
Signed-off-by: Alexey Neyman <stilor@att.net>
46 lines
1.7 KiB
Diff
46 lines
1.7 KiB
Diff
---
|
|
gdb/gdbserver/configure | 11 -----------
|
|
gdb/gdbserver/configure.ac | 11 -----------
|
|
2 files changed, 22 deletions(-)
|
|
|
|
--- a/gdb/gdbserver/configure
|
|
+++ b/gdb/gdbserver/configure
|
|
@@ -7699,17 +7699,6 @@
|
|
|
|
|
|
case "${target}" in
|
|
- *-android*)
|
|
- # Starting with NDK version 9, <elf.h> actually includes definitions
|
|
- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
|
|
- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
|
|
- # leading to conflicts with the defintions from <linux/elf.h>.
|
|
- # This makes it impossible for us to include both <elf.h> and
|
|
- # <linux/elf.h>, which means that, in practice, we do not have
|
|
- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
|
|
- # Therefore, do not try to auto-detect availability, as it would
|
|
- # get it wrong on this platform.
|
|
- ;;
|
|
*)
|
|
ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
|
|
|
|
--- a/gdb/gdbserver/configure.ac
|
|
+++ b/gdb/gdbserver/configure.ac
|
|
@@ -185,17 +185,6 @@
|
|
])
|
|
|
|
case "${target}" in
|
|
- *-android*)
|
|
- # Starting with NDK version 9, <elf.h> actually includes definitions
|
|
- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
|
|
- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
|
|
- # leading to conflicts with the defintions from <linux/elf.h>.
|
|
- # This makes it impossible for us to include both <elf.h> and
|
|
- # <linux/elf.h>, which means that, in practice, we do not have
|
|
- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
|
|
- # Therefore, do not try to auto-detect availability, as it would
|
|
- # get it wrong on this platform.
|
|
- ;;
|
|
*)
|
|
AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
|
|
#include <elf.h>
|