mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-28 08:38:53 +00:00
98bc4decde
Signed-off-by: Alexey Neyman <stilor@att.net>
81 lines
1.7 KiB
Diff
81 lines
1.7 KiB
Diff
---
|
|
PATCHES | 1 +
|
|
VERSION | 2 +-
|
|
configure | 3 +++
|
|
configure.in | 3 +++
|
|
mpfr-impl.h | 6 ++++++
|
|
mpfr.h | 2 +-
|
|
version.c | 2 +-
|
|
7 files changed, 16 insertions(+), 3 deletions(-)
|
|
|
|
--- a/PATCHES
|
|
+++ b/PATCHES
|
|
@@ -1,2 +1,3 @@
|
|
+gmp5
|
|
longlong.h
|
|
sin_cos_underflow
|
|
--- a/VERSION
|
|
+++ b/VERSION
|
|
@@ -1 +1 @@
|
|
-2.4.2-p2
|
|
+2.4.2-p3
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -20449,6 +20449,9 @@
|
|
main ()
|
|
{
|
|
|
|
+#ifndef BITS_PER_MP_LIMB
|
|
+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
|
|
+#endif
|
|
return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
|
|
&& sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
|
|
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -424,6 +424,9 @@
|
|
#include "gmp.h"
|
|
#include "gmp-impl.h"
|
|
]], [[
|
|
+#ifndef BITS_PER_MP_LIMB
|
|
+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
|
|
+#endif
|
|
return BITS_PER_MP_LIMB == BYTES_PER_MP_LIMB * CHAR_BIT
|
|
&& sizeof(mp_limb_t) == BYTES_PER_MP_LIMB ? 0 : 1;
|
|
]])], [AC_MSG_RESULT(yes)], [
|
|
--- a/mpfr-impl.h
|
|
+++ b/mpfr-impl.h
|
|
@@ -65,6 +65,12 @@
|
|
# ifndef __GMP_IMPL_H__
|
|
# include "gmp-impl.h"
|
|
# endif
|
|
+# ifndef BITS_PER_MP_LIMB
|
|
+# define BITS_PER_MP_LIMB GMP_LIMB_BITS
|
|
+# endif
|
|
+#ifndef mpn_sqr_n
|
|
+# define mpn_sqr_n mpn_sqr
|
|
+#endif
|
|
# ifdef MPFR_NEED_LONGLONG_H
|
|
# include "longlong.h"
|
|
# endif
|
|
--- a/mpfr.h
|
|
+++ b/mpfr.h
|
|
@@ -27,7 +27,7 @@
|
|
#define MPFR_VERSION_MAJOR 2
|
|
#define MPFR_VERSION_MINOR 4
|
|
#define MPFR_VERSION_PATCHLEVEL 2
|
|
-#define MPFR_VERSION_STRING "2.4.2-p2"
|
|
+#define MPFR_VERSION_STRING "2.4.2-p3"
|
|
|
|
/* Macros dealing with MPFR VERSION */
|
|
#define MPFR_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
|
|
--- a/version.c
|
|
+++ b/version.c
|
|
@@ -25,5 +25,5 @@
|
|
const char *
|
|
mpfr_get_version (void)
|
|
{
|
|
- return "2.4.2-p2";
|
|
+ return "2.4.2-p3";
|
|
}
|