crosstool-ng/packages/ltrace/0.7.3/0000-avoid-libstdc++.patch
Alexey Neyman 98bc4decde Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
2017-12-02 12:44:39 -08:00

49 lines
962 B
Diff

From: Juan Cespedes <cespedes@debian.org>
Description: avoid warning from dpkg-shlibdeps:
package could avoid a useless dependency if ltrace was not
linked against libstdc++.so.6 (it uses none of the library's symbols)
Last-Update: 2013-12-30
---
configure | 9 +++++++++
configure.ac | 9 +++++++++
2 files changed, 18 insertions(+)
--- a/configure.ac
+++ b/configure.ac
@@ -113,6 +113,15 @@
libstdcxx_LIBS=""])
AC_SUBST(libstdcxx_LIBS)
+if test "x$liberty_LIBS" != "x"
+then
+ libsupcxx_LIBS=""
+ libstdcxx_LIBS=""
+elif test "x$libsupcxx_LIBS" != "x"
+then
+ libstdcxx_LIBS=""
+fi
+
dnl Check security_get_boolean_active availability.
AC_CHECK_HEADERS(selinux/selinux.h)
--- a/configure
+++ b/configure
@@ -11750,6 +11750,15 @@
+if test "x$liberty_LIBS" != "x"
+then
+ libsupcxx_LIBS=""
+ libstdcxx_LIBS=""
+elif test "x$libsupcxx_LIBS" != "x"
+then
+ libstdcxx_LIBS=""
+fi
+
for ac_header in selinux/selinux.h
do :