mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-19 12:57:53 +00:00
66ad1ff514
android-ndk, binutils, gcc, linux, mpfr, ncurses, newlib, uclibc-ng MPC vs MPFR dependencies required modifications in auto-generated templates to also provide non-inclusive older-than/newer-than specifications. Also correct MPC URLs, the website seems to have adjusted its directory layout. Currently, newlib 3.0.0 doesn't build for arm-nano-eabi. Signed-off-by: Alexey Neyman <stilor@att.net>
106 lines
2.3 KiB
Diff
106 lines
2.3 KiB
Diff
---
|
|
binutils/configure | 3 +++
|
|
binutils/configure.ac | 3 +++
|
|
gas/configure | 3 +++
|
|
gas/configure.ac | 3 +++
|
|
ld/configure | 3 +++
|
|
ld/configure.ac | 3 +++
|
|
6 files changed, 18 insertions(+)
|
|
|
|
--- a/binutils/configure
|
|
+++ b/binutils/configure
|
|
@@ -12150,6 +12150,7 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -12311,6 +12312,8 @@
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="bg da es fi fr id it ja ro ru rw sk sv tr uk vi zh_CN zh_TW hr ca"
|
|
# If we haven't got the data from the intl directory,
|
|
--- a/binutils/configure.ac
|
|
+++ b/binutils/configure.ac
|
|
@@ -87,7 +87,10 @@
|
|
fi
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="bg da es fi fr id it ja ro ru rw sk sv tr uk vi zh_CN zh_TW hr ca"
|
|
ZW_GNU_GETTEXT_SISTER_DIR
|
|
--- a/gas/configure
|
|
+++ b/gas/configure
|
|
@@ -13003,6 +13003,7 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -13164,6 +13165,8 @@
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="fr tr es rw id ru fi ja zh_CN sv"
|
|
# If we haven't got the data from the intl directory,
|
|
--- a/gas/configure.ac
|
|
+++ b/gas/configure.ac
|
|
@@ -795,7 +795,10 @@
|
|
AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}", [Target OS.])
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="fr tr es rw id ru fi ja zh_CN sv"
|
|
ZW_GNU_GETTEXT_SISTER_DIR
|
|
--- a/ld/configure
|
|
+++ b/ld/configure
|
|
@@ -16222,6 +16222,7 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -16383,6 +16384,8 @@
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
|
|
--- a/ld/configure.ac
|
|
+++ b/ld/configure.ac
|
|
@@ -234,7 +234,10 @@
|
|
AC_EXEEXT
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
AM_MAINTAINER_MODE
|
|
AM_CONDITIONAL(GENINSRC_NEVER, false)
|